Jump to content
PLC Forum

Riccardo Ottaviucci

Acer 560 - file mancante all'avvio di windows

Recommended Posts

Riccardo Ottaviucci

stamattina i pochi capelli rimasti hanno avuto un sussulto!

All'avvio di window (XP home SP3) sul pc domestico è comparso l'allarme:

"reinstallare il file ntokrnl.exe in sistem32"

Premendo invio il caricamento sembra procedere ma poi stesso avviso.

Ho premuto F8 ed il pc è ripartito e sembra funzionare regolarmente.

Premetto che l'altro ieri e ieri l'avvio era diventato lentissimo così come tutte le funzioni anche non online.

Ieri gli ho fatto una pulizia del registro con RegistryBoot ,cosa che faccio periodicamente e senza mai alcun problema.

Ha trovato 49 errori che ha corretto,dopo il backup del registro stesso.

In effetti il pc ha ritrovato la sua normale funzionalità.

Ieri l'ho utilizzato fino a mezzanotte .

Stamane la sorpresa.

Non ho il cd di window XP home SP3,l'ho acquistato da Mediaworld,pur avendo il codice di attivazione.

Forse ho un cd di ripristino che creai a suo tempo,ma non sono sicuro,forse confondo il pc.

Ho visto che il file ntoskrnl.exe è presente in questo pc dell'ufficio (che ha XP professional) .

Potrei copiarlo nel mio o rischio di dover formattare tutto sul serio?

Edited by Riccardo Ottaviucci
Link to post
Share on other sites

miro.exe

Ciao, puoi metterti il file mancante su FlashDrive USB, poi parti con un LiveCD(tipo BartPE UBCD o Linux), e trasferisci il file dalla Flash al tuo HDD.

Link to post
Share on other sites
Riccardo Ottaviucci

Ciao e grazie per la risposta.

Solo che non ho capito perchè devo partire con un LiveCd (che non so cosa sia tra l'altro) se ho il pc già in funzione.La directory indicata è Sistem32 sotto window senzasperanza.gif

Link to post
Share on other sites
miro.exe

Ma... forse ho interpretato male il tuo messaggio, mi pareva di aver capito che non caricava più il sistema operativo o non completava l'avvio, quindi non operabile...il Live CD serve quando il sistema operativo non completa il caricamento neanche in provvisoria.

Be, non ti rimane altro che inserire il file che ti manca rolleyes.gif

Link to post
Share on other sites
Riccardo Ottaviucci
miro.exe+20/10/2010, 11:40--> (miro.exe @ 20/10/2010, 11:40)

ok,grazie,però mi interessa la storia del CDlive.E' il cd del sistema operativo XP(che non ho) o qualcosa che è disponibile gia pronto ,magari scaricandolo ,da qualche parte?

Link to post
Share on other sites
Riccardo Ottaviucci

grazie miro,nel frattempo mi sono fatto un DVD di ripristino sfruttando l'utility e-recovery della Acer,precaricata col s.o.

Ho appurato che il problema non è software,ma hardware e non so se continuare qui o aprire una discussione nuova nell'altra sezione.

Eventualmente il moderatore di sezione (io qui sono fuori confini biggrin.gif )valuterà e lo farà se crede.

Dicevo che ho verificato che il problema del mancato avvio di windows XP è solo a freddo,e se lo spengo dopo gli allarmi riparte ,anche se ogni giorno stenta sempre più.

Quindi credo che l'hard-disk stia per lasciarmi o forse l'alimentatore.

Gli allarmi che compaino sono:

a disk error reading occours,press ctrl-alt-del to restart

se premo ctrl-alt-del per resettarlo allora mi compare :

il file ntoskrnl.exe è corrotto o mancante.

Premo l'interruttore finchè non si spegne e poi riparto e 2 volte su 3 riparte senza problemi.

Mi compro un hard disk esterno e faccio il back con True image prima di cominciare a bestemmiare in turco? rolleyes.gif

Link to post
Share on other sites
Tommaso Uva

Riccardo non ci sono problemi, possiamo continuare benissimanete qua, non vedo ancora troppo dardware in giro biggrin.gif .

Comuque leggendo del tuo problema, non sono completamente sicuro che sia un problema hardware, anche se il disco potrebbe essere usurato il tuo problema penso che risieda ntoskrnl, è il file che gestisce l'avvio e il boot screen del sistema operativo ed è stato causa spesso di problemi similari al tuo.

Questo è un articolo Microsoft ufficiale su come cercare di ristabilire il tutto, prova non si sa mai e ci riesci.

Ovviamente prima di tutto fatti un bel backup o immagine, se il disco ti decidesse precocemente di lasciarti, almeno sei preparato rolleyes.gif

Ciao

Edited by Tommaso Uva
Link to post
Share on other sites
Riccardo Ottaviucci

Grazie Tommy,molto interessante clap.gif ti terrò aggiornato

Link to post
Share on other sites
miro.exe

Riccardo, fra i link che ti ho postato, il primo, ti scarichi l'iso, ti prepari il CD, poi fai il boot dal CD, vedi che li ci sono vari tools per diagnosticare la macchina, tra cui ram e e hard disk...magari dopo fatto i controlli suggeriti da Tommaso, se ancora non dovesse andare, puoi provare con quel CD autopartente.

Saluti

Link to post
Share on other sites
Riccardo Ottaviucci

ciao Miro,grazie ancora per i consigli.

Nel frattempo ho fatto un chkdsk/r come suggerito nel 4° punto di microsoft.

Ci ha messo quasi 45 minuti,ma non ha trovato nulla.

Per colmo di sf..ortuna poco dopo c'è stato un black-out ( sono senza ups perchè guasto) sad.gif

E il pc non solo non è partito subito ma quando c'è riuscito (dopo un paio di on-off) mi ha cominciato a dare allarmi di firme non autentiche su alcuni programmi,quali outlook express,e pur aprendo le pagine internet iniziali, non voleva saperne di navigare.

Nel frattempo è partita anche la scansione schedulata dell'antivirus (una volta al mese),che ho preferito far terminare.

Io ho l'avg free,non ha trovato nulla se non le solite firme non autorizzate di alcuni programmi,tra l'altro mai usati,mah!

Dopo un riavvio da pannello è finalmente partito a caldo al primo colpo e sembra non dare problemi per adesso,ma credo che a freddo non riparta più lo stesso.

Proverò a scaricare il soft che mi hai consigliato,ma devo sbrigarmi a comprare un hd esterno (non posso usare quello dell'ufficio:rolleyes: )

Se non ci sentiamo vuol dire che il pc non è più ripartito laugh.gif

Ps.: azz,sono 300mB di roba,quasi un film,con la mia adls da 3° mondo mi ci vorrà una giornata,provo a farlo con torrent

Una domanda :non è che il cd mi altera il file system installato rischiando di non ripartire più col sistema originale?

Edited by Riccardo Ottaviucci
Link to post
Share on other sites
Tommaso Uva

Certo anche su sei cosi fortunato che mentri stai facendo un'operazione cosi delicata va via la corrente e sei anche sprovvisto di ups.. wallbash.gif

Sfortuna su sfortuna, come si dice al mio paese "lu can mozzeca sempe alu strazzat" traduzione: il cane morde sempre il poverello biggrin.gif .

Ciao

Link to post
Share on other sites
Riccardo Ottaviucci

ho finito adesso di masterizzare l'iso di ultimate boot cd.

però lo provo domani,non vorrei fare le ore piccole e domani alle 6 sveglia sad.gif

Buona notte ad entrambi per ora.

p.s.:

il mio dialetto è piuttosto simile," lu cane moccica sempre lu poerittu" laugh.gif

Edited by Riccardo Ottaviucci
Link to post
Share on other sites
miro.exe

Riccardo, se a freddo non dovesse funzionare correttamente, probabile che ci può essere un problema di alimentazione, magari dai un sguardo all'interno del PC, se noti dei condensatori elettrolitici deformati(gonfi) sulla piastra madre o nell'alimentatore, la causa del mal funzionamento a freddo, la puoi imputare a loro.

Saluti.

Link to post
Share on other sites
Riccardo Ottaviucci
miro.exe+28/10/2010, 10:10--> (miro.exe @ 28/10/2010, 10:10)

infatti secondo me il problema è hardware,però se dovessi scegliere tra HD e PS scelgo il secondo... laugh.gif

Anche stamane dopo un paio di tentativi è ripartito dry.gif

Link to post
Share on other sites
Riccardo Ottaviucci

ben trovati

addirittura dopo averlo portato in laboratorio e avergli tolto la polvere con il compressore,non ha voluto più sapere nemmeno di accendersi.

E' bastato aprire il PS per vedere un elettrolitico da 1000uF sul primario abbastanza gonfio.

Anche sulla Mobo ,vicino alla batteria del bios,ce n'era uno da 1000uF ingrossato.

Sostituiti entrambi.

Inutile dire che ora il pc si avvia silenziosamente (ventole al minimo,prima urlavano) in 1,5 minuti (prima ne impiegava almeno il doppio) e soprattutto senza allarmi.

Non solo, ma dovrebbe essere sparito un difetto che ogni tanto capitava di RESUME delle impostazioni BIOS anche con batteria nuova (condensatore sulla Mobo).

Se continua così mi ritengo graziato laugh.gif

C'è in questo forum la sezione Guasti Pc risolti? biggrin.gif

Grazie ancora a Tommy e a Miro per la dritta vincente. worthy.gif

Link to post
Share on other sites
Tommaso Uva

Menomale che ogni tanto ci prendiamo la nostra rivincità sulla tecnologia.rolleyes.gif

Contentissimo che hai risolto il problema.

A presto

Link to post
Share on other sites
miro.exe

Macchè grazie...figurati, grazie a te che hai messo in pratica i nostri consigli...è stato un piacere wink.gif

Lunga vita al tuo PC laugh.gif

Saluti.

Link to post
Share on other sites
Riccardo Ottaviucci
miro.exe+28/10/2010, 19:28--> (miro.exe @ 28/10/2010, 19:28)

in effetti è di mia moglie,ma me ne sono appropriato essendo più potente del mio... laugh.gif

Link to post
Share on other sites
Tommaso Uva

Allora attento Riccardo, tua moglie per concedertelo vuol dire che punta a ricevere il nuovo.

Lo donne non sono nuove a questi trabocchetti tongue.gif

Ciao

Link to post
Share on other sites
Riccardo Ottaviucci
Tommaso Uva+29/10/2010, 10:30--> (Tommaso Uva @ 29/10/2010, 10:30)

infatti,vuole un portatile,ma le uniche cose che sa farci è scaricare la posta,navigare e giocarci a Burraco e quindi mi sembrano soldi buttati laugh.gif

Link to post
Share on other sites
miro.exe

Be, ogni tanto il regalo alla signora bisogna pur farlo...potrebbe iniziare a trattarti male...ti mette in astinenza laugh.gif

Fra un pò arriva Natale...quale occasione migliore wink.gif

Link to post
Share on other sites
Riccardo Ottaviucci
miro.exe+2/11/2010, 11:42--> (miro.exe @ 2/11/2010, 11:42)

ha sfasciato la macchina,niente regalo mad.gif

Link to post
Share on other sites
miro.exe

Pensa positivo...le macchine si aggiustano, si comprano...l'importante è che nessuno si sia fatto male smile.gif

Link to post
Share on other sites
Riccardo Ottaviucci
miro.exe+4/11/2010, 11:31--> (miro.exe @ 4/11/2010, 11:31)

be',il motociclista che è caduto stava meglio prima,per fortuna portava il casco e ha subito solo ammaccature ...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...