Jump to content
PLC Forum


Sign in to follow this  
Bledar Kthupi

Bullard Con Cnc Num760 Problemi Di Comunicaziome Con L'esterno.

Recommended Posts

Bledar Kthupi

Buongiorno a tutti e buona pasquetta.

Nella officina dove lavoro da poco abbiamo un tornio verticale vecchiotto ma molto robusto della Bullard USA dottato di CNC Num760. Fino a qualche tempo fa, i problemi legati alla scomodita' della programmazione da bordo macchina gli avevano bypassato collegando la macchina a un pc e trasmettendo i programmi in macchina tramite cavo dati. Questo, fino a qualche tempo fa'...

Ora, i ragazzi mi dicono che la macchina negli ultimi tempi ( prima che andasse fuori uso anche il pc) riusciva a mandare su pc i programmi ma non riusciva a ricevere da pc e quindi si e' tornati a programmare a bordo macchina e cio' che e' peggio, avendo poca memoria a disposizione si e' costretti a cancellare in continuazione programmi prima di scriverne altri.

Vorrei poterli aiutare a risolvere il problema ma non ho idea da dove partire. Potreste aiutarmi ? Grazie.

Share this post


Link to post
Share on other sites

Livio Orsini

Presumo che il collegamento con PC avvenga in seriale RS232.

Se è così il problema probabilemente è dovuto ad un guasto di questa interfaccia.

Se è una macchina vecchia sarà realizzata con componenti tradizionali e non smd.

Segui il percorso dalla porta di comunicazione sino ad incontrare l'integrato di interfaccia.

Share this post


Link to post
Share on other sites
Bledar Kthupi

Ciao Livio. La macchina e' vecchia e il CNC pure. Non ho capito molto cio' che hai scritto (scusami ma sono davvero impreparato in materia). Potrei allegare delle foto e magari mi potreste indicare con piu precisione dove cercare il guasto? Mi hanno suggerito che il tecnico che tempo fa ha messo appunto il gestionale e lo scanner con il quale apriamo e chiudiamo le comesse con un codice a barre, gli aveva dato un occhiata e aveva presuposto che forse ce un guasto nella scheda del PLC. Da qui che e' partita la mia ricerca sulle PLC per capire qualcosa di piu' e mi sono imbattuto nel vostro forum. Grazie comunque.

Edited by Bledar Kthupi

Share this post


Link to post
Share on other sites
lucios

In questi casi la prima cosa che faccio è controllare il cavo, non si sa mai...

Comunque se si tratta di un guasto sulla scheda Num, lascia perdere. L'unica cosa che puoi fare è sostituirla se ne trovi una rigenerata in internet o direttamente da Num Italia.

Se non mi ricordo male, ma non vorrei confondermi con il modello successivo 1060, la seriale era messa sulla scheda chiamata "PROCESS" che, nel cestello di solito è la prima a destra, accanto all'alimentatore.

Se magari posti una foto del cestello posso indicarti dove è collegato il cavo seriale.

Ciao

Share this post


Link to post
Share on other sites
Bledar Kthupi

Buonasera !

Ho fatto controllare il cavo ed è risultato sano, ho acceso il pc che non si accendeva da mesi e anche quello è risultato funzionante. Domani mattina farò provare la comunicazione con la macchina al mio collega che l'ha sempre usato.

Intanto, vi posto una foto della scattola del armadio elettrico da dove parte il cavo che poi finisce sul PC.

Attendo fiducioso vostri suggerimenti. Grazie mille comunque e complimenti per le vostre competenze.

Bledar.


dd04ae5bc12bd61ba70d7b10c91d6bd7.jpg

Share this post


Link to post
Share on other sites
lucios

Che programma usano per comunicare?

Anni fa esisteva un programma fatto da Num stessa che mi pare si chiamasse Numcomm. Lo usavo a volte per verificare che la comunicazione funzionasse.

Adesso non l'ho più purtroppo (in effetti diciamo che non l'ho trovato...), altrimenti te lo postavo (tanto si tratta di abandonware). Comunque penso che se telefoni in Num e chiedi te lo possono mandare.

Mi ricordo però che funzionava in dos o in finestra dos sotto XP, con i nuovi Windows non so...

Share this post


Link to post
Share on other sites
Bledar Kthupi

Ciao,

Confermo tutto, CNC e PC comunicano tra loro grazie a questo programma della NUM stessa. Acceso il PC e collegato la CNC e messa in ricezione, abbiamo provato a trasmettere dal PC un programma che avevamo già usato su quel CNC e mentre sul PC spunta una banda che diventa tutta blu e mi informa che ha terminato la trasmissione, sul CNC continua a lampeggiare per dirmi che è in ricezione ma non spunta nulla. Mi è venuto in mente che può dipendere dal boudrate e sono andato a controllare anche quello sui parametri del programma su PC. Era impostato su 9600. Sul controllo non sono riuscito a trovare la paginata dove viene nominato il boudrate. Quindi, situazione di stallo di nuovo. Suggerimenti ?!!! Come fate di solito per ridurre i kbyte di una foto prima di postarla sul forum ?

Grazie mille.

P:S.

Per gli amanti dei prototipi, su un forum dedicato alle lavorazioni e alle macchine CNC, discuttono da un po di tempo sul progetto di una stampante 3D. Gente davvero in gamba, come voi. Mi siete venuti in mente mentre leggevo le loro discussioni sulla scheda di PLC e al tipo di macchina CNC dove poter applicare la testina della stampante 3D.

Buona serata.

Edited by Giuseppe Signorella

Share this post


Link to post
Share on other sites
lucios

Il baudrate si setta mediante quei 2 commutatori rotativi rossi presenti sul frontalino della scheda process.

Share this post


Link to post
Share on other sites
Bledar Kthupi

Controllato anche il boudrate di macchina ed e' sul 9.6 kB quindi...

Se vi scrivo la sigla della scheda potreste aiutarmi a reperirla rigenerata o nuova su internet? Credete che ci possa essere qualche nuova verifica che potrei fare prima di cambiare la scheda ? Grazie.

Share this post


Link to post
Share on other sites
lucios

Mi è venuto un dubbio rileggendo la discussione: ma la procedura di carico viene effettuata correttamente? Perchè tu parli di qualcosa che lampeggia ma mi pare di ricordare che occorre mettere in modalità input il cnc con l'apposito tasto, quindi premere start ciclo e startare il pc. Quale pulsante ti lampeggia?

Edited by lucios

Share this post


Link to post
Share on other sites
Bledar Kthupi

La procedura è questa:

Tasto input

Seleziono ricevimento

Premo enter

Premo start

Il tasto start rimane luce fissa fino al ricevimento dati.

Ricevuti i dati il tasto start si dovrebbe spegnere,nel nostro caso la luce rimane fissa come in attesa di ricevimento.

Sul pc invece risultano inviati i dati.

Non saprei cos'altro fare... Tra altro questa e' una procedura gia' usata diverse volte in passato e funzionava!!!

Grazie.

Share this post


Link to post
Share on other sites
Werner

Ciao,

per il 760 uso APA10

e l'haware della foto in allegto, non sbaglia un colpo (e scrivendolo .. mi tocco)

e48a1650a09c6361098945ad472175d8.jpg

Share this post


Link to post
Share on other sites
Bledar Kthupi

Mi fa molto piacere per te. Il mio problema non e' quello di scoprire a come far comunicare il pc con il CNC ma trovare il guasto per il quale non comunicano piu' come prima! Tutto qui...

Buona serata.

Share this post


Link to post
Share on other sites
lucios

La procedura è corretta. Hai parlato anche di una sostituzione del pc e, giusto per riepilogare: con il pc attuale e il cavo attuale prima funzionava e ha smesso da un giorno all'altro senza toccare nulla, ho capito bene? Se è così non resta che provare sostituire la scheda. Se decidi di provare (e trovi una scheda uguale) ti ricordo che su di essa c'è montata una schedina con le EEPROM del sistema operativo che devi togliere dalla vecchia e rimontare sulla nuova.

Se non te la senti potresti provare a chiamare il service Num, non conosco le tariffe, ma sono sicuro che forniscono ancora assistenza anche sui CNC vecchi.

Giusto per parlare:

E pensare ad una soluzione radicale? Cioè un bel revamping della macchina sostituendo il CNC con uno nuovo, magari sempre un Num così la programmazione pezzo rimane pressochè compatibile.

Se la macchina meccanicamente "regge" e la tua ditta pensa di utilizzarla ancora per un po' di anni potrebbe avere un senso.

Lo so che è un'idea un pò estrema per rimediare solo ad un problema di seriale, ma considera che le schede Num di quell'epoca stanno diventando sempe più difficili da reperire e rischiate di rimanere fermi per giorni a causa di un qualsiasi altro guasto hardware.

Ciao

Share this post


Link to post
Share on other sites
Werner

Se e' rotta la scheda o la sai aggiustare o chiami la Num o qualcuno che ci lavora, che te la cambia e ti fa delle prove.

Prima prova a trovare un pc molto vecchio, caricaci APA10 e prova i trasferimenti.


io provavo con shell di dos, Dosbox, etc, talvolta riuscivo, talvolta no.

Con PC Dos puro, va sempre tutto.

Share this post


Link to post
Share on other sites
Bledar Kthupi

Ciao. La macchina e' vecchia ( tornio verticale Bullard con 1680 di mandrino ) ma robusta. Tempi duri per investimenti grossi. Le migliorerie che avevo in mente di effetuare erano appunto il ripristino del collegamento con il pc velocizzando cosi la programazione e aggiungendo anche la possibilita' di caricare programmi fatti con il Cam e la modifica della flangia di attacco alla Ram,(con una predisposta per gli utensili con l'attacco Captor )per poter montare e smontare velocemente utensili gia pressetati fuori macchina. Ora sto cercando un elettronico in zona che possa con costi limitati aiutarmi a trovare il guasto. Grazie comunque.

P.S. Provero' l'idea del PC in versione Dos.

Share this post


Link to post
Share on other sites
Bledar Kthupi

Il fatto che da CNC a PC i programmi si riescono a mandare invece viceversa no, può essere una indicazione che il problema non e' nella scheda PLC ?

Grazie ancora...

Share this post


Link to post
Share on other sites
Livio Orsini

Può essere che sia rotto il canale di ricezione della porta; le vecchie porte RS232 eran abbastanza "permalose" con i disturbi.

Share this post


Link to post
Share on other sites
lucios

Le prove da fare sono quelle che probabilmente hai già fatto e cioè:

- Controllare il cavo. Potresti provare con un cavo semplice a 3 fili: RX, TX e GND. Cavallottando RTS e CTS.

- Provare su 2 pc diversi. A questo proposito è giusto quello che ti ha detto Werner, mi ha fatto ricordare che anch'io ho avuto problemi con i vecchi programmi di comunicazione fatti per DOS fatti girare sotto Windows.

Se tutto ciò non da risultati, direi che il colpevole potrebbe effettivamente essere la scheda Num.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...