Jump to content
PLC Forum


comunicazione con tsxnano


fbf99
 Share

Recommended Posts

CON PL-07 V4.0 e cavo TSXPCX1031 non riesco a collegarmi a un TSX 07 21 2412  V:2.4

il plc è usato, alimentandolo si accende solo il led err lampeggiante.

grazie x una eventuale risposta e buona serata a tutti

Link to comment
Share on other sites


buonasera, ma non passa proprio nessuno da quì?

un aiutino x favore ?

non c'è nessuno all'altezza ? Troppo vecchio ?

disturbo ?

grazie comunque.

Link to comment
Share on other sites

Sollecitare non serve, anzi è anche poco simpatico.

Se, e solo se, c'è chi legge la discussione sa, può e vuole rispondere avrai la risposta, altrimenti porta pazienza.

Il forum non è un call center aziendale o un centro di assistenza a pagamento dove si può pretendere delle risposte.

Poi, come ben sai, si tratta di un PLC del secolo scorso, non più in uso, quindi ci sono pochi utenti del forum che ne hanno dimestichezza

Link to comment
Share on other sites

Giuseppe Signorella

Ma come si può pretendere di ricevere un aiuto se non si da un minimo di informazioni indispensabili per poter fare una qualunque di ipotesi?

Su che sistema operativo hai installato Il software PL707?

Che indirizzo hai assegnato nel software per connettersi al PLC?

La porta com è quella corretta?

Che errore ti viene restituito?

 

Link to comment
Share on other sites

Buonasera, si PL707 è installato indirizzo e porta sono giusti , questo pc viene ( veniva ) usato solo x programmare plc telemecanique di quell'epoca .

il pc mi dice errore di connessione, il mio pensiero è che il plc sia rovinato perchè all'accensione non si accende niente se non il led err lampeggiante.

dal manuale leggo che il led err lampeggia a significare errore di applicazione.

Vista l'età e la difficoltà ad avere più informazioni credo mi convenga buttarlo e sostituirlo con uno che conosco meglio.

Scusate se Vi ho fatto perdere tempo, non volevo comunque essere insistente, speravo che essendo sul settore schneider ci fosse qualcuno che si ricordava del nano.

Ciao a tutti e di nuovo buona serata.

Link to comment
Share on other sites

Giuseppe Signorella

Non è una perdita di tempo, solo che non sempre si ha la possibilità di stare dinanzi al computer e poter rispondere.

 

Non hai comunque risposto alle domande che ti ho posto, 

Su che sistema operativo è installato il PL707?

Che indirizzo è indicato sul PL707?

Non è detto che sia il PLC difettoso, può essere anche il cavo.

Quel medesimo cavo va bene per comunicare con il TWIDO, se hai un PLC Twido, prova a verificare se il cavo funziona regolarmente.

Il led error lampeggiante, può significare semplicemente che il PLC è senza programma.

Può essere che il PLC veniva utilizzato come modulo slave.

Il commutatore rotativo degli indirizzi (posto sotto lo sportellino), su che posizione si trova?

Ne ho un paio in ufficio, se mi riesce domani faccio una prova.

 

Link to comment
Share on other sites

Ciao , il PL707 è instalato su windows xp , l'indirizzo 0.254.0.

il cavo l'ho appena usato x un TSX37 con PL7 Pro installato sullo stesso pc e funziona

invece x il nano ho impostato su pl707 la porta su master uni-telway, 9600 bits/sec, il selettore sul cavo TSXPCX1031 pos2 che dovrebbe equivalere al cavo TSX PCU 1030

e poi mi fermo perchè quando cerco di fare il trasferimento o qualunque operazione x collegarmi mi esce errore di comunicazione , verificare il collegamento col plc e riprovare.

il nano non lo conosco ma mi sembra un po' antipatico

Ciao e grazie x l'aiuto comunque vada.

Marino.

Link to comment
Share on other sites

Ciao sul plc il commutatore è su 0 

il plc era di scorta da un cliente, teoricamente glielo avevano lasciato già programmato x futura sostituzione

ma ora che servirebbe non sembra funzionare

Di nuovo ciao e buona serata.

Marino

Link to comment
Share on other sites

Giuseppe Signorella

Come immaginavo.

Il problema è nel sistema operativo.

Il PL707 nasce per il win 95/98 e  gira sotto DOS

I driver di comunicazione (Nativi) del PL707 non  funzionano con windows XP.

Devi procurarti i driver "vado a memoria" del TXS micro.

In alternativa creati una macchina virtuale ed installaci windows 98. Se possibile la prima versione.

Il TSX Nano e quasi identico (equivalente) al TWIDO. Se hai il programma che risiede nel Nano, con pochissime modifiche puoi convertirlo per il TWIDO e fare un upgrade del sistema, che male non fà ;).

Ciao

Link to comment
Share on other sites

Con il controllore in allarme e difficile sapere se non comunica in quanto il plc ha dei problemi oppure e da inputare al software + cavo, se puoi devi provare a fare un collegamento con con un altro "nano" ed escludere che il pc  software e cavo sono ok, oppure devi collegarti in uscita sul cavo sulla porta con un data scoop e vede se vi sono delle richieste di interrogazione, diversamente diventa un pò difficile escludere uno o l'altro a priori.

 

Saluti

Link to comment
Share on other sites

Ciao, grazie a entrambi , farò come dite e vediamo se ne vengo fuori . L'unica cosa che non posso fare è provare con un altro nano perchè il mio cliente ha solo quel dinosauro.

Grazie ancora x l'aiuto e buona giornata.

Marino.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...