Jump to content
PLC Forum


Sign in to follow this  
And69

CN 840D premendo emergenza gli assi si fermano per inerzia

Recommended Posts

And69

Salve a tutti,

 

mi trovo a dover verificare un problema in una macchina fatta con il controllo 840D.
Non esendo molto pratico di CN chiedo se qualche gentile utente può darmi una dritta in merito, penso che il problema derivi da un collegamento elettrico errato.
La macchina è un palettizzatore con due assi x e z.
Il problema è che, da sempre quindi non sopraggiunto, premendo il pulsante di emergenza gli assi non sono più controllati e proseguono la corsa per inerzia a volte creando danni.
Si fermano quando intervengono i freni dei motori, ma questo dopo 1s circa (vedi modulo di sicurezza).
Nell'impianto elettrico c'è un modulo di sicurezza Pilz con dei contatti che si aprono immediatamente e altri che si aprono a tempo (1s circa).

Nello specifico nel modulo alimentatore:
Contato tra morsetto 64 e 9 (x121) si apre immediatamente.
Contato tra morsetto 63 e 9 (x121) si apre con ritardo.
Contato tra morsetto 9-112 e 48 (x161) si apre immediatamente.
Contato tra morsetto NS1 e NS1 (x171) si apre con ritardo.

Sui moduli drive:
Contato tra morsetto 663 e 9 (x431) si apre con ritardo.

Ho dei dubbi sul contatto 9-112 e 48 (x161) che si apre immediatamente, sulla documentazione trovata on-line non riesco bene a capire come dovrebbe essere qualcuno riesce a darmi qualche indicazione?

 

grazie

Share this post


Link to post
Share on other sites

evans

Se togli tensione completamente dovrebbe essere normale,

In ogni caso i morsetti corrispondono a:

  Sblocco impulsi

  Sblocco generale azionamenti

  Abilita Contattore interno

  Abilitazione

  Start

Se ritieni che sia un problema guarda la diagnostica 6 led cosa segnalano.

Ciao

Share this post


Link to post
Share on other sites
And69

grazie evans,

i 6 led li potrò vedere solo la prossima settimana, per il momento sto ragionando solo sugli schemi elettrici.

Quindi se ho capito bene, sia NS1-2 che 48 aprono il contattore interno nel drive e sezionano la parte di alimentazione dalla rete, il 48 lo fa indirettamente pilotando un transistor mentre i morsetti NS1 e NS2 lo fanno direttamente come consenso hardware in serie alla bobina.

Attualmente l'apertura del contattore avviene istantaneamente premendo il fungo di l'emergenza, il contattore si apre e l’alimentatore non può più rigenerare in rete e frenare gli assi.

Se ritardo il 48 (come NS1 e NS2) il contatore resta chiuso per 1 secondo in più. Allora, quando si preme l’emergenza si apre il 64 immediatamente e gli assi frenano potendo rigenerare e dopo un secondo si apre il contatore sezionando rete da parte alimentazione. Corretto il ragionamento?

Share this post


Link to post
Share on other sites
evans

Dunque:

Il morsetto 9 = +24vdc.

E' chiaro che se all'alimentatore in questo caso mancano i consensi ai morsetti 63,64,112, 48 e se manca il consenso

tra i morsetti NS1 e NS2, lo stesso non fornisce la potenza sulle barre per alimentare gli assi.

A quanto pare il problema si manifesta solo quando premi il pulsante di reset, a mio parere quando interviene

il reset devi portare a zero la velocita dei diver assi e poi inibire l'alimentatore. 

Visto che pare l'anomalia sia presente da sempre evidentemente c'è un problema di configurazione hardware iniziale.

Evidentemente inibendo immediatamente l'alimentatore i motori sono scollegati e si arrestano per inerzia.

 

Ciao.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...