Jump to content
PLC Forum


Sign in to follow this  
picluigi

Analizzatore Stati Logici in agonia.

Recommended Posts

picluigi

Buon giorno a tutti.

Oltre vent'anni fa ho acquistato un Analizzatore di Stati Logici  Kikusui DLG 7050 da una Ditta di Milano che da tempo quel marchio non tratta più.

Ha sempre funzionato correttamente ma da alcuni giorni, all'accensione dà un messaggio di errore [ERROR CB] che ne impedisce l'acquisizione dei segnali Parallelo evidenziando anche la scritta [HARD ERR]. Invece i segnali Seriali si possono acquisire.

Al proprio interno , oltre a una schede madre, zeppa di integrati TTL (oltre 150), ha anche tre schede innestate su connettore che portano le seguenti scritte:

1- C RTC

2- CPU

3- CLOCK AND THRESHOLD

Secondo una mia verifica, il problema sta nella terza scheda, la Clock and Threshold.

Al suo interno è montato un quarzo da 100MHz che tramite una rete parallela RLC fa capo ad un integrato HD 10116.

Ho notato che questo circuito con quarzo, non funziona. Al pin 3 dell' integrato dovrebbe uscire il segnale di clock, invece esce un segnale costante a 5Vcc. Allora l'ho sostituito con un altro. Non ho trovato l'HD 10116 ma l'MC 10116 che fa le stesse funzioni. Ma anche con questo nuovo integrato al pin3 esce come prima un segnale costante a 5Vcc.

La cosa mi ha incuriosito, per cui ho provato a ricostruire su breadboard lo stesso circuito utilizzando gli stessi componenti, tutti nuovi, quarzo compreso. Stesso risultato: al pin 3 esce il solito beffardo segnale a 5Vcc invece del segnale  sinusoidale del clock.

Allora pongo la domanda: quali devono essere le condizioni affinchè questo oscillatore possa funzionare?

Allego lo schema elettrico del circuito oscillatore ricavato dalla scheda 3 dell'Analizzatore.

Grazie a tutti per l'attenzione ed eventuali risposte.

 

A_S_Log7050.thumb.jpg.e68cfe778485c65cfe9d06c87a93a407.jpg

Edited by picluigi

Share this post


Link to post
Share on other sites

Livio Orsini

E un oscillatore quarzato piuttosto canonico.

Se l'integrato non è guasto ti restano pochi componenti quarzo, induttore, condensatore e resistore, oltre alle piste ed alle saldature.

Comincia con il sostituire il condensatore da 22 pF

Share this post


Link to post
Share on other sites
picluigi

Grazie Livio per il suggerimento. Devo però confessare una mia ingeniutà. Per rilevare a mezzo oscilloscopio il clock a 100MHz devo utilizzare uno strumento con banda passante di almeno il doppio. Ma il mio vecchio Philips ne ha una di soli 50MHz. Per forza che non vedo niente. Dovrei vedere un segnale piatto di zero Volt. Invece, e qui non capisco, ne vedo uno da 5Vcc. Un saluto.

Share this post


Link to post
Share on other sites
Livio Orsini
1 ora fa, picluigi scrisse:

Ma il mio vecchio Philips ne ha una di soli 50MHz. ........ Invece, e qui non capisco, ne vedo uno da 5Vcc. Un saluto.

 

Praticamente il tuo oscilloscopio lavora come un .... raddrizzatotre con filtro. Direi che è compatibile con il segnale e la banda di 50 MHz teorici.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...