Jump to content
PLC Forum


Robyrapi

Azionamento brushless

Recommended Posts

Robyrapi

Ciao a tutti ! Questo è il mio primo messaggio e vorrei ringraziare il forum per avermi accettato... mi chiamo Roberto e sono un manutentore elettromeccanico . Sono appassionato di elettronica ,ogni tanto faccio qualche esperimento con un plc omron e qualche azionamento Siemens.  Nel tempo libero mi diverto con un pantografo cnc 4 assi  autocostruito , vorrei chiedervi un aiuto per fare funzionare un azionamento Selema eco . Qualcuno li conosce ? Grazie !

Edited by Livio Orsini
modificato titolo da brashless a brushless(senza spazzole)
Link to post
Share on other sites

Livio Orsini
11 ore fa, Robyrapi ha scritto:

vorrei chiedervi un aiuto per fare funzionare un azionamento Selema eco .

 

metti anchen il modello, scrivendo il codice del prodotto, così se c'è chi conosce quell'azienda sa di cosa si tratta.

Link to post
Share on other sites
Robyrapi

Grazie Livio per L interesse ! Dunque , è la serie mini, cioè è un 220 V il modello è un Eco 2 Selema .  Ora è configurato per il funzionamento in Rete can Open, e funziona perfettamente con il suo motore abbinato. Se entro nella programmazione dal tastierino e imposto ingresso analogico , il motore entra in coppia e se alimento con 0:10 V il motore gira perfettamente piano /forte , e fino  qua ci siamo .... Il problema arriva quando seleziono la modalità a impulsi, che è quella che mi interessa ,

il motore entra in coppia ma portando un segnale pnp Step che esce dalla scheda cnc al motore ingresso pulse il motore non gira ,ma girano a me ! He he ... vabbe prima o poi capirò come fare . Spero ! Grazie per i consigli.

Link to post
Share on other sites
Nicola Carlotto

guarda se gli ingressi step e direzione non abbiano bisogno di polarizzazione e se ,magari, non siano npn  penso lo capresti dal manuale di collegamento

ciao

Link to post
Share on other sites
Robyrapi

Ciao Nicola ! Allego una foto del manuale che mostra il collegamento e precisa che gli ingressi sono pnp , la scheda Controller  ha uscite npn che ho convertito in pnp con il transistor bc327.

il segnale arriva giusto . Sul cn2 non ho collegato nulla.
 

DBE0FBFE-8A48-47B2-9C5B-DE536EEB5C65.png

Edited by Robyrapi
Aggiunto una precisazione
Link to post
Share on other sites
max.bocca

A me è successo con altri driver che non mi funzionava perché il duty cycle degli impulsi non erano accettati. (Impulsi troppo corti)

Riesci a fare una prova generando degli impulsi magari con un ne 555 se il driver fa girare il motore?

 

Link to post
Share on other sites
Robyrapi

Grazie Max ! Può essere una buona idea, devo vedere di comperarlo ma dubito che   le spedizioni siano veloci In questo periodo e muoversi è impossibile....visto che bisogna stare a casa volevo fare qualche experimentho.
provo ad allegare le foto dei parametri , io ho modificato il c9 , era a 5 l’ho portato a 1 per modalità impulsi .Magari sarà possibile fare una prova di questo tipo impostare ad esempio 1mm di rotazione ogni impulso ? Che parametro devo modificare ?
Forse così posso capire se il problema sta in qualche parametro sbagliato . Grazie ! 

7CE84085-D6DE-4600-8D83-1C52F697A699.png

5526D964-8D20-4D0D-B507-54C9571BF14C.png

12DB3AFC-4ECE-4C8B-A2AA-F571BB93093C.png

411A9F7A-83F0-43BC-843A-D3EF3245D237.png

Link to post
Share on other sites
max.bocca

??? C9 con descrizione se previsto come opzione.. cosa vuol dire che potrebbe non avere la possibilità di pilotare ad impulsi??

Link to post
Share on other sites
Robyrapi

c’è scritto in tutti come opzione... mi sembra strano non possa ricevere impulsi.    

Link to post
Share on other sites
Robyrapi

Ciao ! È un po’ che sono assente .... in tutto questo tempo ho riprovato a fare funzionare gli Azionamenti selema ma nulla di fatto , non sono adatti al mio controllo cnc . Ora però mi sono rimesso alla ricerca di altri azionamenti e mi sono capitati , perché li ho smantellati da un macchinario in disuso dei Mitsubishi mod

mr- e- 40 a - Qw 003 . Vorrei chiedervi se è possibile collegarli in Line Drive , come richiede il mio controllo, ci sono anche i motori già cablati... Grazie a tutti ! 

A4FA5200-FED7-48A8-A81A-BD67518D17A3.png

4FF8C2DA-23BE-401E-8535-F7A03079A9BB.jpeg

Link to post
Share on other sites
Livio Orsini

devi leggere cosa dice iol manuale di questo inverter che mi sembra un modello non attualissimo

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...