Jump to content
PLC Forum


Induzione E Pic - Disturbi induttivi e PIC


Capu
 Share

Recommended Posts

Ciao a tutti

Ho realizzato un circuito con una PIC 16F877 con display e 8 ingressi già fotoaccoppiati e 8 uscite con relè ,

due uscite mi comandano un motore monofase da 500w , ci sono in igresso dei finecorsa che fungono da stop per il motore .

Il mio problema e che ogni tanto il programma si resetta oppure si blocca , penso che siano distrurbi indutti !

Come posso fare per risolvere questo problema ?

Ciao

Link to comment
Share on other sites


Io per precauzione io uso fotoaccoppiatori anche in uscita.

Ricordati di mettere un diodo sulla bobina del rele'

Per vedere se i disturbi entrano dall'alimentazione , potresti alimentare il circuito con una batteria, se il problema si rislovle deivi applicare un filtro in entrata.

Link to comment
Share on other sites

Grazie

Ma pensi che attraverso i relè di uscita possano entrare dei disturbi ?

Usare un condesatore sul motore porebbe servire ?

come và dimensionato ?

Ciao

Link to comment
Share on other sites

Che tipo di filtro devo mettere per eliminare dei distirbi che mi entrano dall'alimentazione del mio PLC che mi sono costruito con un pic16f877 ?

Grazie

Link to comment
Share on other sites

Che tipo di disturbi?Bassa frequenza,alta frequenza,ripple alimentatore,picchi di tensione,influenze termiche....per un filtraggio generale,elettrolitico da 100microfarad al + e al meno alimentatore,poliestere da 100kpicofarad al + e al -alimentatore,induttanza fra + alimentatore e + Pic,poliestere da 100kpfarad in parallelo al + e - del Pic.......

Link to comment
Share on other sites

Grazie per tutte le risposte .

Avevo già inserito tutto quello che mi avete suggerito, ci siamo accorti che il problema proveniva dalla massa del rete elettrica. Abbiamo scollegato tutte le masse su tutti i dispositivi (motori e pompe) e dopo aver fatto questa operazione il sistema ha migliorato sensibilmente la stabilità del pic .

Ora controlleremo tutte le masse dei dispositivi, pensiamo che ci sia qualcosa in dispersione.

Vi farò sapere.

Il tipo di disturbo è sicuramente induttivo provocato dallo spunto dei motori all'avviamento o spegnimento.

Grazie a tutti

Link to comment
Share on other sites

Hai provato a scollegare solo la massa del circuito pic ?

Non ha la possibilita di usare un oscilloscopio per registrare l'evento?

Non puo essere che l'alimentazione del pic scenda sotto il livello minimo?

Io uso regolarmente il pic in campo industriale , vizino a motori compressori e inverter , non ho mai riscontrato questo problema , ma io la massa non la collego diretta ma uso lo 0v dell'alimentazione 24v.

Link to comment
Share on other sites

Grazie nuovamente

Ovviamente ho verificato il disturbo con l'oscilloscopio, ho riscontrato che anche lasciando la sonda scollegata dall'alimentazione del circuito sull'oscilloscopio si presenta un picco di pochi millesimi di secondo che a volte fa resettare il pic .

Penso che probabilmente è come dici tu deve essere che l'alimentazione del pic scenda sotto il livello minimo solo quelle volte che il tempo del disturbo è tale da far resettare il circuito.

Devo ancora verificare il discorso della massa.

Grazie

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...