Jump to content
PLC Forum


Mirko1975

Temporizzatore ritardato

Recommended Posts

Mirko1975

Salve chiedo scusa se ho erroneamente sbagliato sezione è la prima volta che scrivo sul forum, mi presento  Sono Mirko autodidatta con la passione per l'elettronica con qualche piccola  conoscenza di base, mi rivolgo a voi perche avrei bisogno di costruire un piccolo temporizzatore per controllare un relè,  che agisca  nel seguente modo: ho a disposizione un positivo a 12 volt cc, vorrei che alla presenza di esso non accada nulla, ma quando viene a mancare si chiuda il rele per un tempo di 4/5 secondi e si riapre ,e resti cosi fino al prossimo ciclo

Intanto grazie per la vostra attenzione se non chiedo troppo potreste gentilmente fornirmi uno schema per poi realizzare su pcb

Buona serata complimenti per il forum

Share this post


Link to post
Share on other sites

Mirko1975

Infinite grazie Stefano  lo metto in pratica appena realizzato provo a postare una foto grazie ancora buona giornata Mirko

Scusa ancora l'integrato che utilizzi è un NE 555 perche con questa sigla mi manda ad un integrato da 8+8 piedini cmos forse è un doppio NE555?

grazie ancora

Edited by Mirko1975

Share this post


Link to post
Share on other sites
dott.cicala

MANCA UN COLLEGAMENTO evidenziato qui sotto

image.png.23c51cf44e41d9cb6392569451e8bbc4.png

 

Non è un 555 perché il 555 non controlla i fronti di salita/discesa e farlo a componenti discreti sarebbe un'inutile fatica.

Il CD4538 fa già tutto da solo e ne basta metà.

 

Nello schema manca la seconda sezione che rimane inutilizzata i cui pin  vanno collegati così

 

13-15 con +Vcc

11-14 con GND

 

L'alimentazione è:

pin 8  GND

pin 16 +Vcc

 

Edited by dott.cicala

Share this post


Link to post
Share on other sites
Mirko1975

Faccio delle prove e vedo se riesco a reperire l'integrato qui nel nostro negozio della città

grazie ancora

Share this post


Link to post
Share on other sites
Livio Orsini
48 minuti fa, Mirko1975 ha scritto:

vedo se riesco a reperire l'integrato qui nel nostro negozio della città

 

Lo trovi abbastanza facilmente su ebay, nel caso il tuo negozio ne fosse sprovvisto.

Share this post


Link to post
Share on other sites
Mirko1975

Scusate sono stato un po assente, Grazie Livio e buona serata anche a te, sono riuscito con facilità a trovarlo qui in zona, ho realizzato il circuito ma forse ho sbagliato qualcosa, perchè

si avvicina molto a quello che mi occorre, ma a volte fallisce, cerco di spiegarmi meglio, quando do il positivo lui sta fermo ma quando lo tolgo a volte mi da un impulzo al relè e a volte no devo ridare e ritogliere il positivo +12vcc, ho anche provato a sostituire l'integrato avendolo montato con lo zoccolo, e avendone presi due visto il costo bassissimo dell'integrato

se riesco allego la foto dello schema fatto con kikad, inoltre il relè mi rimane sempre in eccitazione e l'impulzo lo devo ricavare dal contatto NC

Grazie per l'aiuto buona serata Mirko

 

schema temp kikad.jpg

Share this post


Link to post
Share on other sites
dott.cicala

Il relè non può rimanere sempre eccitato.  C'è qualche errore.

Se hai realizzato lo schema che ti ho disegnato e hai usato un transistor NPN, il relè si eccita solo quando il pin 6 va a 1.

+Vdc deve essere presente prima che vada via il segnale da controllare.

Se la sensibilità è insufficiente abbassa  R201 a 1k.

 

Share this post


Link to post
Share on other sites
Mirko1975

Intanto grazie per il tempo dedicatomi ricontrollo il tutto con questo schema il transistor è cambiato io avevo messo un bc337 ora provo con questo bc547, e in effetti avevo dovuto gia abbassare la R201 da 10k  perchè non riceveva l' impulzo io avevo provato con una da 560 ohm inoltre vedo R2 cambiata da 100k anzichè 47k

domani modifico e poi faccio sapere ancora buona serata

Mirko

 

Share this post


Link to post
Share on other sites
Mirko1975

Eccomi di nuovo quà, con qualche accorgimento e sostituzione del transistor probabilmente guasto sono riuscito a far funzionare il circuito proposto da voi, allego sotto anche foto, ora mi rimane un ultimo problema, che cerchero di spiegare, se simulo il positivo con un dip isolato tipo telecomando tanto per intendersi il kit non sbaglia un colpo se questo positivo proviene da un altro rele il disturbo della bobina mi fa scattare il dispositivo sia all'apertura che alla chiusura, inotre il contatto di imput è molto senzibile e parte anche solo appoggiandoci la sonda del tester chiedo scusa se non sono stato molto chiaro nella spiegazione grazie ancora

 

 

 

Temporizzatore PLCforum.jpg

Share this post


Link to post
Share on other sites
dott.cicala

Inizia col mettere in parallelo a D1-R3 un condensatore da 1uF

Share this post


Link to post
Share on other sites
Mirko1975

Spettacolare Stefano ora è stabile, allora ho modificato la R6 da 1K con una da 100k, ho aggiunto un cond elettrolitico da 1uF 25 volt in parallelo tra D1 e R3, e come Transistor avevo disponibile un BC 182B,

voglio indicare il mio utilizzo, il relè in uscita mi deve dare un impulzo ad un combinatore telefonico aggiunto al mio impianto artigianale di antifurto in un canale libero dei 5 per segnalare il solo il disinserimento della modalità allarme e non il cambio di stato altrimenti mi avrebbe segnalato l'inserimento e il disenserimento, con questo grazie a voi quando viene inserito arriva il positivo +12vcc e il rele sta fermo quando invece il positivo viene a mancare il rele da l'impulzo ed invia un sms di stato, scusate ma  mi piaceva condividere la mia necessità con voi che mi avete aiutato a relizzare ciò, adesso monterò il tutto e lascerò qualche giorno di Test

Grazie ancora buona giornata

Mirko

 

 

 

 

Share this post


Link to post
Share on other sites
dott.cicala

Grazie per averci spiegato a cosa ti serve il circuito :thumb_yello:

 

100k però sono un po' tanti perchè con R3 a 100k si forma un partitore di tensione e sul pin 5, quando il pulsante è premuto, si presenta una tensione che vale 1/2 Vcc.

Il monostabile così capisce che il pin 5 non è nè a livello logico zero ma nemmeno a livello logico uno.

 

Per un CMOS infatti i due livelli valgono

<= 1/3 Vcc per lo zero

>= 3/4 Vcc per il livello logico uno

 

1/2 Vcc non rientra nei casi.

Funziona perché il monostabile reagisce sul fronte di discesa del segnale e quindi quando la tensione al pin5 diventa <= 1/3 Vcc.

 

Così ti è andata di c....:superlol:

 

...ma se funge e ti soddisfa....lascialo così.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Mirko1975

Sinceramente con 680k non mi oscillava l'ho portata a 1k come suggerito da te e funzionava,ma visto quella sensibilità di prima pensavo che forse era troppo bassa visto che è quella di ingresso allora ho optato per alzarla a 100k trovando qualche impercettibile miglioramento poi l'ho lasciata così ignorante della tensione di lavoro da te ora spiegatomi, per il momento va poi nel andare del tempo vedrò come si comporta, per me questo forum è un ottimo riferimento tornerò di sicuro a disturbarvi vistro la tua disponibilità ed esperienza

Grazie ancora

Mirko

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...