Jump to content
PLC Forum


Renato Capasso

Parere su problema amplificatore classe D

Recommended Posts

Renato Capasso

Buonasera ragazzi, 

mi trovo davanti ad un problema del tutto nuovo. Si tratta di un amplificatore classe D e purtroppo non sono un grande esperto di questi amp.

Si avvia regolarmente, ma, senza carico resta freddo, se invece collego un qualsiasi altoparlante da  8ohm e lo avvio la restistenza r79 (schema) inizia a surriscaldare in modo anomalo. Questo lo fa una volta su tre in media, sia in presenza che assenza di segnale audio. L'altro canale si comporta in modo simile ma meno frequentemente. 

Ho verificato se i condensatori (c68,65,66,ecc) fossero in dispersione o guasti ma rientravano perfettamente nei valori così come le resistenze. Il valore della resistenza è esatto. E' una resistenza da 7w ceramica, R75-76 se ben ricordo 1w. R75 e R76 scaldano in modo regolare.

Non ho ancora smontato i finali, ma da un primo controllo sembrerebbero ok. Poi il fatto che ne soffrano entrambi i canali mi fa ipotizzare un problema di altra natura e comunque non ho notato surriscaldamento anomalo quando il funzionamento è stato regolare.

Altra cosa , ho effettuato dei test su entrambi i canali con frequenze differenti tra i 120hz e i 1000hz. Dopo un tempo che va da un minuto ad un minuto e quaranta avviene una attenuazione dell'uscita di esatti 20db. Come se andasse in protezione ma senza una causa apparente: suono regolare , solo più basso, nessun surriscaldamento. Questo avviene a prescindere dal volume. Se l'uscita è 80db passa a 60, se 40 passa a 20 (misure fatte col telefonino attendibili fino ad un certo punto).

Qualche idea o suggerimento su quali possano essere le cause? 

Grazie a tutti e a presto.

 

 

 

 

fINALE.thumb.PNG.4ad318e128e32b2906a60659eb9f707e.PNG

Share this post


Link to post
Share on other sites

Renato Capasso

Segnale in ingresso (sorgente- 1° immagine) e segnale amplificato (2° immagine): a me non sembra tanto normale o è una caratteristica della classe d?(Il segnale amplificato risulta più basso perchè ho abbassato di molto il volume, misurato con lo stesso carico: 8ohm) 

1866833982_WhatsAppImage2020-07-10at16_33_38.thumb.jpeg.5b5df6eef6cb6c7f3720c464fee3b62b.jpeg1824181165_WhatsAppImage2020-07-10at16_45_04.thumb.jpeg.be69ffbc08932e544314789fe61dc9c6.jpeg

Share this post


Link to post
Share on other sites
Vicus

È un prodotto commerciale o autocostruito/pgettato? Sembrerebbe powersoft. Nelle misure la base tempi è la stessa? 

Share this post


Link to post
Share on other sites
dott.cicala

Nella foto a dx è chiaro che autooscilla.

Cattura.JPG.4c14920c8e533b579d7e5a2a595ecdd2.JPG

Share this post


Link to post
Share on other sites
Renato Capasso

Ciao , grazie per le risposte, non so se sia Powersoft, credo sia un modulo commercializzato da più marche e non è autocostruito anche se a giudicare dagli interventi visibili ci andiamo vicino...Scherzi a parte, ieri pomeriggio ho indagato più a fondo. ho rimosso i mosfet e controllato i gate...un disastro totale. Mi meraviglio che non sia andato a fuoco. Segnale sporco e disturbato su tutti e 4 in modi differenti. Solo uno più o meno accettabile. Oggi non ho modo di lavorarci su, domani proseguo e vi aggiorno. 

Share this post


Link to post
Share on other sites
maxmix69

Hai già risposto di aver controllato i finali, stavo per dirti che l'unico motivo del riscaldamento sono i finali sballati o pilotaggio errato degli stessi. Importante, controlla se la frequenza di commutazione varia in modo considerevole da quando funziona a quando fa il difetto e pubblica lo schema elettrico completo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...