Jump to content
PLC Forum

Nixie

mega 2560 driver seven

Recommended Posts

Nixie

Ciao, ho scaricato l' ide di arduino (1.8.13) da arduino.cc ed installato su un portatile della dell  con win 7 sp1 

Il programma si installa correttamente e gira ma non comunica con il modulo.

In gestione dispositivi la porta corrispondente è segnalata da un punto esclamativo su triangolo giallo ed in "generale" è evidenziata la dicitura "impossibile avviare il dispositivo. (codice 10)".

Ci già perso parecchio tempo ma non trovo la soluzione, spero che qualcuno mi dia una mano.

Grazie.

 

Link to post
Share on other sites

Livio Orsini

Sei sicuro del bootloader della scheda che connetti? Ho avuto problemi simili con delle schede "leonardo" è l'ho risolto ricaricando il bootloader sulle schede.

Link to post
Share on other sites
Nixie

Buona domenica Livio.

Non ho ancora avuto a che fare con il bootloader e non so bene di cosa si tratti, forse è relativo al firmware della scheda?

 

Link to post
Share on other sites
Livio Orsini
3 minuti fa, Nixie ha scritto:

forse è relativo al firmware della scheda?

 

E il firmware della scheda. In rete trovi molti documenti, anche in italiano, che spiegano come trasferire il boot da un arduino ad un altro.

 

Ma tu quando connetti la scheda al PC fai le operazioni previste? Ovvero selezioni, nel menù strumenti, il tipo di scheda, poi verifichi su quale porta è connesso e dai la spunta.

Link to post
Share on other sites
Nixie

SI, aggiungo un altro particolare: ho pronto ad eseguire la stessa installazione con la stessa versione dell' ide e su un portatile HP di prestazioni pressoché simili al Dell e con so windows seven stessa versione.

Su quest' ultimo il driver viene installato ed il pc comunica con Arduino.

Per quando riguarda la numerazione delle porte sul Dell non è visualizzato il numero della porta che vedo assegnata in gestione dispositivi.

Che sia il portatile che ha qualche problema di compatibilità sulle porte?

Link to post
Share on other sites
Livio Orsini
1 ora fa, Nixie ha scritto:

Che sia il portatile che ha qualche problema di compatibilità sulle porte?

 

E probabile che la versione dell'IDE sia incompatibile con quel portatile. prova eventualmente con una versione antecedente, magari una 1.6.x

Link to post
Share on other sites
Nixie

Sicuramente una buona considerazione.

Verifico quanto prima se sia questa la strada giusta.

Grazie Livio Ti faccio sapere.

Link to post
Share on other sites
Nixie

Ciao Livio, purtroppo niente di fatto.

Previa disinstallazione della versione precedente ho installato la versione 1.6 e poi la 1.0.ma l'indicazione di windows in gestione dispositivi è sempre la stessa ovvero il dispositivo è riconosciuto ma il messaggio di errore è sempre "impossibile avviare il dispositivo. (codice  10).

Non so cosa pensare forse la cosa più probabile è che il Dell abbia una gestione particolare delle porte e voglia un driver suo.

Ma forse sono fuori strada.

Aggiungo che ieri ho installato tutti gli aggiornamenti di windows e non richiede poco tempo, ma niente.

Intanto grazie

 

Link to post
Share on other sites
Livio Orsini

Nella schermata di sistema che da lo stato delle periferiche cosa ti dice rigurado a quella porta USB?

Se hai queste indicazioni

Il 27/9/2020 alle 00:15 , Nixie ha scritto:

In gestione dispositivi la porta corrispondente è segnalata da un punto esclamativo su triangolo giallo ed in "generale" è evidenziata la dicitura "impossibile avviare il dispositivo. (codice 10)".

 

Se ti da indicazioni simili, o cumunque messaggi di attenzione, anche senza alcun dispositivo connesso alla porta è un problema Hw del PC.

Se invece, connettendo, un altro dispositivo USB come, ad esempio, una stampante funziona tutto regolarmente, allora è un problema di incompatibilità con Arduino. Soprattutto percchè hai detto che con altro PC quella scheda si connette regolarmente.

Link to post
Share on other sites
Nixie

Rispondo a gabri-z:   windows seven professional service pack1

Per Livio: in gestione risorse quando scollego arduino sparisce la porta non avverabile dall'elenco e non ci sono altri messaggi di attenzione.

Grazie

Link to post
Share on other sites
Livio Orsini

Con Win7 su un portatile Acer TravelMate non ho alcun problema con l'IDE di arduino anche ultima versione.

Probabilmente hai un problema di compatibilità con il tuo PC.

Link to post
Share on other sites
Nixie

Hai centrato il bersaglio Livio, così ci ho sbattuto un po la testa, perdendoci del tempo e sono arrivato a capire che più marche di pc non hanno le istruzioni per poter gestire il chip di comunicazione CH340/341 che viene usato su alcune versioni di arduino (soprattutto clonate) e questo indipendentemente dall'età del pc.

A questo rimediano dei files che ho trovato online, con estensione exe e dmg che ho provato e scelto i due adatti, uno per  win7 e uno per osx perché anche mac dalla versione 10.11 in avanti non lo mastica più.

Il file in questione è il ch341ser.... varie versioni in base al sistema operativo.

Se qualcuno avesse difficoltà a reperirlo online può chiedermelo.

Spero di essere stato utile a qualcuno oltre ad aver risolto il mio problema.

Grazie della collaborazione e dei suggerimenti a Livio e gabri-z 

Link to post
Share on other sites
Livio Orsini

Grazie anche a te per aver pubblicato la soluzione.

A volte però è un problema legato al bbotloader di arduino; io lo risolvo solitamente copiando il boot di arduino orignale, tengo delle schede originali di arduino 1, nano e Mega proprio per questo scopo.

Link to post
Share on other sites
Nixie

In altri casi sicuramente si risolve in questo modo.

Terrò a mente.

Ciao

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...