Jump to content
PLC Forum


alberto16

Circuito GPS

Recommended Posts

alberto16

Ciao ragazzi, ho un problema con una scheda che ho fatto per un modulo GPS.

Non sono un esperto elettronico, ma essenzialmente ho seguito alla lettera la guida del fornitore. L'ho anche confrontata con una scheda disponibile in commercio e mi sembrava simile, quindi l'ho costruita. Oggi, alimentandolo, non ha funzionato. Volevo chiedervi se potreste darmi una mano a capire cosa non va in quello che ho disegnato.

Qui c'e la guida del fornitore: https://www.u-blox.com/en/docs/UBX-15028081

Pagina del prodotto https://www.u-blox.com/en/product/neo-m8p-series

Grazie! Alberto.

 

MioShematico.jpg

CircuitoInCommercio.png

Link to post
Share on other sites

patatino59
11 ore fa, alberto16 scrisse:

Non sono un esperto elettronico

Hai usato la scheda finita o ne hai costruita una personalmente ?

Che strumentazione hai ?

E come faresti a gestire in autonomia, o con le indicazioni del Forum, un simile progetto su carta ?

Forse non basta lo schema per arrivare alla soluzione finale, ci sono migliaia di variabili, elettriche, fisiche, pratiche eccetera, da considerare.

Magari sei un ottimo programmatore.

 

Edited by patatino59
Link to post
Share on other sites
alberto16

Grazie mille per la risposta!! Ho preso ispirazione dal circuito di SparkFun che ho inviato, quindi ho disegnato un circuito semplificato e ho provato a costruirloIMG-20210505-WA0005.thumb.jpg.f436bcb7bd6b567a05f270468c91c11e.jpg

Io sono un studente in ingegneria elettronica e non avendo svolto ancora gli esame di progettazione ma soltanto quelli di base non riesco a capire cosa non vada a livello teorico o pratico nel circuito che ho mostrato. Magari c'e qualcosa che è ovvio agli occhi di un esperto ma invisibile ai miei, perchè ci ho perso un sacco di ore senza concludere nulla!

 

Link to post
Share on other sites
Livio Orsini
10 ore fa, alberto16 scrisse:

quindi ho disegnato un circuito semplificato

 

Ti racconto un aneddoto illuminante.

Circa 50 anni fa alla comparsa dei primi SMPS diretti da rete, per un certo periodo, mi dedicai allaprogettazione di questi apparati specificamente per il mercato televisivo. Ai tempi c'erano numerose aziende che producevano TV in Italia, per lamaggior parte piccole, dette "cantine".

Una volta stavo prendendo accordi per fornire ad una di queste, un nuovo SMPS e il responsabile mi portò nel loro laboratorio di pregettazione, dove stavano progettando un nuovo modello, su cui sarebe andato il nuovo alimentatore.

Li avevano un TV Philips e 2 ragazzi stavano provando a tagliere un componente alla volta, per verificare se il televisore funzionava egualmente. Se continuava a funzionare, lo cancellavano dallo schema. Alla fine ne avrebbero derivato lo schema del loro televisore!

Ti sembra un buon metodo di progettazione?

 

Tu hai "semplificato" lo schema originale. Tieni presente che questi modulini, a bassissimo costo, sono già ridotti al minimo indispensabile. Visto che i volumi di produzione sono elevati, anche un diodo, od un condensatore in più, incidono sui profitti.

 

Dando solo un'occhiata superficiale ai 2 schemi si vede che hai tolto tutti i filtri e le protezioni. Non sono superflui, servono a garantire un buon funzionamento ed una discreta affidabilità.

 

Poi come hai collaudato la tua scheda?

Come hai dedotto che non funziona?

Quel modulo è un ricevitore GPS che deve dialogare con un dispositivo master per ricevere dare informazioni. Avrà il suo protocollo. Sei sicurto dei comandi che dai?.

 

Forse se spieghi tutto quello che hai fatto qualcuno potrebbe darti qualche indicazione mirata alla soluzione di tuoi problemi.

Link to post
Share on other sites
lemmondroberto

Se la foto che hai postato il cavo rosso- nero e' l' alimentazione

c'è un corto!

 

IMG-20210505-WA0005.thumb.jpg.f436bcb7bd6b567a05f270468c91c11e.jpg.6562a8be0cc60a5e1f2dd9bb3eea0ab1.jpg

 

Saluti Roberto.

Link to post
Share on other sites
alberto16

Grazie mille per le risposte.

Come ho scritto nel primo messaggio io ho seguito alla lettera la guida del fornitore, non "semplificando lo schema originale". Il circuito corrisponde alle caratteristiche minime indicate dal costruttore (a pagina 11 della guida inviata), soltanto alla fine della progettazione lo abbiamo confrontato con quello già presente in commercio non riscontrando particolari differenze.

Allego altre due foto che potrebbero facilitare la comprensione. Essenzialmente i passaggi che abbiamo seguito sono i seguenti:

1: Progettato il circuito seguendo le indicazioni nel manuale dei costruttori con le caratteristiche minime per il funzionamento del circuito
2: Creato lo schema PCB e le piste per fare il circuito stampate (quelle nella foto in bianco e nero)
3: Con una cnc laser e il cloruro ferrico create le piste su una basetta ramata
4: Saldati tutti i componenti con saldatore a mano a 350 gradi
5: Saldato il GPS seguendo rigidamente le istruzioni e le linee guida presenti nel manuale
6: Collegata l'alimentazione e dedotto il non funzionamento dal TIMEPULSE

 

Per quanto riguarda il corto ho controllato meglio ma non mi sembra di vederlo!

 

Grazie Alberto.

 

index.jpg

index1.jpg

Link to post
Share on other sites
Livio Orsini
9 ore fa, alberto16 scrisse:

soltanto alla fine della progettazione lo abbiamo confrontato con quello già presente in commercio non riscontrando particolari differenze.

 

Qulache differenza c'è e salta all'occhio subito, ci sarebbe da chiedersi perchè chi produce per vendere ha adottato una topografia circuitale un po' più dispendiosa.

9 ore fa, alberto16 scrisse:

Collegata l'alimentazione e dedotto il non funzionamento dal TIMEPULSE

 

Scusa da cosa lo hai dedotto? Hai dato tensione e non hai visto uscire l'impulso ad 1" da cui hai dedotto che il circuito non funziona?

 

Link to post
Share on other sites
Lorenzo-53

Per esempio il pin 7 da schema non va a GND, poi perchè prevedere quel cavallotto blu quando bastava implementare la traccia? 

Link to post
Share on other sites
alberto16

Ovviamente ci sono delle differenze ma a noi sembravanmo tutte necessarie ad avere delle funzionalità in più che a noi non servivano (interfaccia usb, batteria di backup, salvataggio su scheda sd, etc). Comunque abbiamo dedotto il non funzionamento dal led del timepulse, il geofence da un segnale molto debole (il led è molto meno luminoso di come dovrebbe essere) e i pin di lettura dati oggi mi hanno dato qualche segnale. Questa settimana collego ad arduino e vedo se sono dati sensati.

Per quanto riguarda il pin 7 nel nostro schema va a gnd, e questo perchè nel manuale se non viene utilizzata l'interfaccia usb va messo a gnd, e ha ragione sul cavo blu ma ce ne siamo accorti dopo 😅

Link to post
Share on other sites
Lorenzo-53

Quei moduli li ho visti tutti schermati con un coperchietto in lamierino a massa

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...