Jump to content
PLC Forum


bilancia scale house APM


gabritinaro
 Share

Recommended Posts

gabritinaro

Un saluto a tutti, ho questa bilancia che ha smesso di pesare, mi spiego,accendo la bilancia la procedura di accensione è regolare il display si presenta con la dicitura  0,00Kg ed è pronta a pesare ma mettendo del peso sul piatto non misura niente. entrando nel menu della bilancia per  fare la  calibratura  funziona  tutto regolare, io non avendo un minimo di esperienza sulle bilance chiedevo un consiglio di cosa potrei fare per risolvere il problema, c'è una eeprom potrebbe essere lei? e se fosse lei  come sostituirla? la cella di carico funziona regolare spero di un  Vostro  suggerimento grazie di tutto Tinaro

Link to comment
Share on other sites


Livio Orsini
9 ore fa, gabritinaro ha scritto:

la cella di carico funziona regolare

 

Come fai ad affermarlo? Ne hai misurato l'uscita?

 

Se la cella, ed il relativo ampificatore funzionano regolarmente, non c'è molto da fare. Hai scritto che c'è una EEPROM dovrebbe esserci un micro; prova a leggere le siglie dei componenti ad a pubblicarle, magiri corredate da qualche foto.

 

Riassumendo, tu hai scritto:

  • la cella funziona regolarmente
  • la procedura di calibrazione funziona regolarmente.

Se non c'è alcun collegamento interrotto, significa che non avviene la conversione A/D del segnale proveniente dalla cella. Se c'è un micro la conversione avviene all'interno dello stesso, quindi è il micro che è guasto almeno nella sua parte di conversione.

Il rimedio? Sostituire il micro, ovviamente con il nmedesimo firmware.

Link to comment
Share on other sites

gabritinaro

CIao Livio come sempre siete sempre cortesi ad interessarvi di noi profani, detto questo torniamo alla bilancia, allego le foto della main, Dai mie controlli da i2 operaziionali il segnale esce,e  che misuro movendo il piatto, con un tester, sono di qualche millivolt poi non riesco più a seguire. posso dirti anche che toccando il piedino 6    della eprom,la bilancia e come se  pesasse qualcosa poi si ferma come se avesse trovato il peso medio.

Leggendo la tua diagnosi che mi sembra corretta, il micro di conversione stando alla foto  quale sarebbe  AD7715AD. a mè sembra che quando  si accende la bilancia

fa tutta la procedura poi sembra , questa è una mia opinione, che non ci sia lo  start dato dai pesi messi sopra al piatto ma passi direttamente allo stop, un'altra cosa

sempre che sia utile a farti capire il più possibile la tastiera se non vai in impostazioni  non funziona, funziona solo in  of on. 

non so se sono stato comprensibile a spiegare il problema, sono certo della Tua buona pazienza  un saluto GabriIMG_20220724_201849.thumb.jpg.008af81f381c5799e731e267376efda9.jpg

IMG_20220724_202131.jpg

Link to comment
Share on other sites

Livio Orsini

Lo AD7715 èun convertitore A/D Sigma delta a 16 Bit

Al piedino 6 devi misurare 3V o 5V, secondo che sia il modello a 3V o a 5V di alimentazione.

Il segnale proveniente dalla cella di caricoè appliocato ai pin 6 e 7e deve essere di qualche volt a fondo scala.

Dovresti procurarati dei pesi corrispondenti a circa metà scala e misurare le tensioni in uscita dagli ampli.

 

Se riesci leggi e scrivi la sigla del chip quadrato e di quello grande rettangolare.

Link to comment
Share on other sites

gabritinaro

Ciao Livio ti invio sigle integrati  il rettangolare grande - 40PIN  AT89C52   -  IL  quadrato  52 PIN  D7225G NEC -     eprom atmel 93c46  -  ad7715  16pin -  2 operazionali OP07-

quello in alto a destra  HEF4027BP.  intanto controllo le tensioni che mi ai suggerito poi ti saprò dire

grazie intanto del tuo interessamento saluti Gabri

Link to comment
Share on other sites

Livio Orsini

Lo AT89C52 è il micro controllore, il D7225G è il controllore del diaplay, la 93c46 è una tipica EEprom seriale, da 128x8 o 64x8 secondo cha sia la versione A o B, usata per memorizzazione dati e paramentri.

Gli OP07 sono amplificato ri operazionale usati per amplificare il segnale della cella, segnale che sarà applicato al convertitore AD7715, il segnale convertito in digitale sarà letto in modo seriale dal micro che a sua volta invierà i dati da visualizzare al controllore del display D7225.

Il HEF4027BP. è un doppio flip-flop J-K che sarà usato per qulache operazione logica.

 

Segui il segnale dalla cella sino all'ingresso dello ad converter, se hai una tensione coerente con le variazioni di peso, allora il problema è propabilmente legato allo stesso convertitore.

Link to comment
Share on other sites

gabritinaro

Ciao  Livio  appena posso faccio i controlli che mi ai suggerito poi ti saprò  dire.

Ti ringrazio infinitamente per la Tua premura Gabri

Link to comment
Share on other sites

  • 2 weeks later...

Ciao Livio sono quà, le tensioni  su lo  AD7715AN -3  sembrano corrette 3v alimentazione  e una tensione che varia in base al peso messo sul piatto   sul piedino 7 ciò significa che fino a quel punto dovrebbe essere funzionante, volevo sostituire lo AD7715 ma non sono riuscito a trovarlo, si trova AD7715AN-5 ma il 3 nò, hai qualche suggerimento dove potrei trovarlo?

Un chiarimento, mi parli di un  "micro" è il funzionamento che ha lo AD7715? scusa della domanda ma ripeto nelle bilance sono negato.

Grazie ancora della Tua gentilezza saluti Gabri

Link to comment
Share on other sites

13 ore fa, gabritinaro ha scritto:

mi parli di un  "micro" è il funzionamento che ha lo AD7715?

 

No. Lo AT89C52 è il micro controllore. Questo dispositivo governa tutto ili sistema. Verifica e troverai che il pin di uscita dello AD ed i pins di comando sono connessi con alcuni pins dello AT89C52.

 

13 ore fa, gabritinaro ha scritto:

si trova AD7715AN-5 ma il 3 nò,

 

Sono praticamente identici, tranne che per la tensione di alimentazione 3V per il 3 e 5V per il5.

Prova a fare ricerche in rete; io non prenderei in considerazione i chip proposti da aliexpress e siti simili; dopo un'attesa lunghissima ti ritrovi per le mani qualche cosa che poi non funziona.

Prova a verificare nel sito Texas Instruments; in genere per ogni loro componente ti propongono rivenditoori a cui rivolgersi per campionatura.

Link to comment
Share on other sites

Ciao Livio  provo a sostituire AD7715NA-3 con un 5 mettendo un regolatore di tensione,  che da 6V  mi porti a 5V.   lo    AT89c52  se dovesse essere lui non saprei proprio come fare  a sostituirlo non avendo il modo di programmarlo, è cosi?  o ci sono soluzioni che io non sò. per sostituirlo. se mi puoi dare un ultimo consiglio Ti sarei molto grato, scusa della mia insistenza un saluto Gabri.

Link to comment
Share on other sites

2 ore fa, gabritinaro ha scritto:

lo    AT89c52  se dovesse essere lui non saprei proprio come fare  a sostituirlo non avendo il modo di programmarlo, è cosi? 

 

Purtroppo si, però visto che riesci ad avere lo zero iniziale non credo si tratti del micro.

Da 6 V ottenerne 5 regolati, anche usando un regolatore a basso dropout, mi sembra una....missione impossiible.

Inoltre, cosa più importante, il trapianto non funziona perchè anche tutti i segnali ed i riferimenti, di tutto il circuito, sono tarati per 3V e non per 5. Anzi rischi di danneggiare qualche altro componente.

Link to comment
Share on other sites

Ciao Livio ho già acquistato ad7715 provo ad adattarlo non sò come,  poi ti saprò dire, spero bene. Questa è una bilancia di qualità, ma datata l'assistenza non la considera più oggi bisogna buttare!!!! io da vecchio riparatore ottantenne mi diletto per gli amici, scusa del mio sfogo.

Un saluto e tante grazie per il Tuo interessamento  Gabri

Link to comment
Share on other sites

5 ore fa, gabritinaro ha scritto:

provo ad adattarlo non sò come,

 

Ma è un lavoraccio, dovresti mettere dei traslatori di livello.

Ci sono 2 pericoli.

I camndi che vanno alconvertitore son di livello appena suffciente per consentire il livello alto,però riduci drasticamente l'immunità ai disturbi.

I segnali che vanno dal convertitore al al resto dell'apparato potrebbero causare guasti se gli altri dispositivi non sono tolleranti per i 5V.

Poi hai ilproblema delle misure sballata perchè il livello analogico è previsto per un riferimento di 3V, con il tipo a 5v anche il riferimento dovrebbe essere a 5V.

Verifica sul data sheet se il tipo a 5V accetta anche l'alimnetazione a 3V; ora non ho sottomano il datasheet, ma in alcuni casi accettano entrambe le alimentazioni.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...