Jump to content
PLC Forum


Incrociare Dati Su Due Fogli Excel


Samu778
 Share

Recommended Posts

Ciao a tutto il forum,

ho due file excel distinti dove in ognuno ho gli stessi nomi e cognomi (colonna nomi - colonna cognomi)

I due file si differenziano perchè in uno ho dei numeri tessera per ogni persona oltre ai nomi e cosgnomi (colonna numeri tessera - colonna nomi - colonna cognomi).

Ora voglio che in automatico i numeri tessera del primo file vadano anche nel secondo file in corrispondenza di ogni persona

quindi se mario rossi ha il numero di tessera 1 voglio che nel secondo file di excel nella riga mario rossi sia scritto numero di tessera 1.

Anticipatamente ringrazio

Link to comment
Share on other sites


Riccardo Ottaviucci

forse non ho capito bene il problema,ma basta che nella casella in cui deve essere riportato il n° tessera scrivi = e poi apri il foglio sorgente da cui devi copiare nella casella corrispondente,ti posizioni nella casella e invi.Poi trascini copiandola la formula su tutta la colonna,così è banalissimo,ma forse ti serve qualcosa di più complesso,spiegati meglio

Link to comment
Share on other sites

sicuramente mi sono spiegato male e troppo sintetica è stata la mia domanda, cerco di porla in maniera più dettagliata.

File excel 1

in questo file ho queste colonne

NOME - COGNOME - N°TESSERA

Queste colonne sono tutte compilate, ogni persona ha il suo numero di tessera (ci sono circa 300 utenti)

File excel 2

in questo file ho queste colonne

NOME - COGNOME - N° TESSERA

le uniche colonne compilate sono NOME e COGNOME (gli stessi del file 1).

Ora ho bisogno che tutti i numeri tessera che trovo sul primo file siano riportati nel secondo file, considerate che l'elenco non è uguale, nel senso ho bisogno che il programma capisca lo stesso cognome e nome che è presente nei due file e che riporti il numero tessera in quel file dove la colonna n° tessera è vuota.

Edited by Samu778
Link to comment
Share on other sites

tecnico.logico

- Rinomina foglio 1 di documento Excel in FileExcel1

- Rinomina foglio 2 di documento Excel in FileExcel2

- Colonne di FileExcel1: A=NOME, B=COGNOME, C=CONCATENAMENTO A+B, D=NUMERO TESSERA

- Colonne di FileExcel2: A=NOME, B=COGNOME, C=CONCATENAMENTO A+B, D=NUMERO TESSERA

- Formula in tutte le celle della colonna C di entrambi i fogli immetti in C2 poi copia incolla fino a C300: =A2&B2

- Formula in tutte le celle della colonna D solo del foglio FileExcel2, immetti in D2 poi copia incolla fino a D300: =SE(VAL.NON.DISP(CERCA.VERT(C2;FileExcel1!$C$2:$D$300;2;FALSO));0;CERCA.VERT(C2;FileExcel1!$C$2:$D$300;2;FALSO))

- Nascondi la colonna C in entrambi i fogli di lavoro

- Prima di cominciare a usarlo definitivamente fai un po' di test per vedere se ci sono problemi.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...