Jump to content
PLC Forum


chinellatomarco

Simboli predefiniti "p_" in Sysmac studio

Recommended Posts

chinellatomarco

Ciao ragazzi qualcuno di voi sa dove sono spariti i simboli predefiniti "p_1s", "p_1min", ecc...che c'erano in cx programmer. Inserendo la lettera P su un contatto in Sysmac studio mi esce solo "p_on", "p_off" e qualche altro simbolo, ma quelli a base tempo, il "low_battery" e tutto il resto?

Grazie mille!

Marco

Link to post
Share on other sites

Ctec

I segnali "pulsanti", o meglio di clock, non sono più appoggiati a specifici bit, ma si leggono con le apposite istruzioni GetxxxClk, dove xxx è il tempo voluto. Purtroppo è sparito il clock a 200ms, ma è facile ricostruirselo.

Dei vari segnali old style (GT, EQ LT, ecc) rimane solo il carry P_CY. Erano roba di compatibilità verso il SysWin.

Altri simboli di sistema, una volta associati agli Axxx, li trovi ora nominati con Underscore iniziale. Per un elenco, vai in Guida->Riferimento Variabile Definita dal Sistema, e trovi un documento con tutte le info.

Per esempio, il vecchio Low_Battery ora si chiama _SelfTest_LowBattery

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...