Vai al contenuto

Darlington

Calcolo resistenza PNP

Recommended Posts

Darlington

Ho un BD140 che commuta un carico (led) da 800mA circa, pilotato da un BC337 che inverte il segnale, pilotato a sua volta da un pic, ho dovuto per forza commutare il positivo perché il negativo era in comune con un altro carico.

 

Come calcolo la resistenza in base? Devo usare la stessa formula degli NPN per la resistenza tra base ed emettitore e poi usare, come ho trovato in un altro sito, un resistore di un decimo del valore del primo in serie al 337?

 

L'uso è semplice on off, niente PWM o altro, posso calcolare direttamente la resistenza sugli 1.5A massimi del 140, in modo da essere sicuro di lavorare in saturazione? Grazie in anticipo 

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini

I calcoli non differiscono tra NPN e PNP.

Io ti consiglierei di pilotare il finale con una coppia complementare in modo da ottimizzare i fronti di salita e discesa.

Dal datasheet, per correnti >= 0.5A il guadagno minimo garantito è >=25; una corrente di di collettore da 800mA necessita di una corrente di base di 32 mA. Si sovrapilota per garantire una rapida saturazione e si impongono 100 mA di base. 

Considerando un'alimentazione a 5 V, la tensione utile è di 4V (0.7 V base emitter del 140 e 0. V del pilota), la resitenza serie alla base sarà pari a 39 ohm, con un'altra identica tra base ed emitter.

Il bc337 con Ic di 100 mA ha un guadagno di 200, quindi Ib circa 0.5 mA.

Facendo considerazioni simili alle precedenti si può mettere una 1000 ohm in serie alla base con una da 1500 ohm tra base ed emettitore.

Io metterei anche 2 condensatori di speed up in parallelo ai resistori di base.

 

Il circuito non l'ho simulato per verificarlo. Se ho tempo e voglia magari oggi o domani lo faccio.

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini

Simulato, funziona bene anche con resistori di valore pari a 2200 ohm sulla base del BC377

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
5 ore fa, Livio Orsini scrisse:

Facendo considerazioni simili alle precedenti si può mettere una 1000 ohm in serie alla base con una da 1500 ohm tra base ed emettitore.

 

Ciao Livio, i led sono alimentati a 7.5V circa, io ho provato a simulare il circuito su circuit maker ma non riesco a far andare in conduzione nessuno dei due transistor virtuali, anche usando valori assurdi tipo 1 ohm alla resistenza di base del 337, ma di sicuro sbaglio qualcosa io... scopo della simulazione era capire quando arrivavo alla saturazione perché in giro per la rete i calcoli sono spiegati in maniera troppo prolissa per i miei gusti, e specie con il caldo non riesco a seguirli :)

 

Se sulla base del 337 ci metto una 4.7k riesco a saturare? Se non ho capito male (5-0.8)/4700=0.0008 che poi moltiplicato 160 (hfe del 337) mi dà 0.14, quindi posso arrivare a 140mA di corrente di collettore sul 337.

 

Ora passando al 140, se voglio far scorrere 100mA nella sua base devo calcolare 7.5V di alimentazione - 0.8V della caduta della giunzione, no? Quindi 6.7V, diviso 0.1, mi darebbe 67 ohm di corrente di base da mettere al 140, dove sto sbagliando?

 

Il pullup tra emettitore e base del 140 per mantenerlo interdetto da quel che ho capito è molto meno critico e qualche kohm dovrebbe bastare, o no?

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Cosi funziona di sicuro :

1035845886_CDOPNP.GIF.115f70a5e1215c643807bf32f3d11837.GIF

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

Ti ringrazio, comunque i calcoli che ho fatto erano quelli giusti allora?

 

Devo riadattare ai valori che ho nel cassetto, passo dai 47 ohm ai 100 ohm, con 100 ohm dovrei avere 67mA di corrente in base, comunque sufficienti per saturare il 140, giusto?

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini

I conti li avevo fatti con 5 V di alimentazione anche per i LED.

Il circuito di Gabri è corretto.

 

Io però aumenterei R4 sino a 180 - 200 ohm.

Diminuirei anche i valori R2 ed R5; esse servono solo per velocizzare l'interdizione dei transistors, diminuendo il tempo di svuotamento delle cariche dalla base virtuale. Diminuendone il valore  la commutazione è più veloce e diminuisce la dissipazione.

 

Quote

con 100 ohm dovrei avere 67mA di corrente in base, comunque sufficienti per saturare il 140, giusto?

 

Come ho scritto prima con una Ic di 800 mA la Ib sarà <= 32 mA, quindi basta avere una corrente maggiore di questo valore per assicurare una buona commutazione. Se proprio si vuole essere sicuri di avere fronti ripidissimi, si mette un condensatore di speed up da 68 nF in parallelo ad una 180 ohm

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Scusa , ma i LED hanno la corrente limitata internamente a 800 mA ,oppure la limitazione la deve fare il circuito ? Perché cambia tutto...

ESATTO  ! Cosa servono 100 mA in base ?

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

I Led appartengono ad una lampada di emergenza, originariamente erano alimentati da due batterie da 3.6V in serie, quindi 7.2V, che con batterie a piena carica arriveranno sui 7.5.

 

La limitazione originale praticamente non c'era, credo abbiano fatto i conti sulla cdt dei led perché il positivo era collegato direttamente ad un PNP per l'accensione in mancanza di energia, e tra il negativo ed i led ci sono tre resistenze in parallelo per un valore totale di 1 ohm, non credo ce le abbiano messe per limitazione di corrente.

 

Quel che voglio fare io (e che ho già fatto, in parte) è alimentare i led con un dc-dc con 24V in ingresso provenienti dalle batterie di un mezzo dove la lampada andrà installata, e visto che ho rifatto da capo la logica di controllo, aggiungere anche un pulsante per l'inibizione; il tutto poi sarà controllato dal pic.

 

Comunque il transistor dovrà fare solo da interruttore, ho provato ad alimentare direttamente i led con l'alimentatore da banco ed effettivamente a 7.2V senza nessuna limitazione aggiuntiva assorbono sui 720-730mA, compatibili con le caratteristiche della batteria originale da 750mAh, dato che l'autonomia garantita è di un'ora ci siamo

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Beh...prima c'era di mezzo anche la resistenza interna delle batterie , quasi certo maggiore di quella del DC-DC .....

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
1 ora fa, Livio Orsini scrisse:

Io però aumenterei R4 sino a 180 - 200 ohm.

 

Mi viene anche più facile perché ho delle 120 e delle 220 ohm

4 minuti fa, gabri-z scrisse:

Beh...prima c'era di mezzo anche la resistenza interna delle batterie , quasi certo maggiore di quella del DC-DC .....

 

Oddio, erano delle ni-cd, note per avere resistenza interna molto bassa...

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Allora stai tranquillo !:superlol:

Metti 120 Ohm ma stai attento alla potenza , dissiperà quasi mezzo Watt , per cui...

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Se il BD 140 ha un hFE maggiore di 50 , puoi mettere una da 220 Ohm / 0,5 W 

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
8 minuti fa, gabri-z scrisse:

Metti 120 Ohm ma stai attento alla potenza , dissiperà quasi mezzo Watt , per cui...

 

Neanche farlo apposta son saltate fuori le 100 e le 120 ohm da 2W, già ero rassegnato a dover aspettare lunedì :lol:

 

altri valori per resistenze di potenza niente da fare, cioé ce le ho ma tutte di valore troppo basso, non avevo tenuto in considerazione i problemi di dissipazione, tanto che sul pcb ho messo il footprint della 1/4W...

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z
9 minuti fa, Darlington scrisse:

tanto che sul pcb ho messo il footprint della 1/4W...

Eh..cambi la serigrafia !:roflmao:

Oppure metti la resistenza nel portabagagli .

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

Va beh, piegando i piedini dovrebbe starci 😛

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

Alla fine ho fatto lo schema di gabri con la R1 da 4k7 e la R4 da 120 ohm, ho omesso R2 dopo aver verificato che non ci sono problemi di false accensioni al power-up del pic.

 

Il 140 scalda abbastanza, ho dovuto mettere un piccolo dissipatore e sul dissipatore misuro circa 60° con la termocoppia del tester; al "ditometro" comunque è molto caldo ma non brucia, mi chiedo se scaldasse così tanto anche il pnp originale, un 2SA1273 che ha un package anche più piccolo del 140...

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini
8 ore fa, Darlington scrisse:

ho omesso R2 dopo aver verificato che non ci sono problemi di false accensioni al power-up del pic.

 

Hai fatto male!

Quel resistore serve per scaricare le cariche della base. non mettendolo il transistor si interdice più lentamente e dissipa di più

E' una mania diffusa tra certi smanettoni; non capisco cosa si risparmia ad omettere quel resistore.

8 ore fa, Darlington scrisse:

Il 140 scalda abbastanza,

 

Verifica se:

  1. I fronti di salita e discesa sono sufficientemente rapidi.
  2. La tensione Vce in saturazione e la Vce in interdizione; dovrebbero essere circa 0.3V la prima ed eguale alla tensione di batteria la seconda.

Con 800 mA in saturazione la dissipazione deve essere pari a 0.24 W, massimo 0.32 W.

Se non è ben saturato o, peggio, se le commutazioni sono lente allora io transistor dissipa molto.

Se i fronti sono lenti metti il condensatore di speed up

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
7 ore fa, Livio Orsini scrisse:

Hai fatto male!

Quel resistore serve per scaricare le cariche della base. non mettendolo il transistor si interdice più lentamente e dissipa di più

E' una mania diffusa tra certi smanettoni; non capisco cosa si risparmia ad omettere quel resistore.

 

Scusa, ma collegandolo ad una porta CMOS del micro non dovrebbe venire chiuso a massa (attraverso la resistenza di base) quando interdetto?

 

Comunque vedrò di aggiungercelo, però vedo tantissime applicazioni commerciali che non ce lo hanno...

 

7 ore fa, Livio Orsini scrisse:

Verifica se:

  1. I fronti di salita e discesa sono sufficientemente rapidi.
  2. La tensione Vce in saturazione e la Vce in interdizione; dovrebbero essere circa 0.3V la prima ed eguale alla tensione di batteria la seconda.

 

Ma dici sul 140 o sul 337?

 

Per i fronti devo vedere con l'oscilloscopio, per il 337 ho 0.08V quando è in conduzione, e la tensione di alimentazione di 7.5V quando interdetto, mentre per il 140 ho 3.9V a lampada spenta, 0.93V a lampada accesa.

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Ma la R5 l'hai messa  ? 

Come fai avere 3.9V a lampada spenta ? 

Vuol dire che il 140 è mezzo andato o le botte ricevute in base l'hanno ammaccato. 

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
5 minuti fa, gabri-z scrisse:

Ma la R5 l'hai messa  ? 

 

Si, da 1k

 

5 minuti fa, gabri-z scrisse:

Come fai avere 3.9V a lampada spenta ? 

 

Boh! Però è quel che misuro tra collettore ed emettitore...

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

Un aggiornamento, al posto del dc-dc ho collegato l'alimentatore da banco per "vederci chiaro" e con i led accesi l'assorbimento dell'insieme è di 1.1A, non 750-800mA come avevo preventivato.

 

Se abbasso la tensione di mezzo volt, l'assorbimento cala a 950mA, in tutto ciò l'assorbimento della scheda è irrisorio, saremo sui 10mA (a cui sommare la scarsa corrente di eccitazione dei 337, ma nulla che giustifichi un salto di centinaia di mA)

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini
45 minuti fa, Darlington scrisse:

Scusa, ma collegandolo ad una porta CMOS del micro non dovrebbe venire chiuso a massa (attraverso la resistenza di base) quando interdetto?

 

In questo modo la carica della base virtuale si annulla tramite il resistore in serie alla base, 2k2 in questo caso, e l'impedenza del Cmos che chiude a zero. Mentre se metti un resistore tra base ed emitter l'impedenza su cui si scarica la base virtuale risulta essere il parallelo delle due, quindi inferiore. Più bassa è questa resistenza, più velocemente si scarica la base virtuale e più velocemente il transistor si apre.

 

51 minuti fa, Darlington scrisse:

Per i fronti devo vedere con l'oscilloscopio, per il 337 ho 0.08V quando è in conduzione, e la tensione di alimentazione di 7.5V quando interdetto, mentre per il 140 ho 3.9V a lampada spenta, 0.93V a lampada accesa.

 

Per il BD140 sono valori inaccettabili.

La tensione a transistor aperto, se tu non hai fatto un errore di misura, o che l'impedenza di ingresso del voltmetro sia bassa, ha un valore che indica una fortissima corrente di perdita.

A transistor saturo la tensione è il doppio del giusto. Il valore massimo ammesso sono 0.5V con 5mA di base 0.5A di collettore. Con 0.8A non puoi avere quasi il doppio di tensione, anzi dovrebbe essere sempre 0.5V. SI tratta di dissipare 4W contro 7.5W  Con 4 W lavori senza dissipatare senza raggiungere temperature dannose, a meno di chiudere l'oggetto in un contentore di refrattario.:smile:

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington
13 minuti fa, Livio Orsini scrisse:

La tensione a transistor aperto, se tu non hai fatto un errore di misura, o che l'impedenza di ingresso del voltmetro sia bassa, ha un valore che indica una fortissima corrente di perdita.

A transistor saturo la tensione è il doppio del giusto. Il valore massimo ammesso sono 0.5V con 5mA di base 0.5A di collettore.

 

Come scritto sopra c'era un errore di valutazione di cui non mi ero accorto perché avendo collegato il dc-dc vedevo solo il suo assorbimento.

 

Se stacco il dc ed alimento direttamente a 7.5V ho 1.1A di corrente assorbita da tutto l'insieme, che calano se scendo di mezzo volt: con 7V all'emettitore, ho 0.55V di Vce mentre la lampada è accesa, in compenso ho rifatto la misura e seguito ad avere 3.5V circa di Vce a lampada spenta, se scollego i led scendono a 1.60V

Condividi questa discussione


Link discussione
Condividi su altri siti
Livio Orsini

Significa che quel transistor non è interdetto.

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×