Jump to content
PLC Forum


plfrmcmp83

Disturbo su rete profibus

Recommended Posts

plfrmcmp83

All'Interno di uno stabilimento industriale è installata una rete profibus che collega una cpu centrale alle isole di ingresso/uscita remotate, per un totale di circa 20 nodi e uno sviluppo totale di centinaia di metri. Succede che talvolta, circa un paio di volte al mese, senza una precisa logica, che la connessione tra i nodi si interrompa. Dopo diversi tentativi, tra cui sostituire la cpu e inserire dei repeater, la situazione non è risolta. Quali potrebbero essere le ulteriori verifiche da effettuare, i possibili punti critici e le cause di questi problemi? Nelle vicinanze dei nodi sono presenti anche azionamenti. Con strumenti come l'oscilloscopio è possibile dedurre informazioni utili?

Share this post


Link to post
Share on other sites

hfdax
il 31/10/2018 at 19:16 , plfrmcmp83 scrisse:

uno sviluppo totale di centinaia di metri. ...Nelle vicinanze dei nodi sono presenti anche azionamenti.

Il che rende probabile la presenza di disturbi sulla rete seriale.

 

il 31/10/2018 at 19:16 , plfrmcmp83 scrisse:

Quali potrebbero essere le ulteriori verifiche da effettuare,

la qualità della schermatura.

Share this post


Link to post
Share on other sites
luigi69

Tu riesci a capire quale nodo causa il problema ?

Se hai collegato i repeater..la linea, si svolge in senso lineare oppure ci sono "derivazioni" isolate dai repeater ? per assurdo , funzionava tempo fa e adesso ti crea problemi , o è nuova a gia da adesso si evidenziano i problemi ?  provare a spostar ei repeter su nodi differendi o su trtatti di cavo differente per individuare  il problema ?

Gli estremi linea sono chiusi correttamente ?

come ragionamento assurdo.... i connettori volanti sono bene avvitati sulle vaschette a 9 poi ?  montato tutto su piastra , o quanche espansione su portella dei quadri , per cui aprendo e chiudendo portella il cavo nuove ?

Vado a memoria sulle CPU serie 300, puoi forzare la volocità di rete molto bassa?   o mi confondo con MPI...come ulteriore prova

Share this post


Link to post
Share on other sites
Livio Orsini

Nel software d'impianto non è stato previsto un log degli errori.

Quando la rete profibus, ma anche altri bus di campo, si impianta sulla CPU master arrivano dei codici di errore.

Che tipo di CPU è il master? E' un PLC? Altro?

Share this post


Link to post
Share on other sites
hfdax

Mi avete fatto ricordare che tanti anni fa, quando lavoravo in ambito industriale sulle macchine di filatura, ogni volta che un nodo mandava in blocco la rete (erano reti RS485) scollegavo i nodi uno alla volta tenendo sott'occhio il segnale sulla seriale con l'oscilloscopio. Ma erano 144 nodi per macchina. Due palle.....:P

Share this post


Link to post
Share on other sites
Blackice

Puoi provare ad abbassare la velocità di comunicazione e vedere se il problema persiste.

Share this post


Link to post
Share on other sites
plfrmcmp83

Purtroppo al momento non ho altri dati a disposizione, vi aggiorno appena ho nuove informazioni.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...