Vai al contenuto

MusicIsLife

Circuito per suoneria 12V e lampada a led

Recommended Posts

MusicIsLife

Ciao ragazzi!

Ho costruito il circuito che vedete in fotografia per alimentare una lampada a led e una suoneria da interno (tipo din don). La suoneria funziona a 12v alternati, mentre la lampada va a 8-32v continui.

Lo scopo che avrei dovuto raggiungere con il circuito sarebbe stato il seguente: viene premuto il pulsante "campanello" all'esterno della stanza. Alla pressione di tale pulsante la lampada inizia a lampeggiare per un tempo prestabilito e nel contempo la suoneria appunto suona. Per far si che la lampada inizi a lampeggiare necessario dare un impulso a massa sulla linea "LIN".

 

Il problema é dovuto al fatto che non ho, stupidamente, acquistato un pulsante che avesse due contatti indipendenti in modo da sezionare totalmente la bobina della suoneria e, quindi, fare arrivare la tensione di 12v alternati, successivamente raddrizzato, alla linea LIN. Infatti, per come é collegato ora il circuito (il diodo D2 in serie alla bobina non é presente) la lampada inizia a lampeggiare non appena fornisco alimentazione poiché l'anodo di D1 viene portato in tensione dalla bobina della suoneria. Quindi il pulsante campanello, in questa condizione, serve solo a fare strillare la suoneria, ma non agisce sulla lampada a led.

Premesso che lo spazio che ho sulla millefiori é poco e che non voglio stravolgere il circuito, secondo voi sarebbe possibile inserire il diodo D2 in " anti serie " ad un capo della bobina della suoneria in modo da interrompere il flusso di corrente attraverso essa mentre il pulsante non è premuto? In questo modo anche il segnale LIN resterebbe alto fino a quando effettivamente il pulsante verrebbe premuto. Mi rendo conto che inserendo D2 la bobina della suoneria si troverebbe una tensione semionda raddrizzata ai suoi capi e non una tensione alternata, anche se non credo possa non permetterne il corretto funzionamento.

 

La suoneria, per capirci é la seguente: https://www.bricoman.it/n/orbassano/elettricita-illuminazione/citofoni-videocitofoni/campanelli-suonerie/suoneria-bitonale-simon-urmet-8-12vac/10042914/?gclsrc=aw.ds&&gclid=CjwKCAiA0O7fBRASEiwAYI9QApGvsNtduZXepR0sqvsjk8eO2vkjUZIGpdczlEsIWDR4oGYIQxHEvBoChOwQAvD_BwE

 

Se avete altre soluzioni proponente pure, ovviamente!!

 

Una curiosità mia: il pulsante che utilizzo é quello da frutto a muro, ed é largo 2 posti con targhetta inclusa. Come mai ha 3 contatti e non semplicemente 2? Ha anche il foro che dovrebbe essere per la luce della targhetta. Questo é il pulsante in oggetto. https://www.leroymerlin.it/catalogo/pulsante-con-targhetta-portanome-illuminabile-feb-flat-bianco-35097566-p

IMG_20181127_082836.jpg

Condividi questa discussione


Link discussione
Condividi su altri siti
patatino59
24 minuti fa, MusicIsLife scrisse:

non ho, stupidamente, acquistato un pulsante che avesse due contatti

Ma col pulsante ci puoi azionare un relè, e a seconda degli scambi disponibili (per es. 2,3,4) farci piu cose.

Inoltre, se il pulsante è illuminabile e la lampadina a 220V è inclusa, hai un terzo contatto per la sua alimentazione serale.

In questo caso, utilizzando un relè con bobina a 220 V AC puoi gestire la parte di comando a 220V e il resto (dopo il relè)  a bassa tensione.


Messaggio editato da patatino59

Condividi questa discussione


Link discussione
Condividi su altri siti
tesla88

Può essere che mi sbagli ma se raddrizzi a singola semionda risolvi :

ABCABCABC.JPG

Scusa lo schema di brutta ma andavo di fretta...


Messaggio editato da tesla88

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

@tesla88 sai che probabilmente hai ragione?

Volevo usare il ponte di Greatz per avere meno ripple di tensione avendo due semi onde, ma alla fine posso raddrizzare a singola semi onda visto che la lampada ha in ingresso un DC/DC che non avrà problemi a prendere una tensione con un po' di ripple.

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

@patatino59 non ho a disposizione la 220v sul pulsante citofono. Al pulsante citofono ho già tirato i fili che collegherò ai 12v alternati.

Più che altro cercherei una modifica semplice e che impatti poco sul circuito che ho già realizzato.

Provo la strada suggerita da tesla e vediamo se funziona.

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

Ciao ragazzi, vi aggiorno in merito alle prove fatte.

Ho modificato il circuito come detto solo che non funziona.

La suoneria suona ogni volta che chiudo il contatto, ma la lampada non parte.

Ho misurato tra LIN e GND con un tester in DC. Quando il pulsante non é premuto ho circa 16V DC; quando premo, la tensione scende a 8V e quindi la lampada non parte.

Considerate che all'interno sella lampada c'è una R da 10k tra LIN e VCC, poi un partitore con due resistenze da 10k tra LIN e GND.

Ho abbassato la resistenza di collettore anche a 1k, nulla da fare.

Avete idee?

Grazie!

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Non saprei come è fatta la lampada , sarebbe utile sapere cosa sono LIN , VCC e GND per la lampada e come sono collegati al circuito .

Al interno dici che sia così :1748839110_ledsuoneria.GIF.6a60ee06d9bdc722460bbe3120653388.GIF   ?

10 ore fa, MusicIsLife scrisse:

Considerate che all'interno sella lampada c'è una R da 10k tra LIN e VCC, poi un partitore con due resistenze da 10k tra LIN e GND

 Non potrebbe andare.....


Messaggio editato da gabri-z

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

Ciao a tutti.

 

Allego un immagine del circuito completo, ovvero la parte che ho realizzato e la parte di interesse interna alla lampada.

La lampada ha all'interno un DC/DC che accetta 8-32V in ingresso e all'uscita di tale blocco DC/DC sono connessi i LED.

All'alimentazione principale (VCC) è connesso un LDO che genera 12V in uscita. A tale LDO è connessa la rete che vedete in immagine.

 

Ricordo che la condizione per far partire la lampada (che lampeggia per 20 secondi e poi si ferma) è quella di portare sulla net "uC" un segnale letto come "0" per un tempo di almeno 10ms.

 

 

Ho fatto le seguenti prove (se il tester non mente).

1) Suoneria scollegata.

Sul nodo LIN, quando chiudo il contatto "citofono", misuro circa 5,5V. Quindi mi sembra che il BC337 non sia polarizzato correttamente, in questa situazione.

Nonostante ciò la lampada parte, poiché sulla net che va al microcontrollore "uC" avrei circa 3,8V e la soglia per lettura dello "0" è impostata a 4V.

Non vorrei sbagliarmi, ma sulla base del BC337 (nodo C) ho letto 2,5V.

 

2) Suoneria collegata.

In questo caso la suoneria suona, ma la lampada non parte in alcun modo. La tensione misurata sulla linea LIN è infatti superiore a 11V. Sul nodo B ho una tensione pari a 0V.

 

 

IMG_20181203_094800.jpg

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

Ciao ragazzi.

Ho scoperto che il diodo riquadrato in rosso nell'immagine sottostante (1N4148) era andato (segnava 45 Ohm).

L'ho sostituito e ho verificato le tensioni nel caso in cui la suoneria non sia presente e la lampada invece sia collegata. Effettivamente ora il collettore del BC337 si porta a quasi 0V.

 

Mi è venuto il dubbio che il diodo potrebbe essersi rotto a causa dell'extra tensione che si trova sul suo anodo nell'istante in cui lo SW del citofono viene rilasciato. Infatti la corrente che scorre nella suoneria, che è un circuito di tipo induttivo, non può ricircolare da altre parti se non nel diodo rotto, il quale si trova una tensione di reverse che schizzerebbe in alto.

Per risolvere questo problema ho introdotto un varistore da 25V connesso come in fotografia, che dovrebbe limitare la tensione sull'anodo del diodo 1N4148 evitando che si rompa.

 

Credete che possa andare bene come soluzione?

Appena posso collego anche la suoneria (in questo momento non l'ho qui) e provo tutto.

 

 

 

IMG_20181203_141103.jpg

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

A me è sembrato strano dal inizio il 4148, perché non metti dei 1N4004/7? 

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

Ciao gabri.

Non avevo a disposizione il diodo 1N400x e quindi ho messo il 1N4148 anche perché la pista riferita al diodo in oggetto é di segnale.

Comunque questa sera ho collegato il circuito alla lampada e alla suoneria e sembra funzioni tutto con il variatore inserito. Magari appena posso vi aggiornò sulle tensioni nel vari punti del circuito.

 

Sta di fatto che, per sicurezza, sostituirò il 1N4148 con il 1N400x appena lo recupero.

Condividi questa discussione


Link discussione
Condividi su altri siti
tesla88

il 4148 potrebbe anche guastarti perché deve caricare un 47uF che quando è scarico è come fosse un corto, metti in serie al diodo  una resistenza per limitare la corrente, comunque metti un 1n4007 o simili. 

Condividi questa discussione


Link discussione
Condividi su altri siti
sx3me

meglio 1N5399... i miei preferiti... :)

Condividi questa discussione


Link discussione
Condividi su altri siti
MusicIsLife

Diodo sostituito.

Ho messo un 1N4007 e ho riprovato con tutto connesso. Funziona!

 

Grazie del supporto!

 

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×