Vai al contenuto

olometabolo

Modifica aspirapolvere a batterie

Recommended Posts

olometabolo

Buongiono

Ho un aspirapolvere a batterie che inizia a perdere colpi.
Il problema, sono le 4 batterie AA che vanno cambiate.
Ma visto che mi trovo sotto mano un paio di lipo 18650 pensavo di usarele. Lo so che la tensione é molto piu alta 4.7V contro 7.2V ma ho provato e il motore gira senza scaldarsi troppo (inoltre lo stesso modello é venduto con varie "potenze" tra cui una alimentata a 7.2v).
Il problema é che per rendere sicura carica e scarica ho installato un bms per 2 batterie con equilibrazione della carica https://it.aliexpress.com/item/2-s-2-Ce ... 4c4deK6Ich
Ha protezione contro le sovracorrenti a 10A in continuo e 20A di picco
Il problema é che va in protezione
Ho misurato la corrente con una pinza amerometrica e a regime ho 7-8A con un picco iniziale di 10-11A (ma so che la pinza non é abbastanza rapida per farmi vedere il vero valore di spunto)
La resistenza del motore é di 0.2ohm (che à batterie cariche 8,3V fa 41.5A)
Qui trovate lo schema di come funzione la schedina https://github.com/megasaturnv/HX-2S-JH ... ection-PCB
Pensavo di prendere uno spezzone di cavo di rame e meterlo in parallelo alle due resistenze da 0.005ohm  cosi da modificare la resistenza di shunt e fargli credere che passa meno corrente.

Il mosfet FDD6030l tiene fino a 50A di picco percui dovrebbe essere ok

Cosi facendo non perdo le protezioni di carica sarica e il bilanciamento
Secondo voi esiste qualche altro modo per far funzionare il tutto?
grazie


Messaggio editato da olometabolo

Condividi questa discussione


Link discussione
Condividi su altri siti
Darlington

Invece di modificare qua e là senza cognizione di causa, come prima cosa inizierei a vedere che non siano le batterie a sedersi per via del rateo di scarica inadatto. 

 

Le litio non sono tutte uguali, esistono quelle per "basse correnti" usate in cellulari, mp3, torce elettriche non troppo potenti e poi esistono le "high drain" usate nei power tools, nelle sigarette elettroniche ed in tutti gli apparecchi dove la corrente di scarica supera 1C.

 

Se usi una batteria non adatta la tensione scende ed il circuito interrompe l'erogazione perché è lo stesso comportamento della batteria quasi scarica 

Condividi questa discussione


Link discussione
Condividi su altri siti
olometabolo
19 minuti fa, Darlington scrisse:

Invece di modificare qua e là senza cognizione di causa, come prima cosa inizierei a vedere che non siano le batterie a sedersi per via del rateo di scarica inadatto. 

 

La cognizione di causa credo di averla chiarita

Infatti so che il problema sono le batterie che come é normale che sia dopo qualche anno e tante cariche scariche perdono le loro caratteristiche.

Per la precisione ci sono 4 elementi al NiCa da 1.2V 1200mah in serie

Anche da nuovo l'aspirapolvere dopo 5 minuti iniziava a perdere potere aspirante e a 10 non era piu utilizzabile( il che mi sembra logico con un assorbimento di 3-4A)

Visto che 4 buone batterie AA costano 20e e che ho 20 18650 che non uso (marca samsung e sony di memoria certificate per 20A continui) ho pensato di fare la modifica

28 minuti fa, Darlington scrisse:

Se usi una batteria non adatta la tensione scende ed il circuito interrompe l'erogazione perché è lo stesso comportamento della batteria quasi scarica

Dovrei verificare con un oscilloscopio ma con il multimetro non ho visto cali di tensione.

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z
7 ore fa, olometabolo scrisse:

4 buone batterie AA costano 20e

Intendi dire Euro ? 

Condividi questa discussione


Link discussione
Condividi su altri siti
olometabolo
14 ore fa, gabri-z scrisse:

Intendi dire Euro ? 

si non avevo premuto alt gr :-)

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Non avevo problemi con il simbolo , ma con i 20 ! 

22 ore fa, olometabolo scrisse:

Visto che 4 buone batterie AA costano 20e

Ma sono ricaricabili ?

Condividi questa discussione


Link discussione
Condividi su altri siti
olometabolo
1 minuto fa, gabri-z scrisse:

Non avevo problemi con il simbolo , ma con i 20 ! 

Ma sono ricaricabili ?

Si comunque 20€ ho esagerato diciamo 10-15€

Comunque sempre troppo rispetto a quelle che ho gratis :-)

Condividi questa discussione


Link discussione
Condividi su altri siti
olometabolo
il 6/12/2018 at 13:06 , Darlington scrisse:

Se usi una batteria non adatta la tensione scende ed il circuito interrompe l'erogazione perché è lo stesso comportamento della batteria quasi scarica  

 

Effetivamente ho misurato con l'osciloscopio e la tensione scende troppo (5V) al momento dell'accensione. Le batterie sono di recupero e probabilmente hanno perso la loro vitalità

Collegando i cavi direttamente dalla batteria al motore dopo lo spunto inziale la tensione risale e si assesta.

Un idea sarebbe di mettere una resistenza in serie e un condesatore in parallelo al circuito che misura la tensione con il giusto rapporto dovrei riuscire ad aggiungere un delay allo stacco per tensione troppo bassa

che ne pensate?

PS

Visto che la tensione scende cosi tanto il problema della troppa correnti si auto risolve

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×