Vai al contenuto

Mauro Dalseno

Pickit 3 e MPLAB IDE

Recommended Posts

Mauro Dalseno

Ho un piccolo problema da risolvere per chi ha pratica:

Ho ricevuto un file .hex da installare sopra ad un Pic 16F886 che ho appena acquistato, per fare questa operazione ho disponibile il PICKit 3 e ho installato MPLAB IDE v.8.86, il problema è che non riesco a capire come trasferirlo sul processore.

Ho fatto la procedura per impostare il PIC Giusto, la procedura per alimentarlo a 5V, lui si accende regolarmente ma il programma non riesco a trasferirlo... Ho trovato un tutorial ma è fatto con vecchie versioni che sono diverse, oppure trovo qualcosa in inglese che non mastico. Qualche buon anima non mi spiegherebbe passo per passo come fare a importarlo regolarmente e trasferirlo?

Grazie a chi mi risponderà

Condividi questa discussione


Link discussione
Condividi su altri siti
Lcucinelli

buonasera , io uso il pickit3 come programma, uso la funzione import exe , penso che dovrebbe essere molto simile.

Condividi questa discussione


Link discussione
Condividi su altri siti
dott.cicala

File>Importa

selezioni il tuo file HEX,

vedrai la conferma dell'importazione nella finestra OUTPUT>Build

Vai su Programmer e premi Program

Condividi questa discussione


Link discussione
Condividi su altri siti
Mauro Dalseno
21 ore fa, dott.cicala scrisse:

File>Importa

selezioni il tuo file HEX,

vedrai la conferma dell'importazione nella finestra OUTPUT>Build

Vai su Programmer e premi Program

Stefano è un po scarna la tua risposta io ci provo....

altrimenti proverò a scaricare il programma consigliato da Cucinelli, ieri sera l'ho cercato, ma ero troppo cotto e non ho trovato nemmeno dove si scarica sul sito Microchip

 

Grazie a tutti e due, vi saprò dire

Condividi questa discussione


Link discussione
Condividi su altri siti
Mauro Dalseno

GRANDE 😀

sono a debito di un caffè!!!!

Condividi questa discussione


Link discussione
Condividi su altri siti
gabri-z

Si vede che non occorreva un messaggio da dieci pagine :smile: Corto , secco , preciso.:thumb_yello:

Condividi questa discussione


Link discussione
Condividi su altri siti
Mauro Dalseno

il problema è che utilizzavo un file .hex per un Pic diverso, infatti già facevo la procedura corretta utilizzando le apposite iconcine del programma, ma non ero sicuro di procedere nel modo corretto... Quando ho fatto la procedura di Stefano ottenendo lo stesso risultato ho capito che l'errore era altro, infatti ho provato su un Pic diverso e magicamente funzionava...

22 ore fa, gabri-z scrisse:

Si vede che non occorreva un messaggio da dieci pagine :smile: Corto , secco , preciso.:thumb_yello:

effettivamente è corto e a prova di ignorante :wallbash:

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×