Jump to content
PLC Forum


marcook

Filtro per modulo relay arduino uno

Recommended Posts

marcook

Buongiorno, avrei un problema riguardo una serratura elettrica da 12v a connessa ad un progetto arduino funzionante. A parole arduino è connesso ad un sensore di peso: se il peso rilevato è compreso in un intervallo specifico parte un codice che aziona attraverso un modulo relay da 4 elementi la serratura in questione, un motorino di un tergicristalli prima in senso orario e poi antiorario. Inoltre c'è un display che descrive all'utente le varie fasi contando anche il numero di volte che il codice si aziona. Inizialmente tutto il progetto era sviluppato senza la serratura, ma successivamente è nata l'esigenza di aggiungerla e qui è successo un disastro: a causa del picco di tensione ai capi del relè arduino si riavvia e nel tempo sicuramente svilupperà dei danni, per cui si rende necessario impedire questo picco. Ho letto in giro che la cosa è risolvibile inserendo in parallelo un diodo e due condensatori, uno da 100uf e uno da 0.1uf. Il diodo può andar bene un 1N4007. Il fatto è che prima agire vorrei un parere su chi ne sa più di me su questo genere di cose, perchè è il mio primo progettino. Premetto che ho provato anche ad alimentare la scheda relè esternamente togliendo il ponte ma niente. Io vorrei collegare i componenti in questo modo:

WhatsApp Image 2019-04-27 at 19.43.45.jpeg

e così dovrebbe essere come va inserito il diodo

diodi_5.jpg

 

 

Grazie per l'aiuto

Edited by marcook

Share this post


Link to post
Share on other sites

ilguargua

L'alimentazione a 12V alimenta anche l'arduino?

 

 

Ciao, Ale.

Share this post


Link to post
Share on other sites
Livio Orsini

A parte il fatto che i diodi in antiparallelo al carico induttivo sono il minimo sindacale, per i diturbi che mandano in crisi arduino servono a poco, anzi a nulla.

 

Devi alimentare Arduino con una sua alimentazione separata galvanicamente dall'alimentazione dei dispositivi in campo. ptaticamente significa derivare l'alimentazione daun trasformatore dedicato solo ad arduino.Possibilmente che sia alimentato da un filtro di rete e, magari, mettere anche una bella cella pigreco C-L-C immediatamente all'ingresso alimentazione di arduino.

 

Poi i comandi verso il campo vanno effettuati tramite linee optoisolate, idem per i segnali provenienti dal campo.

 

In questo modo ci sono ragionevoli speranze di non avere problemi di disturbi.

A questa architettura non ci sono arrivato per ispirazione dello spirito santo,ma dopo aver sbattuto la faccia su alcuni problemi.

Edited by Livio Orsini

Share this post


Link to post
Share on other sites
marcook
2 ore fa, ilguargua scrisse:

L'alimentazione a 12V alimenta anche l'arduino?

 

 

Ciao, Ale.

Si, parte tutto da un trasformatore 220v 12v 30A che si usano per i led e da lì alimento tutto

 

1 ora fa, Livio Orsini scrisse:

A parte il fatto che i diodi in antiparallelo al carico induttivo sono il minimo sindacale, per i diturbi che mandano in crisi arduino servono a poco, anzi a nulla.

 

Devi alimentare Arduino con una sua alimentazione separata galvanicamente dall'alimentazione dei dispositivi in campo. ptaticamente significa derivare l'alimentazione daun trasformatore dedicato solo ad arduino.Possibilmente che sia alimentato da un filtro di rete e, magari, mettere anche una bella cella pigreco C-L-C immediatamente all'ingresso alimentazione di arduino.

 

Poi i comandi verso il campo vanno effettuati tramite linee optoisolate, idem per i segnali provenienti dal campo.

 

In questo modo ci sono ragionevoli speranze di non avere problemi di disturbi.

A questa architettura non ci sono arrivato per ispirazione dello spirito santo,ma dopo aver sbattuto la faccia su alcuni problemi.

No certo non lo metto in dubbio. Quindi se ho capito bene, al di là del discorso del diodo posso provare a vedere se alimentando separatamente arduino il disturbo sparisce anche senza diodo? Per il filtro di rete e cella pi greco mi documento perchè ne ho solo sentito parlare.

Share this post


Link to post
Share on other sites
ic910

Mi è capitato che gli alimentatori per i led  a commutazione  non siano filtrati in maniera ottimale in uscita.

Inoltre hanno un rumore insito per loro natura.

Come già detto da Livio conviene utilizzare un trasformatore dedicato da 230Vac 12Vac 3/2 VA per alimentare solo Arduino con un regolatore di tensione dedicato e filtrato.

 

Share this post


Link to post
Share on other sites
ilguargua
2 ore fa, marcook scrisse:

Si, parte tutto da un trasformatore 220v 12v 30A che si usano per i led e da lì alimento tutto

Come ti hanno già detto, se puoi provvedere ad una alimentazione separata è senz'altro meglio. Puoi anche tentare una soluzione di questo tipo :

itv38.thumb.jpg.2d95d2a81fc0865e91a480a1740b5c8b.jpg

 

Se alimenti l'arduino dal jack esterno puoi omettere la prima sezione e usare l'uscita "driver", oppure usare un 7808 al posto del 7805, non so quanta roba alimenti con i 5V dell'arduino, con 12V in ingresso il regolatore integrato si stressa già abbastanza.

 

Ciao, Ale.

 

Share this post


Link to post
Share on other sites
Livio Orsini

Ale è la prima soluzione che provai: non funziona!

S e non c'è separazione galvanica completa tra arduino ed i circuiti "di campo", i disturbi entrano. Cos' come entrano dalla rete, anche se c'è un trasformatore e filtri sulla continua. E' praticamente indispensabile anche il filtro di linea prima del trasformatore dell'alimentatore di Arduino.

Addirittura se non si separano i 2 trasformatori, ma si usano 2 secondari del medesimo trasformatore, entrano diturbi sufficienti a bloccare il tutto.

 

Poi anche la disposizione dei componenti ed il cablaggio ha importanza.

Arduino è comodo, facile da usare, ma è stato previsto per altri scopi e questo lo rende molto sensibile ai disturbi EMC.

 

15 ore fa, marcook scrisse:

Quindi se ho capito bene, al di là del discorso del diodo posso provare a vedere se alimentando separatamente arduino il disturbo sparisce anche senza diodo? Per il filtro di rete e cella pi greco mi documento perchè ne ho solo sentito parlare. 

 

Il diodo va comunque messo.

Il filtro di rete lo devi acquistare belo è montato e, soprattutto, di buona qualità; l'ideale sarebbe uno Shaffner.

Il fitro "pi grego" lo metti sulla continuia, molto vicino al connettore di arduino. Si tranna di 2 condensatori e di una induttanza. Un condensatore elettrolitico tra "+" e 0V, un'induttanza in serie al "+" ed un altro condensatore da circa 0.33µF ceramico tra l'altro capo dell'induttanza e lo 0V

Share this post


Link to post
Share on other sites
ilguargua
11 minuti fa, Livio Orsini scrisse:

Ale è la prima soluzione che provai: non funziona!

Beh, garanzie non ce ne sono, ma quella soluzione se ben ti ricordi risolse il problema in un altra discussione (ho provato a cercarla ma non la trovo), anche se in effetti il problema era diverso (PWM led con mosfet e relativo driver). Concordo, come ho già premesso, che separare completamente le 2 alimentazioni sia la soluzione migliore. Poi, come accade spesso, parliamo sempre per ipotesi : l'OP cita un sensore di peso, motori e relè, ma senza uno schema e foto dei cablaggi è difficile dire che cosa esattamente genera il disturbo, o meglio tramite cosa il disturbo entra nell'arduino.

 

Ciao, Ale.

Share this post


Link to post
Share on other sites
Livio Orsini
10 minuti fa, ilguargua scrisse:

anche se in effetti il problema era diverso (PWM led con mosfet e relativo driver

 

E' molto differente. Se il dirver dei LEDs è almeno decente ha già dei filtri per abbattere i pochi disturbi che può generare un carico puramente (quasi) resistivo.

 

Poi, ripeto, io mi ci sono scontrato ed alla fine ne ho fatto una questione di principio.

Il vero grande problema è che la situazione in cui non ha una completa separazione galvanica può anche funzionare in apparenza. Poi, in modo csuale, ogni tanto arduino perde il controlo del programma; resetti arduino e tutto torna a funzionare correttamente sino al prossimo "sfarfallamento".

Share this post


Link to post
Share on other sites
ilguargua
2 ore fa, Livio Orsini scrisse:

Se il dirver dei LEDs è almeno decente

Mi sono espresso male, il driver era per il mosfet, che poi pilotava i led, comunque si, un caso diverso.

 

 

Ciao, Ale.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...