Jump to content
PLC Forum


KK43

Info su Relè

Recommended Posts

KK43

Ho un centralina di una lavatrice dove per azionare la resistenza viene usato un comunissimo relè 12VDC - 250VAC con 10A di portata. L'ho testato e ho appurato la bontà dell'avvolgimento. Applicando una tensione ai sui capi il relè chiude senza problemi , però mi chiedo è possibile che non chiuda il contatto quando sui contatti vi è montato un carico? 

Share this post


Link to post
Share on other sites

Darlington

è una ipotesi piuttosto rara, anche se non impossibile, io sono convinto che il problema sia altrove 

Share this post


Link to post
Share on other sites
Lcucinelli

Buonasera , puoi testarlo alimenta la bobina come hai gia fatto e verifica se lo scambio si chiude, con valori prossimi allo 0 ohm , se questa prova l' hai gia fatta considera il rele funzinante, verifica invece se arriva tensione ai capi della bobina quando è in funzione la lavatrice.

Share this post


Link to post
Share on other sites
KK43

Purtroppo , come quasi sempre succede , non avendo uno schema elettrico ho cercato di ricostruirlo partendo dall'alimentazione. La scheda è alimentata direttamente dalla 220v , senza trasformatore , dove viene utilizzato un condensatore in serie per far cadere la tensione che poi viene raddrizzata da diodi e filtrata da un condensatore e stabilizzata da uno zener a 12V. Visionando la scheda ho notato che a monte vi era una resistenza di basso valore ohmico un pò annerita  , ma non interrotta e in parallelo tra la fase e il neutro ho trovato un varistore esploso , indice di un picco di sovratensione. La parte di rettifica è ok , quindi credo che il varistore abbia fatto il suo sporco lavoro. La problematica della lavatrice è che lava con acqua fredda , in ogni caso.  Quindi come seconda cosa sono andato a verificare il percorso che va dal microcontrollore alla bobina del relè , trovando qualche transistor , nello specifico , quelli "digitali" con internamente già le resistenze di polarizzazione un esempio : Datasheet . Non riesco a venirne a capo , ormai ho controllato quasi tutti i componenti , dai semiconduttori ai resistori e in nessuno ho trovato dei guasti . Procederò a cambiare i due condensatori di filtraggio per sicurezza ma non credo sia li il problema , ma visto che ci sono ne approfitto visto che comunque hanno prestato servizio da 6 anni .Ovviamente cambierò anche varistore e resistenza , ma anche quelli ai fini del risultato finale non hanno nessun peso. In sintesi , la logica interna della lavastoviglie è ok , non scalda! 🤯

Share this post


Link to post
Share on other sites
Darlington
26 minuti fa, KK43 ha scritto:

La problematica della lavatrice è che lava con acqua fredda

 

e ti da qualche errore?

 

se la risposta è no, inizia sostituendo la sonda di temperatura piuttosto che fissarti sul guasto impossibile 

Share this post


Link to post
Share on other sites
KK43

@Darlington

Non da nessun errore.

Secondo chi mi ha fornito la scheda , la sonda NTC è stata sostituita , purtroppo non ho avuto modo di vederla e testarla , ma in quanto nuova credo sia da escludere...

Edited by KK43

Share this post


Link to post
Share on other sites
Vincenzo Durante 2001

Cosa importante la resistenza è ok? 

Share this post


Link to post
Share on other sites
KK43

Ora mi viene un dubbio , ho misurato dei transistor serigrafati A8A e A6A che credo corrispondano a questi tipi di transistor, correggetemi se sbaglio: A6A A8A . Internamente sono fatti cosi " prendo come esempio l'NPN " 

Se lo misuro come se fosse un normale npn in realtà non saprei se la giunzione BE è in corto o sbaglio? Come si può misurare l'integrità di tali componenti?

Cattura 5.PNG

Edited by KK43

Share this post


Link to post
Share on other sites
patatino59
7 ore fa, KK43 ha scritto:

Come si può misurare l'integrità di tali componenti?

O verifichi il componente sotto tensione,con tester e batteria, o montato, con pilotaggio attivo.

Se il suo scopo è di condurre quando la base è polarizzata non c'è altro modo.

Share this post


Link to post
Share on other sites
Livio Orsini

La lavatrice quando va in riscaldamento si ferma ed attende che latemperatura sia quellaprevista.

Se lava a freddo ilproblema non è nella parte riscaldante ma èo nella misura di temperatura o nella scheda di controllo.

 

tutto il lavoro che stai facendo è inutile.

Share this post


Link to post
Share on other sites
KK43

@Livio Orsini

Perdonatemi per il lapsus ma ieri sera non so cosa avevo nella testa . Non stiamo parlando di una lavatrice ma bensì di una lavastoviglie . Chiedo venia 😁 Il principio di funzionamento però rimane il medesimo o sbaglio ?

Share this post


Link to post
Share on other sites
gabri-z

😀

 Anche io faccio prima dire lavatrice al posto di lavastoviglie....

Share this post


Link to post
Share on other sites
Livio Orsini

Che lavi stoviglie o biancheria, dal punto di vista del tuo problema nulla cambia.

 

Se lava a freddo ilproblema non può essere nella resistenza o nel relè che la comanda, ma deve essere o nel sensore di temperatura o nella scheda di controllo.

Share this post


Link to post
Share on other sites
KK43

@Livio Orsini

😁 Scusa Livio , ma  se la scheda di controllo comanda la  il transistor e il transistor fosse rotto , di conseguenza la resistenza che è attaccata al rele non si chiude sul neutro in questo caso . O sbaglio?

Share this post


Link to post
Share on other sites
Livio Orsini

Quando il controllore comanda il riscaldamento il programma si arresta in attesa che l'acqua raggiunga la temperatura prevista.

Se ci fosse un guasto alla parte riscaldante, dal comando del controllore in poi, il processo di lavaggio si fermerebbe a tempo indeterminato.

Invece tu dici che la va a freddo, quindi ci sono solo 2 possiiblità: la misura di temperatura è errata ed il processore rileva sempre una temperatura => al valore impostato, oppure è guasto il il controllore e salta il ciclo di riscaldamento.

 

Se le cose stanno come le hai descritte, è inutile che tu ti interstardisca a controllare la parte riscaldante.

Share this post


Link to post
Share on other sites
KK43

Grazie Livio mi sei stato molto d'aiuto , purtroppo non operando nel settore non ero a conoscienza della logica interna :)

Edited by KK43

Share this post


Link to post
Share on other sites
Trans Istor

Ciao, io non conosco le lavatrici e non so se Livio le riparava o progettava pero'  faccio una supposizione, se il programma della lavast. usa la sonda per temporizzare la durata del riscaldamento ma se questo non avviene salta al passo successivo comunque, andrebbe comunque controllato se il relè viene commutato durante il programma..

o meglio, se il transistor che lo pilota riceve l' impulso.. questo però trovo che abbia poco a che fare con un varistore esploso, essendo il relè a 12v usera' una tensione diversa da quella del microcontrollore, forse la linea 12v e' andata a pallino.

Edited by Trans Istor

Share this post


Link to post
Share on other sites
Lcucinelli
21 hours ago, KK43 said:

 

Se lo misuro come se fosse un normale npn in realtà non saprei se la giunzione BE è in corto o sbaglio? Come si può misurare l'integrità di tali componenti?

Cattura 5.PNG

 

Buonasera , se il disegno del transistor che ha postato è corretto , la giunzione BE è baypassata da una resistenza .

Dissalda il componente e misura la tensione ai capi della Base in questo modo ti accerti se il transistor e pilotato dal microprocessore .

Io concordo con Livio  che il micro fa proseguire il programma perché non vede un setup di temperatura.

Possibili cause forse il programma stessso del micro corrotto.

Comunque prova a staccare la sonda ntc avvia apparecchio e vedi se ti tira fuori qualche errore o si blocca il programma.

Verifica il valore ohmico della sonda a temp ambiente.

 

Share this post


Link to post
Share on other sites
Darlington

nelle lavastoviglie di solito viene misurato il rateo di salita della temperatura: se la sonda sente che la temperatura entro tot minuti non è salita almeno di tot gradi conclude che qualcosa non va e da un errore. 

 

se la sonda sente l'acqua già calda allora non da errore ma non prova neppure a scaldarla perché dal suo punto di vista non è necessario 

Share this post


Link to post
Share on other sites
Livio Orsini
10 ore fa, Darlington ha scritto:

se la sonda sente che la temperatura entro tot minuti non è salita almeno di tot gradi conclude che qualcosa non va e da un errore. 

 

Esatto, se non ci sono messagi di errore, e KK43 non ne fa cenno, allora il problema sta nella sonda o nella scheda.

Share this post


Link to post
Share on other sites
_angelo_

Fosse mia, seguirei le spiegazioni di Darlington e Livio, verificando bene ed escliudendo 100% la parte di misura, incluso il relativo circuito sulla scheda. Faston ben stretti etc. 

 

I transistor vanno tante volte in corto tra C ed E. Si da un occhio col tester prima senza smontare. Poi se da un valore prossimo allo 0, si dissalda, e dunque puoi fare la prova accademica delel giunzioni in entrambi i sensi, senza dimenticare il test C-E.

 

Rele', nel dubbio, puoi dissaldarlo e testarlo a tavoino con tanto di carico. Ma prima verificare che tutte le tensioni d'alimentazione della scheda siano in ordine, spesso problemi derivano da alimentazioni mancanti o variabili (cambio condensatori su schede vecchie fa sempre bene).

Edited by _angelo_

Share this post


Link to post
Share on other sites
causicurti

A questo punto sposterei la discussione su Riparazione Lavastoviglie.

Share this post


Link to post
Share on other sites
Darlington
17 ore fa, _angelo_ ha scritto:

Fosse mia, seguirei le spiegazioni di Darlington e Livio, verificando bene ed escliudendo 100% la parte di misura

 

purtroppo come mi è capitato di vedere buona parte degli utenti considera "la scheda" come fonte di tutti i mali, oramai è passato del tempo da quando mi chiamarono perché una Electrolux scaricava di continuo e non faceva selezionare il programma, quindi "la scheda" era andata e non volevano spendere centinaia di euro per "la scheda" . Mi portarono anche "la scheda" ed io risposi che dovevo vedere il guasto sul posto. Morale "la scheda" non aveva proprio nulla che non andasse, era l'antiallagamento che su quel modello tagliava fuori l'elettronica ed alimentava direttamente la pompa di scarico. Una flangia si era rotta, loro ovviamente non avevano dato peso alla cosa "tanto funziona" , ed i continui trafilamenti avevano gonfiato il polistirolo al punto che il galleggiante restava su anche quando l'acqua si era asciugata del tutto.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...