Jump to content
PLC Forum


Andrea086

Ac Dc 5v PSR

Recommended Posts

Andrea086

Salve a tutti.

Ho acquistato un alimentatore tipo open frame ed ho eseguito un reverse engineering, riproducendo la scheda pcb tramite questo schema.

Funziona solo con un piccolo carico, aumentando va in protezione e si riavvia continuamente.
Ho controllato le tensioni con l'originale, l'unica che cambia di molto è la VDD sul diodo D1. VCC originale 7,8V, VCC scheda clone 11,2V.

Sul diodo smd c'è scritto "F7", cercando su internet ho ipotizzato fosse un FR107W. 

Secondo il vostro parere ho sbagliato in questo?

Grazie

 

 

Cattura1.thumb.JPG.c53aad4877a7903e01ed1b53362e29ec.JPG

Cattura11.JPG

Cattura111.JPG

Edited by Andrea086

Share this post


Link to post
Share on other sites

dott.cicala

Lo schema non mi sembra corretto.

Il Cs che legge la cdt sulla R5 ha la R5 collegata a massa?? E che corrente può scorrerci così?

Share this post


Link to post
Share on other sites
Andrea086

Si ti confermo, la resistenza R5 da 2.4r è collegata a massa. Non saprei quanta corrente potrebbe scorrere, guarda questo schema in allegato l'ho preso dal datasheet del produttore.

Ht2812h diagram.JPG

Share this post


Link to post
Share on other sites
Gorilla-K2

Senti ma mi sembra strano che il feedback venga preso dall'uscita aux del trasfo, secondo me la R4 ha piu senso collegata sul catodo di D1, poi la Rsense (R5) da 2R4 non ne ho mai vista una sopra l'ohm, non sara' 0,24?

Edited by Trans Istor

Share this post


Link to post
Share on other sites
Andrea086

Ho controllato nuovamente il pcb originale sperando di aver sbagliato, invece no. La resistenza 2r40 misurata 2,4 ohm e il feedback collegato come da schema diretto all'uscita aux.

Tutto funziona però se varia il carico velocemente l'alimentatore va in protezione, come se vedesse un corto. Potrebbe essere la tensione VCC troppo alta? 

Ho fatto una prova: per abbassare la tensione sul pin VCC ho inserito tre diodi, la stessa è scesa a 8V consentendo il funzionamento anche variando il carico velocemente.

Non capisco dove sbaglio 

Share this post


Link to post
Share on other sites
patatino59

Per me, vista l'enorme semplificazione del circuito, il Layout dello stampato potrebbe provocare qualche autooscillazione.

Share this post


Link to post
Share on other sites
Gorilla-K2

Viene subito spontaneo chiedersi dove hai beccato il trasformatore compatibile, potrebbe esserci un errore nell'avvolgimento aux o nella scelta del nucleo, con la modifica dei diodi hai controllato la correttezza dell'uscita (V)?

Share this post


Link to post
Share on other sites
Andrea086

Ecco il problema, questi nuovi trasformatori hanno un avvolgimento diverso. 13 giri in meno rispetto a quello originale 😫.

La tensione con in serie i tre diodi variava di 200mV.

Secondo voi posso adattare il circuito?

20200113_083633.jpg

Share this post


Link to post
Share on other sites
Livio Orsini

Quell'alimentatore è un classico flyback dove il cuore di tutto il sistema è il traformatore.

Da come è messo, e da come è fatto, l'avvolgimento di reazione dipende il buon funzionamento di tutto l'alimentatore.

Mi ero fatto una cultura in merito attorno al 1975 quando, per un breve epriodo, ho progettato alimentatori SMPS per TV.Basta una piccola differenza di posizionamento dell'avvolgimeto, oppure una spira in più o in meno, per avere un cambio drastico delle prestazioni.

 

15 ore fa, Andrea086 ha scritto:

VCC originale 7,8V, VCC scheda clone 11,2V.

 

Già questo è un indizio molto preciso.

 

Abbiamo inserito il messaggio quasi contemporaneamente, quindi ho visto solo dopo le caratteristiche del trasformatore.

Questo conferma la diagnosi iniziale.

Per prina cosa lavora sul partitore R3-R4.

Inoltre la variazione del rapporto di trasformazione modifica anche la tensione riportata al primario

 

Edited by Livio Orsini

Share this post


Link to post
Share on other sites
Gorilla-K2

Se intendi lasciando i diodi ti direi di no perche' si abbassa l'efficienza, e altri metodi non ne vedo, direi che non ce ne sono.

Pero' se vuoi inserire questi diodi va cambiato il partitore del feedback immagino...

Edited by Trans Istor

Share this post


Link to post
Share on other sites
gabri-z

Potresti ritoccare il rapporto R5-R6 (schema di catalogo )

Share this post


Link to post
Share on other sites
Gorilla-K2

Se togli i diodi in piu e metti un trimmer al posto della R3 o cambi R3 con 10k e metti in serie il trimmer da 10k impostato partendo da 5k magari finisce che riesci a ottenere la VCC e la Vout giusta, non saprei..

Edited by Trans Istor

Share this post


Link to post
Share on other sites
Andrea086

Perdonatemi, rileggendo tutti i messaggi forse mi sono espresso male. 

La tensione in esame che varia ( originale 7,8V; scheda fatta da me 11,2V ) è stata misurata sul pin alimentazione dell integrato ( VCC ) che proviene dall avvolgimento ausiliario.

Sul datasheet quest'ultima dovrebbe essere massimo di 9V, almeno credo.

La tensione in uscita è giusta e stabile, solo quando varia il carico l'alimentatore va in protezione 

 

Share this post


Link to post
Share on other sites
gabri-z

Bravo ! Un dettaglio da niente.

 

Share this post


Link to post
Share on other sites
Gorilla-K2

Scusa l'ignoranza magari dico una fesseria, più che diodi se metti in uscita all'aux una resistenza in base all'assorbimento del pwm chip seguita dal diodo e uno zener da 9v poi fai i test vari anche di assorbimento del alimentatore e lo confronti con quello originale magari va bene come rendimento

Share this post


Link to post
Share on other sites
gabri-z

Dovrebbe starci  se per '' aux '' intendi l'avvolgimento da 13 spire .

Edited by gabri-z

Share this post


Link to post
Share on other sites
dott.cicala

Se va in protezione quando si inserisce il carico, il responsabile è il CS

Share this post


Link to post
Share on other sites
Andrea086
44 minuti fa, Trans Istor ha scritto:

se metti in uscita all'aux una resistenza in base all'assorbimento del pwm chip seguita dal diodo e uno zener da 9v

Ho provato solo con una resistenza in serie per diminuire la tensione ( non ho lo zener da 9V ), l'assorbimento è talmente piccolo che è difficile capire il valore esatto.

 

42 minuti fa, dott.cicala ha scritto:

Se va in protezione quando si inserisce il carico, il responsabile è il CS

Giusto, ho provato con una resistenza da 2,7ohm / 3ohm e solo su alcuni ho risolto.

Non riesco a capire il motivo del malfunzionamento, l'unica tensione che cambia è quella del pin VCC che cambia in base al carico, direttamente proporzionale.

Forse è proprio quella la causa? La tensione sul pin VCC dell integrato supera la soglia massima?

Share this post


Link to post
Share on other sites
gabri-z
17 ore fa, Andrea086 ha scritto:

l'ho preso dal datasheet del produttore.

Metteresti il link ? A me con la stessa sigla ( mi :P ) da solamente un generatore di tono....

Edited by gabri-z

Share this post


Link to post
Share on other sites
gabri-z

Il motivo della protezione te l'ha detto il dott'' , ma potrebbe essere dovuto alla tensione alta di VCC  , a sua volta dovuta al rapporto diverso degli avvolgimenti .

Share this post


Link to post
Share on other sites
Gorilla-K2

mettendo solo resistenza riduci la corrente vcc ma non la tensione e non serve a niente, il motivo del malfunz. lo trovi nel datasheet, se c'è una protezione di soglia del vcc allora hai la risposta (OVP), i miei ricordi sono frammentari, se aumenti la R5 riduci la corrente massima nel mosfet, quindi il duty viene interrotto prima del dovuto e avrai una vcc piu bassa ma immagino anche la vout..

Share this post


Link to post
Share on other sites
Livio Orsini

Metti un resitore in serie al diodo D1 seguita da uno zener verso zero così da limitare la tensione su VCC attorno agli 8V.

poi lavora, sui valori del partitore R3 e R4.

Attualmente il rapporto circa 0.36, portalo a circa 0.25 e dovrebbe funzionare correttamente.

Share this post


Link to post
Share on other sites
gabri-z
8 ore fa, gabri-z ha scritto:

Potresti ritoccare il rapporto R5-R6 (schema di catalogo )

 

Share this post


Link to post
Share on other sites
Livio Orsini

Si ma va limitata la tensione di alimentazione che dipende direttamente dal rapporto spire del trasformatore.

Prima si riporta il valore della tensione di alimentazione entro i limiti specificati dal costruttore, poi si potrà agire sul partitore di reazione.

Edited by Livio Orsini

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...