Jump to content
PLC Forum


STEU

Ingressi STO su azionamenti per brushless

Recommended Posts

STEU

Buongiorno

 

vorrei sapere se sugli ingressi di sicurezza STO A e STO B degli azionamenti per motori brushless, è corretto montarci i contatti delle barriere fotoelettriche di sicurezza, oppure andrebbero collegati solamente i contatti del circuito di emergenza. La domanda perchè nella macchina in cui sto lavorando sono state messe le barriere di sicurezza , e quando l'operatore le interrompe , perchè deve operare nell'isola di lavoro, ed il motore è fermo ogni tanto l'azionamento va in allarme. Ci tengo a sottolineare che la barriera viene interrotta a motore fermo senza comandi.

Link to post
Share on other sites

Livio Orsini

La barriera dovrebbe entrare nel circuito di emergenza, assieme alle altre sicurezze.

La sequenza di emergenza, tra le altre operazioni, deve bloccare gli azionamenti o tramite gli ingressi di comando di sicurezza, oppure con dispositivi elettromeccanici esterni, qualora l'azionamento non fosse dodato di comandi di sicurezza.

 

Se dall'analisi del rischio, all'apertura dei ripari è ammesso bloccare solo una zona della macchina, si possono usare i contatti di sicurezza per realizzare la fermata di quella zona e bloccare in sicurezza l'azionamento o gli azionamenti.

 

In ogni caso il blocco in sicurezza del drive non deve mandare in allarme il drive stesso.

Che allarme compare?

Tra l'altro non specifichi quale tipo di drive brushless stai usando, specificare la marca e modello da qaulche dato in più.

Inoltre dovresti leggere il codice dall'arme e controllarne le cause possibili, secondo il manuale.

Link to post
Share on other sites
STEU

Prima di tutto grazie per le risposte.

L'azionamento è un Festo   CMMT-AS-C5-11A-P3-PN-S1

Lo schema è qui sotto i telerutti che chiudono STO a e B ,sono i 15 KA1 e 15KA2 che sono collegati direttamente al modulo di sicurezza della barriera.

L'errore è azionamento disabilitato , anche con i teleruttori chiusi. il problema è che l'errore accade random ogni tanto, e succede quando l'operatore dopo aver interrotto la  barriera esce dalle stesse e i teleruttori si richiudono.

 

festo.JPG

Edited by STEU
Dimenticata la parola operatore
Link to post
Share on other sites
Livio Orsini
30 minuti fa, STEU ha scritto:

L'errore è azionamento disabilitato , anche con i teleruttori chiusi. il problema è che l'errore accade random ogni tanto, e succede quando l'operatore dopo aver interrotto la  barriera esce dalle stesse e i teleruttori si richiudono.

 

Potrebbero verificarsi 2 casi

  • Rimbalzi in chiusura e l'inverter interpreta male il fatto e si mantiene bloccato
  • Non perfetta chiusura dei contatti.

L'allarme persiste anche dopo la chiusura dei ripari o scompare e riappare immediatamente dopo?

Hai provato a misurare fisicamente la tensione presente agli ingressi "STO" quando è presente l'allarme?

Link to post
Share on other sites
STEU

Si ho provato ed il 24 Volt è presente, è la prima prova che ho fatto, per quanto riguarda i rimbalzi potrebbe essere, anche se credo sia strano perchè utiliziamo dei teleruttori e non relè semplici

 

Link to post
Share on other sites
STEU

Per fa si che l'allarme vada via devo dare il reset sull' FB che controlla l'azionamento

 

 

Link to post
Share on other sites
Livio Orsini
35 minuti fa, STEU ha scritto:

anche se credo sia strano perchè utiliziamo dei teleruttori e non relè semplici

 

Se per teleruttore intendi contattore, oltre ad essere inutile perchè non c'è potenza da commutare, è anche dannoso perchè i contatti sono inadatti.

Bisogna usare relè di segnale di buona qualità.

Link to post
Share on other sites
STEU

Si intendo contattore, quali potrebbero essere dei relè di qualità? Intendo che marca e modello mi consiglieresti? In verità con altri azionamenti ho sempre utilizzato dei contattori anche perchè utilizzo l'altro contatto di potenza per tagliare i comuni alle schede del PLC.

Link to post
Share on other sites
Lucky67
3 ore fa, STEU ha scritto:

Per fa si che l'allarme vada via devo dare il reset sull' FB che controlla l'azionamento

 

Non conosco il tuo azionamento però in quelli che uso io, i comandi di STO non mandano in blocco l'inverter bensì staccano staccano il comando sugli IGBT e lo segnalano: quando viene ridato lo STo ripartono. Potrebbe essere una non simultaneità dell'intervento del doppio canale: c'è la possibilità di lavorare, per provare, a singolo canale per vedere se ti fa lo stesso?

 

Link to post
Share on other sites
STEU

Ho provato a simulare la non contemporaneita, premendo a mano i contattori, ma in quel caso da un allarme sul circuito di sicurezza,, dicendo appunto di un errore di contemporaneità

Link to post
Share on other sites
Livio Orsini
4 ore fa, STEU ha scritto:

Intendo che marca e modello mi consiglieresti?

 

Qualsiasi buon produttore di elettromeccanica ha in catalogo anche relè di segnale

4 ore fa, STEU ha scritto:

utilizzo l'altro contatto di potenza per tagliare i comuni alle schede del PLC.

 

Perchè tagli i comuni quando si aprono i rapari?

Link to post
Share on other sites
Lucky67

Scusa ma non gho capito una cosa: aldilà che il circuito funzione bene o meno, se tu hai un intervento delle fotocellule il driver va in allarme e tu devi resettarlo con un'azione esterna??Questa è l'azione normale?

 

2 ore fa, STEU ha scritto:

Ho provato a simulare la non contemporaneita, premendo a mano i contattori, ma in quel caso da un allarme sul circuito di sicurezza,, dicendo appunto di un errore di contemporaneità

Scusa ma faccio ancora fatica a capire...se tu azioni a mano il contattore i contatti saranno ugualmente contemporanei...poi non capisco cosa c'entra il circuito si sicurezza...quello che hai descritto immagino sia il feedback per il reset ma intendevo lato driver (la non contemporaneità) cioè se lo STO A ad esempio interviene qualche decisecondo prima o dopo rispetto lo STO B.

Link to post
Share on other sites
STEU
14 ore fa, Lucky67 ha scritto:

Scusa ma non gho capito una cosa: aldilà che il circuito funzione bene o meno, se tu hai un intervento delle fotocellule il driver va in allarme e tu devi resettarlo con un'azione esterna??Questa è l'azione normale?

Normalmente quando ripristino le barriere l'azionamento si riabilita in automatico e lavora normalmente, una volta su quindici, non si riabilita e da l'allarme

 

14 ore fa, Lucky67 ha scritto:

Scusa ma faccio ancora fatica a capire...se tu azioni a mano il contattore i contatti saranno ugualmente contemporanei...poi non capisco cosa c'entra il circuito si sicurezza...quello che hai descritto immagino sia il feedback per il reset ma intendevo lato driver (la non contemporaneità) cioè se lo STO A ad esempio interviene qualche decisecondo prima o dopo rispetto lo STO B.

i contattori sono 2 , il problema della contemporaneità esce fuori  tolgo un filo su un contattore, chiaramente se ne premo uno solo tolgo l'abilitazione a tutti e due i canali

Edited by STEU
Link to post
Share on other sites
STEU
16 ore fa, Livio Orsini ha scritto:

Perchè tagli i comuni quando si aprono i rapari?

Perchè l'operatore operando sulla macchina potrebbe pizzicarsi un dito nel caso di un'uscita che va in corto, è stata fatta un'alisi dei rischi

Link to post
Share on other sites
Livio Orsini
2 ore fa, STEU ha scritto:

Perchè l'operatore operando sulla macchina potrebbe pizzicarsi un dito nel caso di un'uscita che va in corto, è stata fatta un'alisi dei rischi

 

Allora usi un contatto del relè di segnale per aprire l'ingresso STO ed un'altro per apre l'alimentazione alla bobina che taglia i comuni.

 

Se una volta su 15 a contatti chiusi l'inverter rimane in blocco significa che non ha riconosciuto la chiusra contemporanea dei contatti di STO; i contattori sono più lenti in commutazione e, con picocle correnti, è più facile che ci sia indecisione durante la fase di chiusura.

Link to post
Share on other sites
STEU

Farò delle prove e se risolverò il problema spiegherò come ho fatto

 

Link to post
Share on other sites
Max.bocca69

Mi era successa una cosa simile, contralla le specifiche che indicano minima corrente e tensione di commutazione dei contatti,  io ho risolto con aggiunta di contatti aggiuntivi per piccole correnti.

Anche sulla pulsantiera telemecanique per esempio aveva i contatti argentati o dorati proprio per utilizzi su elettronica. É difficili trovarli in campo ma se li hanno fatti ci sarà un perché...

Link to post
Share on other sites
Livio Orsini
3 ore fa, Max.bocca69 ha scritto:

io ho risolto con aggiunta di contatti aggiuntivi per piccole correnti.

 

Il 10/8/2020 alle 11:45 , Livio Orsini ha scritto:

Bisogna usare relè di segnale di buona qualità.

 

Link to post
Share on other sites
STEU

Proverò con dei relè con contatti dorati e farò sapere , anche se credo , dico credo perchè non ho possibilità di misurare, che la corrente che iterrompe il contattore non sia bassissima, andando a tagliare la corrente sulle basi di transistor di potenza penso che sia di qualche decina di milli Amper

Link to post
Share on other sites
Livio Orsini
3 minuti fa, STEU ha scritto:

andando a tagliare la corrente sulle basi di transistor di potenza penso che sia di qualche decina di milli Amper

 

Oramai da un paio di decenni si usano IGBT, quindi son pilotati in tensione; inoltre i contattori, anche i taglia "0", son fatti per commutare correnti dell'ordine degli ampere.

Link to post
Share on other sites
STEU

Il problema è stato risolto, penso possa essere utile per molti. Ho aggiornato il firmware dell'azionamento ed il problema dell'anomalia è sparito, ho lasciato per ora il cablaggio così come era.

Penso che ,essendo un modello nuovo, patisca qualche problema di gioventù.

 

Link to post
Share on other sites
Livio Orsini
1 ora fa, STEU ha scritto:

Penso che ,essendo un modello nuovo, patisca qualche problema di gioventù.

 

Ti auguro che l'aggiornamento abbia effettivamente risolto il problema.

rimane il fatto che i contattori di potenza non sono adatti per commutare segnbali con correnti deboli. Al limite usa i cantatti ausiliari.

Link to post
Share on other sites
STEU
3 ore fa, Livio Orsini ha scritto:

 

Ti auguro che l'aggiornamento abbia effettivamente risolto il problema.

rimane il fatto che i contattori di potenza non sono adatti per commutare segnbali con correnti deboli. Al limite usa i cantatti ausiliari.

Grazie dei consigli, e da ieri dalle 15.00 circa e tutto oggiche il problema non si è più presentato. Lunedì abbiamo il collaudo della macchina e penso che metteremo dei relè normali, non con i contatti dorati per maggiore sicurezza. Sul manuale la descrizione è generica non danno nessun suggerimento sui relè da utilizzare per i contatti di sicurezza. Comunque grazie dell'aiuto

 

Link to post
Share on other sites
Livio Orsini
1 ora fa, STEU ha scritto:

Comunque grazie dell'aiuto

 

niente di che, il forum serve anche a questo:smile:

Tienici aggiornati su eventuali sviluppi.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...