Jump to content
PLC Forum


markolino

1214C e tia portal

Recommended Posts

markolino

Ciao ragazzi, ho appena comprato per hobby una 1214C .

La cpu aveva all'interno un suo ip, ma dato che non me ne fregava nulla del sw che aveva all'interno ho fatto un nuovo progetto inserendo il dispositivo corrispondente ed assegnando un nuovo ip nella parte profinet.

Quindi ho scaricato il progetto verso la cpu.

 

Il problema è che l'ip è stato recepito ma il resto no.

 

Ora praticamente la cpu è in stop, e se provo a collegarmi il collegamento fallisce (allego foto).

 

C'è un modo per resettare tutto e ripartire da capo ?

Non riesco nemmeno a collegarmi per ad andare in diagnostica per fare il reset to factory settings.

Escludi sia il mio pc perchè con un altro 1200 zero problemi di connessione. 

 

Grazie a tutti.

tia_1214C.png

tia_1214C_b.png

Edited by markolino

Share this post


Link to post
Share on other sites

markolino

Edit : problema risolto con reset utilizzando il simatic automation tool scaricabile dal sito siemens.

Grazie.

Share this post


Link to post
Share on other sites
markolino

Ragazzi, stasera ho semplicemente rieditato il sw di ieri, ho provato a rimandarlo e bam. Stesso errore di prima.

Qualcuno può darmi una mano ? Sembrava risolto, ma è riapparso. Improvvisamente non si collega più e la Cpu è in run tranquillamente.

Le foto non le riposto perchè sono identiche a quelle del mio primo post.

 

Grazie.

Share this post


Link to post
Share on other sites
ken

nelle foto di prima cerchi di collegarti a due cpu che hanno indirizzo Ip diverso. sicuro che l'ip sia raggiungibile?

Share this post


Link to post
Share on other sites
pigroplc

e fai un PING continuo (es 192.168.1.10 -t) e in prima battuta si capisce se a basso livello il collegamento non presenta problemi quindi se non perde il collegamento la causa potrebbe essere la CPU che presenta qualche anomalia. Prova a fare un ripristino di fabbrica nel menu online diagnostica 

 

Share this post


Link to post
Share on other sites
batta

Firmware della CPU?

Share this post


Link to post
Share on other sites
markolino

@Ken e pigroplc

Confermo, ip raggiungibile e ping senza problemi.

@Batta allego foto della versione FW.

 

Per ripartire ho resettato alle impost. di fabbrica dal simatic automation tool perchè da tia portal non si collegava nemmeno dalla diagnostica.

Stavolta dopo il reset dal simatic automation tool, ho resettato anche dal tia portal cancellando l'ip.

Ho rimandato giu il progetto e stava andando, le uscite blinkano.

 

Chiuso il tia portal, riaperto, piccola modifica al blocco ob1, clicco per mandare giu il progetto stesso errore. Allego foto.

Le uscite continuano ad andare, quindi il programma gira.

Non capisco...il progetto è sempre lo stesso...ho solo chiuso e riaperto il tia. Ripeto con 1211 nessun problema.

 

Può essere il fw da aggiornare ? Qualche suggerimento ?

 

Grazie mille

plc.png

plc2.png

Edited by markolino
upload image

Share this post


Link to post
Share on other sites
markolino

Aggiungo che qui ho trovato versioni di fw nuove per la cpu 

https://support.industry.siemens.com/cs/document/38710558/operating-system-updates-for-cpu-1214c-compact-cpu-dc-dc-dc?dti=0&dl=en&lc=it-IT

 

Non ho la card per tentare un'upgrade. Ho provato a cercarla online e l'ho trovata purtroppo costa troppo per le mie tasche...c'è un altro modo ?

Edited by markolino

Share this post


Link to post
Share on other sites
pigroplc
1 ora fa, markolino ha scritto:

Ho provato a cercarla online e l'ho trovata purtroppo costa troppo per le mie tasche...c'è un altro modo ?

Prova a impietosire un rivenditore Siemens locale, in genere un modulo per l'aggiornamento firmware ce l'hanno per i loro clienti

 

Share this post


Link to post
Share on other sites
markolino

Credo opterò per la restituzione del materiale al venditore....

Share this post


Link to post
Share on other sites
markolino

 

Se non ci sono altre soluzioni...😔

Edited by markolino

Share this post


Link to post
Share on other sites
ken

con il 1500 si aggiorna il firmware col cavo diretto senza nessuna memory card. non ricordo però se la funzione è attiva da una versione di tia portal in poi oppure se con firmware di partenza più nuovi.

Share this post


Link to post
Share on other sites
batta

Non mi è ancora chiaro se il FW della cpu nel progetto corrisponde esattamente al FW reale della CPU.
Suppongo di sì, dato che, in caso contrario, non dovrebbe fare nemmeno il primo trasferimento, ma una conferma non guasterebbe.

Ma, d'altra parte, ti dice che il dispositivo è incompatibile, e questo farebbe pensare ad una versione di FW non allineata.

Share this post


Link to post
Share on other sites
markolino

@Batta

Ricontrollo e ti do conferma.

Pero come dici tu...perché il primo trasferimento lo fa e gli altri no...

Non trovo veramente senso...

 

Share this post


Link to post
Share on other sites
markolino

@Batta

Uso Tia v15.1

La versione del progetto é 2.0 quella della cpu é 2.0.2

 

Share this post


Link to post
Share on other sites
batta

L'ultima cifra non è rilevante, quello che conta è FW 2.0 quindi, il FW corrisponde.

Hai provato a fare un progetto completamente nuovo (anche vuoto o con due istruzioni in croce) e vedere se ti dà lo stesso problema?

 

Share this post


Link to post
Share on other sites
markolino

Ci ho riprovato per l'ennesima volta e sono riuscito a connettermi.

Ecco la sfilza di errori che compaiono quando vado online.

Nessun errore invece durante l'upload o il download dei blocchi, che comunque viene eseguito una volta connesso.

Aggiungo anche che dalla tabella di controllo le variabili o le DB non possono essere comandate...

 

 

 

plc3.png

Edited by markolino

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...