Jump to content
PLC Forum


alessandro.frione

S7 1200 V90 EPOS encoder assoluto

Recommended Posts

alessandro.frione

Salve a tutti, 

 

ho un problema che non riesco a risolvere con un v90 gestito in EPOS che comanda un motore 750W 220V con encoder assoluto. 

L'applicazione funziona molto bene, il problema è che al riavvio perde la posizione di riferimento (o meglio l'Offset rispetto allo zero)

A nulla valgono le procedure di salvataggio dati RAM to ROM e la scrittura dei parametri tramite SINA_PARA. Sembra che il problema sussista anche a PLC scollegato (referenziando l'asse con V-Assistant e riavviando)

Sicuramente sbaglio qualcosa, ma non riesco a capire che cosa

 

Qualche idea?

 

Grazie

 

Alessandro

Link to comment
Share on other sites


Livio Orsini

Lo zero asse, essendo l'encoder assoluto, consiste in una quota che dovresti memeorizzare in una locazione di memoria permanente.

Al primo ciclo di PLC dopo una rialimentazione si fa il confronto tra la quota attuale e quella memorizzata; se i due valori differiscono si rialinea l'asse.

Link to comment
Share on other sites

batta

Che telegramma stai usando?
Perché, al posto di SINA_POS e SINA_PARA non gestisci il drive con le istruzioni motion?
Con le istruzioni motion, con MC_Home con Mode = 7 fai l'impostazione dell'encoder assoluto.

Se sicuro di utilizzare i giusti comandi di SINA_PARA per l'encoder assoluto?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...