Jump to content
PLC Forum


Siwarex v4.1


acquaman
 Share

Recommended Posts

Buongiorno, qualcuno in archivio ha una versione del progetto Siwarex fornito dalla siemens per gestire le celle di carico versione 4.1.

Grazie

Link to comment
Share on other sites


Per il software ho risolto, ma non riesco a far funzionare il sistema, ho fatto la parametrizzazione rapida inserendo i dati di fabbrica delle 3 celle di carico, ho seguito la procedura come scritta sul manuale, ma sul pannello non viene visualizzata la misura, e sul primo canale degli ingressi della cella c'è un valore di 16800

ed oscilla di -300.

Sul pannello però si vede la scritta Vuoto e >< diventare verde.

Cattura.thumb.png.188a3608cb3dbe82949e8c0738cad996.png

Edited by acquaman
Link to comment
Share on other sites

max.riservo

Come già suggerito per il problema delle termocoppie : occorre partire dalla verifica dell'installazione.

Trattandosi di celle di carico occorre verificare quanto segue :

- Tensione di alimentazione (SUPPLY) in partenza dal quadro (generalmente tra i 5 e i 12 V)

- Tensione di ritorno dalle celle (SENSE) di ritorno al quadro (qualcosa in meno rispetto al SUPPLY)

- Tensione in arrivo dalle celle di carico (MEASURE) di ritorno (milliVolt)

- occorre ripetere le misure nella cassetta giunzione su ogni singola cella (almeno per quanto riguarda il segnale MEASURE)

- la tensione MEASURE in uscita delle singole celle deve essere similare per verificare che non ci sia un montaggio meccanico carente (su 3 punti sei abbastanza certo che le celle sia quasi equamente compresse)

Dopo le verifiche di corretta installazione elettrica/meccanica delle celle di carico ti dedichi al SW (non mi dilungo sulla scelta insana di utilizzare schede di pesatura PLC con sw di configurazione/calibrazione osceni quando esistono trasmettitori di peso che possono essere gestiti anche da NON tecnici e/o programmatori) ...

Link to comment
Share on other sites

La parte hadware l'ho già verificata l'alimentazione che esce dalla scheda è 10v simile al sense, ed ho una tensione di ritorno di circa 2mv, la cassetta è unica apposta per i collegamenti delle celle in parallelo.

Meccanicamente ho un silos vuoto appoggiato su 3 celle ai 3 lati del silos senza nessun vincolo meccanico che possa viziare la misura.

Ovviamente sto usando il blocco standard fornito da siemens.

Link to comment
Share on other sites

Sul pannello ho anche questi segnali:Cattura.thumb.png.c2b4f468e1258d3001984b96550fe852.png

 

 

Ma nessuna misura a display e quel valore sull'uscita analogica.

Link to comment
Share on other sites

max.riservo
3 minuti fa, acquaman ha scritto:

La parte hadware l'ho già verificata l'alimentazione che esce dalla scheda è 10v simile al sense, ed ho una tensione di ritorno di circa 2mv, la cassetta è unica apposta per i collegamenti delle celle in parallelo.

Meccanicamente ho un silos vuoto appoggiato su 3 celle ai 3 lati del silos senza nessun vincolo meccanico che possa viziare la misura.

Ovviamente sto usando il blocco standard fornito da siemens.

Verifica nella cassetta giunzione che il segnale da ogni cella di carico sia coerente (ovvero che sia un valore intorno ai 2 mV per ogni singola cella di carico).

Anche se dovessi rilevare segnali sbilanciati dalle celle (ie. 1mV, 2mV e 3 mV quindi valore medio al siwarex di 2 mV) non preoccupartene : per i tuoi fini

la cosa importante è che tutte le celle di carico  rilevino un peso e che questo peso (quindi il valore in mV) sia stabile.

Conoscendo la portata (in kg/T) delle celle di carico, la sensibilità delle celle (in mv/V) e la tensione di alimentazione (10 V) e

sapendo la tensione di ritorno (circa 2 mV) è anche possibile ricavare il peso indicativo della struttura (a vuoto).

Supponendo che le tue celle di carico abbiano una sensibilità di 2mV/V posso dirti che stai caricando le celle a circa

il 10% della loro portata nominale (i.e 3 celle da 10T = 30T in totale, quindi peso stimato struttura 3T).

 

Spero che il silo non sia tanto alto e che in questo momento non sia una giornata (molto) ventosa dove ti trovi ...

 

Per la parte siwarex non so aiutarti ... io non uso schede di pesatura per PLC.

Link to comment
Share on other sites

Il problema sembra essere il software che gestisce quei dati, nella variabile s_IO_Data.PROCESS_VAL_1, che ci dovrebbe essere il valore del peso, effettivamente c'è e dovrebbe essere abbastanza corretto tutto il resto delle variabili e il segnale analogico non vanno.

Per controllare quella variabile ho messo 4 piastroni sul piedino di una cella di carico e misurava 14kg, ho diviso i 4 piastroni su 2 celle e mi dava 11kg, se li tolgo mi da 0.

 

Link to comment
Share on other sites

max.riservo

Quindi sembra essere un problema lato hw/sw siemens ... purtroppo non so aiutarti di più.

 

Ciao

Link to comment
Share on other sites

7 minuti fa, max.riservo ha scritto:

.. purtroppo non so aiutarti di più.

Grazie comunque, sei sempre disponibile.

Link to comment
Share on other sites

Non riesco a capire dalle 6 word mappate sulla configurazione hw cosa dovrebbe uscire, dalla prima word dovrebbe uscire la misura del peso, ma a me esce in valore strano e ne manuale con c'è scritto nulla.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...