Jump to content
PLC Forum

Wanderer666

Acer Travelmate 290: problema MISTERIOSO [P

Recommended Posts

Wanderer666

Ciao a tutti. smile.gif

Ho un problema con un notebook Acer Travelmate 290 che mi sta facendo letteralmente impazzire, ma prima di telefonare alla Neuro per prenotare una camera magari provo a chiedere il vostro aiuto.

Dunque... questo notebook, come tantissimi altri di questa serie maledetta (nei Forum in rete ci sono letteralmente DECINE di persone tutte alle prese con Notebook analoghi e dalla stessa sintomatologia, ma nessuna soluzione), presentava il seguente problema:

All'accensione, dopo un paio di secondi (ancora durante la fase di post) lo schermo diventava totalmente bianco e poi si spegneva, lasciando accesa la spia del power, ma senza che il notebook, desse più segni di vita.

Non c'era verso di riaccenderlo, se non lasciandolo scollegato dall'alimentazione (sia dalla batteria sia dall'alimentatore) per periodi variabili da pochi secondi a parecchi minuti. Fatto ciò, a volte ripartiva normalmente, per poi morire alla stessa maniera di cui sopra pochi secondi dopo (ah, precisazione: non sempre avveniva l'imbiancamento dello schermo).

Confortato anche dal fatto che su eBay c'è un tizio che propone proprio il servizio di riparazione a costo fisso (e non altissimo, quindi di certo non sostituisce la mainboard) di questa serie di notebook e di alcune serie analoghe della Acer, mi sono impuntato nel cercare di capire quale potesse essere il problema.

Dopo un accurato smontaggio e relativo nonchè reiterato testing dei componenti, ho scoperto una cosa davvero allucinante: a notebook smontato (senza lo chassis superiore), se prima di accenderlo sollevo da un lato il gruppo ventola/dissipatore in maniera da flettere di pochi millimetri verso il centro la mainboard in quella zona, il notebook si accende in maniera regolare, e funziona perfettamente (per sicurezza ho fatto partire un Live CD di Mandriva 2009 e ci ho smanettato per un po', il tutto senza problemi di alcun genere, come se il notebook fosse intatto).

A questo punto ho supposto che potesse esserci un falso contatto da qualche parte tra lo chassis e la mainboard, e mi sono dedicato ad isolare OGNI possibile punto di contatto che non fosse predisposto ad esserlo (e vai con chilometri di nastro isolante e pezzi di acetato trasparente). Il tutto senza alcun successo, com'era prevedibile in base alle leggi del nostro caro Murphy.

Per sicurezza, ho fatto quindi una prova smontando del tutto la mainboard dallo chassis, e lasciandole collegata solo la roba indispensabile: CPU, dissipatore+ventola, alimentatore, RAM, LCD.

Risultato: se non tocco nulla, il notebook non da segni di vita se non la falsa partenza di cui sopra (e a volte nemmeno quella), se invece afferro l'estremità della mainboard su cui è montato il gruppo di dissipazione e la fletto, il notebook resuscita miracolosamente.

Ovviamente a questo punto ho anche verificato che non ci fossero improbabili cortocircuiti tra il gruppo di dissipazione e la mainboard, ma altrettanto ovviamente non ne ho rintracciati.

A questo punto, le uniche spiegazioni che riesco a darmi riguardano la presenza di microsaldature difettose di fabbrica (che magari cedono dopo un tot di tempo dall'acquisto, e questo spiegherebbe il perchè è un problema così diffuso - e nella stessa maniera identica - su questa ed altre serie), oppure (ma mi sembra improbabile, anche se non si può mai dire) una microfrattura di qualche pista della mainboard (è possibile secondo voi che la mainboard sia multistrato e si sia rotta una pista in uno degli strati interni? A me sembra davvero allucinante come ipotesi...).

Detto ciò (oddio, ho praticamente scritto un romanzo d'appendice anzichè un post tecnico, ma preferivo eliminare alla radice qualunque dubbio o perplessità sulla situazione), mi rivolgo ai VERI esperti (io non mi ritengo tale, credo di essere un buon tecnico informatico, ma la microelettronica non è decisamente il mio campo).

Avete consigli, ipotesi, suggerimenti, sacrifici umani alla dea Kalì, varie ed eventuali, da porgermi per aiutarmi a risolvere la faccenda?

Naturalmente è esclusa a priori l'ipotesi di sostituire la mainboard (mi costerebbe quanto un office notebook di nuova generazione), anche perchè - come vi ho detto - quando viene flessa il notebook torna a funzionare in maniera assolutamente PERFETTA, quindi non penso proprio che ci siano dei componenti guasti.

Esiste un modo per verificare quale componente o pista possa presentare un problema di saldatura, a parte l'indagine visuale (che ho fatto decine di volte, ma senza risultato alcuno se non la perdita di un paio di diottrie :\ )?

Qualcuno di voi magari ha avuto per le mani un notebook con lo stesso tipo di problema, e sa come risolvere?

Attendo fiducioso le vostre risposte. Nel frattempo, cercherò di non buttare dal balcone i pezzi del notebook uno ad uno per la disperazione...

Grazie, e scusatemi per la prolissità. happy.gif

Link to post
Share on other sites

nll

La risposta te la sei data già da solo e complimenti per la dettagliata analisi, che non tutti si degnano di scrivere, forse perché temono di tediare, o perché ci credono dei maghi indovini.

Il difetto che denunci ha tutta l'aria d'essere una saldatura fredda, ma per individuarla con certezza, senza il rischio di danneggiare altri componenti, dovresti rifarle una per una con pazienza: ne rifai una, la identifichi chiaramente per non ripassarla ancora e provi il notebook, se non va provi con un'altra saldatura e così via tutte le altre, finché il guasto non è riparato.

Prima di partire con le saldature, controlla bene i contatti dei banchi delle RAM, dell'HD e della scheda grafica, a volte è solo un connettore non inserito bene, o un contatto ossidato. Anche se dubito sia il caso tuo, è una operazione rapida e facilissima ed è quindi bene tentarla.

Link to post
Share on other sites
doctordf

Problemi di questo tipo sono sempre più frequenti: guasti "strani", che vanno e vengono, tocchi leggermente la scheda e funziona tutto, comuni a tutta la serie del prodotto, il guasto si presenta solo a caldo, ecc...

Saldature fredde su MB di un pc sono molto improbabili, così come è improbabile che un microfrattura della scheda sia comune a tutta la serie.

Spesso, ma non sempre, mi accorgo che sono problemi dovuti agli integrati BGA (Ball grid array), per intenderci quelli che non hanno i piedini in vista.

Ottima tecnologia per quel che riguarda l'ingombro ma con resistenza meccanica quasi nulla e con grossi problemi di affidabilità quando i componenti in questione sono di quelli che si scaldano molto, CPU, GPU, ecc...

In sostanza le palline di stagno che costituiscono le saldature tendono a staccarsi, causando il falso contatto.

Se il problema è questo... in teoria non puoi farci nulla.

Io, e lo dico con orrore, persa per persa la board ci provo sempre con la pistola ad aria calda... in effetti abbastanza spesso funziona, ovviamente non mi sento di consigliartelo... se però qualcuno ha un'idea migliore....

Edited by doctordf
Link to post
Share on other sites
DerHimel

Complimenti per il mega-dettagliato post sul difetto clap.gif

Spero non mi prendiate per pazzo ma la vecchia soluzione della "zeppa" no eh?

Con un vecchio(oggi) 386 che mi fletteva al centro della M.B. causa peso del gruppo processore-ventola, forse anche perchè progettata male la stessa M.B., ogni tanto dava dei problemi strani. Ho messo uno spessore di gomma fino a rifare il pari ed ha viaggiato senza più problemi.

Quindi, anche se è una soluzione grezza, prova a zeppare il gruppo ventola dissipatore, riproducendo di fatto il sollevamento che fai quando parte, non avrai risolto in modo "professionale" ma se ti funziona............... senzasperanza.gif

Ciao Giovanni

Link to post
Share on other sites
nll

doctordf, prima dici che non può trattarsi di una saldatura fredda, poi porti un esempio proprio di una saldatura fredda... prima di smentire quanto scritto da altri mi preoccuperei di valutare quel che devo dire io, non ti pare?

Torno a dire che la causa di quel difetto è possibile che sia una (o più) saldatura fredda, a maggior ragione se si ripete allo stesso modo su più macchine dello stesso modello: impostazione errata della temperatura o dei tempi per la saldatura del componente nella linea automatizzata (l'errore si ripete su tutte le schede che passano per quella linea prima che venga ritarata l'attrezzatura).

Una soluzione poco ortodossa, ma a volte decisamente pratica, è quella proposta da DerHimel, che merita d'essere provata, visto che costa poco in tempo e in materiale.

Edited by nll
Link to post
Share on other sites
doctordf

Bè nll, mica te la devi prendere se ho un'idea diversa dalla tua.

Ovvio che qui uno riferisce sulla base delle esperienze che ha... io non ho escluso in maniera assoluta che possa trattarsi di un problema di saldatura fredda, ho parlato in termini probabilistici, sulla base di quella che è la mia esperienza.

Fino a circa un paio d'anni fa sarei stato d'accordo con te ed avrei cercato un falso contatto, un piedino sollevato, una pista interrotta per motivi meccanici... nello specifico parlare di saldature fredde mi suona comunque un pò "vintage".

Oggi mi capita spessissimo, quindi probabilità più alta, che il problema sia dovuto ad un componente BGA: se sulla scheda c'è , ad esempio, una cpu di quel tipo, la mia attenzione si focalizza su quello, non parto a saldare a casaccio perchè ritengo sia molto probabile che butterò del tempo, tutto qui.

Un'ultima cosa, per rispondere alla tua provocazione, secondo te se io parlo di saldatura che cede parlo di saldatura fredda?

Bè definire una qualunque saldatura che cede come "fredda", oltre che vintage mi sembra del tutto sbagliato.

Link to post
Share on other sites
crmsistemi

Visto che siamo nel campo delle ipotesi, io ne farei una che oltrettuto è facilissima da verificare.

Flettendo il gruppo ventola-dissipatore si sollecitano, oltre alla maindoard, il connettore della CPU e l'accoppiamento termico tra CPU e dissipatore.

Allora possiamo ipotizzare un contatto difettoso della CPU nello zoccolo o un insufficiente accoppiamento termico con il dissipatore, tale da portare in sovratemperatura la CPU con conseguente spegnimento per protezione termica.

Prova a smontare la ventola e a togliere il dissipatore, estrai la CPU dallo zoccolo e rimuovi tutta la polvere che trovi, anche sotto la ventola e dentro il dissipatore.

Rimetti al suo posto la CPU, togli tutti i residui di grasso siliconico (quella pappetta bianca) se necessario con un pò di alcool.

Metti del nuovo grasso siliconico e rimonta il dissipatore e la ventola.

Hai visto mai che funziona ? biggrin.gif

Link to post
Share on other sites
fabionesmd

Sono in accordo con la verifica e pulizia in primis di tutti i contatti a vista, a pettine e connettori e connessioni vare.

Abbandonerei l' idea di fare lavoraare il pc con la MB sottoposta a torsione, sono troppi i componenti ceramici presenti sulla scheda, risci di craccarli.

Tenta l' accensione del pc con la main board libera da torsioni e premendo con un dito su un microprocessore o controllore alla volta, partendo da quelli che non vedi i pin perche sottostanti al corpo del componente.

Se si tratta di un falso contatto derivante da cr**k termico o meccanico o saldatura mancata per effetto pillow in rifusione, dovresti individuarlo.

Prima di proseguire avrei un paio di domande:

Verifica la data di produzione della MB attraverso le etichette interne.

Si tratta di una produzione rohs compliant?Verifica se ci sono etichette che riportano la scritta rohs o lead free.

Il pc è caduto?Ci sono ammaccature esterne?

saluti f1

Link to post
Share on other sites
maxps

Ciao ho il tuo stesso identico problema con un travelmate 290

le ho provate tutte:

il notebook l'ho smontato e rimontato una decina di volte, ma niente da fare!!

C'e' da dire pero' che a volte parte facendo pressione in prossimita' del tasto di accensione

la butto li' : in altri forum inglesi alcuni felici possessori di questa serie dicono di aver risolto il problema sostituendo la batteria della scheda mamma o anche collegandola ad un led per scaricarla completamente cosa che ancora non ho testato...

...mi accodo in attesa di nuove idee...

Saluti

Max

Link to post
Share on other sites
skyx69

doctordf+17/04/2009, 00:05--> (doctordf @ 17/04/2009, 00:05)

A mio modesto parere ,sono assolutamente d'accordo con Doctordf;se non avesse scritto lui l'intervento,il mio sarebbe stato piu o meno lo stesso.Dalla dettagliata descrizione ,escludendo interventi di risaldatura a tappeto con flussante liquido,interventi di spessori vari e presumendo a questo punto BGA che a causa di surriscaldamento ( per cattivo sottodimensionamento in termini di wattaggio del componente che dopo tempo dà questo genere di problemi)hanno perso uno dei contatti reoforici,.............perso per perso facendo la prova a parte su di un pezzetto di stagno (giusto per capire l'azione della pistola ad aria calda),io interverrei con cautela ma con aria calda sui BGA.

Questo è il mio personale pensiero.

Edited by skyx69
Link to post
Share on other sites
Wanderer666
nll+16/04/2009, 20:17--> (nll @ 16/04/2009, 20:17)

Grazie per i complimenti, in realtà trovavo indispensabile esprimere il problema in maniera il più possibile completa, proprio per eliminare ogni dubbio superfluo.

L'idea del rifare le saldature una per una è piuttosto improponibile... sono centinaia (e microscopiche), ci vorrebbe tanto di quel tempo (e le mie residue diottrie penso andrebbero del tutto in pensione) che faccio prima a smembrare il notebook e a venderne i pezzi funzionanti).

Riguardo la possibilità di connettori ossidati o componenti non inseriti correttamente, ho già fatto TUTTE le possibili verifiche, senza risultato alcuno. sad.gif

Link to post
Share on other sites
Wanderer666
doctordf+17/04/2009, 01:05--> (doctordf @ 17/04/2009, 01:05)

L'idea di utilizzare la pistola ad aria calda mi terrorizza...

L'ho prevista esclusivamente come ultima spiaggia, prima del bidone della spazzatura. ^_*

Link to post
Share on other sites
Wanderer666
DerHimel+17/04/2009, 09:47--> (DerHimel @ 17/04/2009, 09:47)

Ci avevo già pensato, ma purtroppo il tipo di flessione a cui va sottoposta la mainboard per funzionare stabilmente non permetterebbe il montaggio della parte superiore dello chassis.

Mi resterebbe solo da inchiodare la mainboard nella corretta posizione flessa ad un supporto ed usarla come PC fisso... wallbash.gif

Link to post
Share on other sites
Wanderer666
crmsistemi+22/04/2009, 14:16--> (crmsistemi @ 22/04/2009, 14:16)

E' stata una delle prime cose che ho verificato, ovviamente...

Ma altrettanto ovviamente, senza successo alcuno. sad.gif

Link to post
Share on other sites
Wanderer666
maxps+24/04/2009, 12:17--> (maxps @ 24/04/2009, 12:17)

Non riesco a capire neppure alla lontana il nesso tra questo tipo di problema e la batteria tampone... :\

Probabilmente i tizi di quei forum s'erano fumati un intero campo di barbabietole. laugh.gif

Quel tipo di procedura avrebbe senso esclusivamente se si trattasse di un problema legato alla CMOS (che cambiando o scaricando la batteria verrebbe così resettata, ma per quello basta anche solo cortocircuitare gli appositi pin), ma qui stiamo parlando di un problema di tipo FISICO assolutamente provato (vedasi la faccenda della flessione della mainboard).

Link to post
Share on other sites
Wanderer666
skyx69+25/04/2009, 23:35--> (skyx69 @ 25/04/2009, 23:35)

Mh... questo mi sembra un consiglio piuttosto sensato e preciso.

Dici quindi che mi tocca comprare una pistola ad aria calda e tentare sui chip BGA?

Qualche consiglio su una pistola economica ma affidabile? Non saprei da dove iniziare...

Link to post
Share on other sites
Wanderer666

Ah, dimenticavo... indipendentemente dall'utilità pratica o meno dei vari consigli, vi ringrazio tutti di cuore.

Ho inserito lo stesso quesito su 6 Forum differenti, e questo è il Forum dal quale ho ricevuto maggior feedback in assoluto, nonchè le risposte più sensate (anche quando non risolutive).

Grazie davvero. smile.gif

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...