Vai al contenuto

Lorenzo2891

Configurazione Prommer

Recommended Posts

Lorenzo2891

Salve,

 

vorrei programmare una eprom tramite step 5 V 7.23 installato su WXP. Il prommer in mio possesso, compreso di cavo originale, è il C79451-A3449-A11.

 

C'è un problema: il prommer non viene visto anche da progetto è stato selezionato un prommer esterno.

 

Cos'altro c'è da verificare?

 

GRazie

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc

Potrebbe essere un problema con la parallela del PC rispetto a ciò che si aspetta il prommer. Spero che sia una porta nativa e non ottenuta con un adattatore.
Prova, nel bios  del PC, a verificare la modalità: preferisci la SPP se possibile e comunque evita le EPP/ECP.
 

Condividi questa discussione


Link discussione
Condividi su altri siti
Lorenzo2891

Grazie rguaresc,

 

Credo proprio che debba controllare questo. Ho visto su alcuni  siti che è una impostazione obbligatoria.

 

Si la porta è nativa e non c'è nessun adattatore. Abbiamo un pc della Dell dedicato a questi tipi di lavoro.

 

Secondo te non c'è bisogno di installare altri driver?

 

Saluti.

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc
2 hours ago, Lorenzo2891 said:

installare altri driver?

no, i driver sono già in STEP 5

Condividi questa discussione


Link discussione
Condividi su altri siti
Lorenzo2891

Salve rguaresc,

 

avrei controllato il Bios ed effettivamente l'impostazione della LPT1 non era corretta. Credi che debba reinstallare il programma? Avrei ancora dei problemi a scrivere su Eprom, non riesco a far partire la procedura nonostante abbia seguito tutti i passaggi.

 

1) creazione del progetto;

2) caricamento del file *.5ST;

3) impostazione del prommer esterno su LPT1;

4) gestione Eprom con impostazione parametri dello stesso ( tipologia di Eprom da scrivere)

5) tentativo di scrittura che non porta da nessuna parte.

 

Non riesco a capire dove sbaglio. C'è una funziona del programma Step 5 che mi consente di capire se lo stesso "vede" il prommer esterno?

 

Ciao e grazie

 

 

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc

 

Non saprei, ho un prommer USB, è diverso, ma se installo STEP 5 dopo STEP 7 non va il driver, mentre viceversa funziona.

qui trovi un  Manuale

 

I PC coetanei di quel prommer erano a 16 bit

Condividi questa discussione


Link discussione
Condividi su altri siti
Lorenzo2891

Grazie rguaresc,

 

domani  faccio un altra prova.

 

Buonaserata

 

 

 

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti
Lorenzo2891

Buonasera rguaresc,

 

avrei fatto la prova modificando dal bios la gestione della periferica LPT1 come da manuale. Purtroppo,nonostante imposti il progetto in maniera corretta ( almeno credo ), non riesco ad avviare la scrittura. Avrei impostato il file .S5D, impostato il prommer esterno, parametrizzato la eeprom corretta ma all'atto della scelta del trasferimento di tutti i Blocchi la scrittura non viene eseguita.

 

Che posso fare?

 

Grazie in anticipo

 

 

 

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc

 

Non saprei,

 

DA XP non so se il prommer parallelo può funzionare da XP
c'è una "parametrizzazione memory card nel pannello di controllo che per default punta a USB
poi \start\simatic\STEP 5\S5EProm

 

STEP 5 in origine funziona da MS-DOS puro, servirebbe una partizione FAT16, poi

da MSDOS 
Step 5 poi il Tab 6 EPROM ecc

 

Condividi questa discussione


Link discussione
Condividi su altri siti
Lorenzo2891

Buonasera rguaresc,

 

alla fine ho risolto. Ho capito dove sbagliavo. Essendo un programma "poco user friendly" ho fatto fatica a seguire tutte le impostazioni  prima di lanciare la scrittura. Ma alla fine, come ho scritto all'inizio, ce l'ho fatta. Pensavo che  bastasse inserire una sola volta in "parametri Eprom" il modello della memoria mentre invece va inserita ogni qual volta che si deve fare ogni operazione di lettura, scrittura o cancellazione. Questo andava fatto tramite il tasto "ins".  

 

Dopo aver capito ciò volevo passare alla scrittura di tutti i blocchi inserendo il comando "B" solo che alla fine della procedura ritrovavo solo il blocco OB1, che non era, fra  l'altro, il primo della lista. Come mai? Ci deve essere un ordine della scrittura?

 

Grazie. 

 

 

 

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti
pt1957

Buonasera,

 

io ricordo che per scrivere su EPROM impostavo i tipi di blocchi (OB,PB,FB) non le DB che venivano ricreate in RAM.

 

 

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×