Vai al contenuto

Robertoxxx

Problema con pulsante web server logo 0BA0

Recommended Posts

Robertoxxx

Buon Giorno a tutti, sono nuovo su questo forum e vedendo i suggerimenti delle problematiche, chiedevo se si riuscisse a risolvere anche il mio.

Sto programmando un logo 0BA0, con interfacci web, ho preparato un programma con logo soft confort 8.2 per effettuare delle aperture, blocchi, e segnalazione di movimento, di 5 cancelli automatici che risiedono in una ditta.

ho poi preparato con logo web editor, una paginetta grafica dove ci sono i 5 comandi dei cancelli con le rispettive apertura, blocco e spia lampeggiante del singolo cancello in movimento. Il tutto e' stato scaricato nella sd da 16g nel logo.

Il problema che sussiste e' che dal web server del logo, quando clicco sul tasto apertura o stop del cancello, il tasto mi esegue la funzione di  interruttore on/off, quindi il comando inviato al logo rimane sempre chiuso fino a che non clicco il tasto apertura per la seconda volta e allora si riapre il contatto. Io avrei bisogno che quando clicco sul tasto dal web server, il comando sia 1/0, un pulsante, che dopo il comando ritorni aperto.

Sul plc non ho nessun ingresso programmato come pulsante di apertura e stop, uso solo l'interfacci web, gli unici ingressi programmati sono le spie di segnalazione di movimento che mi indicano che il cancello si sta muovendo.

Spero che mi sia espresso chiaramente nel mio problema. Un grazie anticipato per gli aiuti. Ciao

Vi allegoCattura1.thumb.PNG.cc4b9992333a9adeeadf6cf70b35b800.PNG il programma con logo confort e logo web editor

Cattura.PNG

Cattura2.PNG

Cattura3.PNG

Condividi questa discussione


Link discussione
Condividi su altri siti
max.bocca

Il problema che manca il tasto monostabile sul web editor.... So che dicevano che l'avrebbero sistemato . LWE è aggiornato? 

Condividi questa discussione


Link discussione
Condividi su altri siti
Mircoron

Potresti mettere un rilevatore di fronte positivo e uno di fronte negativo, metterli in or e hai il comando a impulso. Quando premi, se va in on, generi un impulso e analogamente se il pulsante va in off generi sempre un impulso.

 

Condividi questa discussione


Link discussione
Condividi su altri siti
max.bocca

Però se fai questo workaround hai la visualizzazione del tasto non veritiera. A meno che non ti interessa

Condividi questa discussione


Link discussione
Condividi su altri siti
84paolo

Ma non puoi resettare la memoria appena arriva e poi il comando lo dai con un'altra memoria interna( messa a uno quando premi il pulsante)  che si autoritiene con il comando di apertura?

Condividi questa discussione


Link discussione
Condividi su altri siti
Robertoxxx

Il fatto e' che quando faccio la simulazione con il logo online, vedo che l'impulso rimane costantemente attivo dalla parte del webserver, se schiaccio nuovamente lo stesso tasto di prima, il contatto si apre dopo 2 secondi come impostato nel temporizzatore, se tolgo i temporizzatori il contatto si apre subito dopo aver ripremuto il tasto dal webserver. econdo me' e' proprio dalla parte del webserver che il contatto viene ritenuto.

Condividi questa discussione


Link discussione
Condividi su altri siti
Mircoron
16 ore fa, max.bocca scrisse:

Però se fai questo workaround hai la visualizzazione del tasto non veritiera. A meno che non ti interessa

Ma se metti la stessa immagine per on e per off non dovresti vedere differenza fra premuto o no, poi ha di fianco la spia che indica se è attivo o no.

Condividi questa discussione


Link discussione
Condividi su altri siti
Robertoxxx

Grazie per la risposta, il web editor e' la versione 1.0, e non mi sembra che ci siano aggiornamenti.

Condividi questa discussione


Link discussione
Condividi su altri siti
Robertoxxx

Ciao mircoron, grazie intanto per le risposte, il tasto verde fa' solamente l'apertura e la richiusura e' automatica, lo fa' lui da solo, il tasto rosso e' lo stop che serve per lasciarlo aperto, il lampeggiante cambia colore quando il cancello e' in movimento o quando rimane aperto, tutto questo gia' testato personalmente con il programma che ho postato, naturalmente quello postato e' solo un blocco di un cancello, il problema che ho e' solamente il fatto che rimane chiuso che mi arriva dal web server, anche in siemens ci anno confermato del problema che presenta il web editor per il pulsante.  Cosa intendi quando mi dici di (Potresti mettere un rilevatore di fronte positivo e uno di fronte negativo, metterli in or e hai il comando a impulso. Quando premi, se va in on, generi un impulso e analogamente se il pulsante va in off generi sempre un impulso.) Se mi spieghi meglio ci voglio provare,  

Dal tasto che schiaccio dal webserver, comunque no  ho nessuna risposta dell'avvenuta risposta, il mio riferimento e' il lampeggiante che quando si muove si sta aprendo ho chiudendo.

Condividi questa discussione


Link discussione
Condividi su altri siti
Mircoron
17 ore fa, max.bocca scrisse:

Però se fai questo workaround hai la visualizzazione del tasto non veritiera. A meno che non ti interessa

Ma se metti la stessa immagine per on e per off non dovresti vedere differenza fra premuto o no, poi ha di fianco la spia che indica se è attivo o no.

pulsante.jpg

Ho fatto la prova, ho messo un pulsante con la stessa immagine on e off che comanda M1 e un altro pulsante non writable su M2 che indica lo stato.

Ho fatto un esempio dove ad ogni pressione del pulsante attaccato a M1 l'uscita M2 rimane attivata per 2 secondi.

 

LWE pulsante.jpg

LWEspia.jpg

Condividi questa discussione


Link discussione
Condividi su altri siti
Robertoxxx

Facendo delle prove ho provato questo schema e sembra funzionare. ditemi se potrebbe andare.

Cattura5.PNG

Condividi questa discussione


Link discussione
Condividi su altri siti
Mircoron

A occhio mi sembra che possa funzionare ma è "contorto", non è "pulito e lineare",

 

ciao

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×