Vai al contenuto

aniellos

plc sematic s5 da run a stop

Recommended Posts

aniellos

buonaserata volevo ringraziare a tutti i moderatori e non che mi aiutano tanto ..grazie...su un impianto gestito da cpu sematic s5  quando lavora mi va in stop rosso acceso...e mi ferma tutto.io non faccio che resettarlo da run a stop per un paio di minuti e si riprende run verde..ma mi sta facendo sempre di piu...volevo sostituire il modulo cpu lo stesso di rispetto., ma se lo spengo e gli tolgo la sua eprom inserirla nel nuovo , ho possibilita,'di perfere programma?? oppure devo adottare altre manovre...la batteria e buona...grazie per aiuto

Condividi questa discussione


Link discussione
Condividi su altri siti
pigroplc

invece di procedere a tentativi sarebbe meglio analizzare con il software il motivo dello stop. Ti serve uno che ha il software Step5 e l'interfaccia per andare online. 

togliere e rimettere la EEPROM serve solamente a perdere eventuali dati nelle DB e inizializzare le DB come da programma


Messaggio editato da pigroplc

Condividi questa discussione


Link discussione
Condividi su altri siti
aniellos

grazie per la risposta pigroplc ..ma purtroppo non ho nessuno che mi analizza il software... m

Condividi questa discussione


Link discussione
Condividi su altri siti
Adelino Rossi

Potresti avere anche un guasto in una delle schede di I/O periferiche. Il sistema s5 va in stop anche per guasto hardware sulle periferiche. Fai una foto completa del plc.

Condividi questa discussione


Link discussione
Condividi su altri siti
battistella.roberto

Ciao. ti posso indicare come ercare la causa dello stop random.

Premessa, ti serve step5 almeno v6.0 (io uso v7.23), il cavo di collegamento TTY.

Vai online con la CPU quando è in stop (il commutatore modo operativo lo devi lasciare su pos.run), naviga al menù AG (le voci saranno attive perchè sarai online con la CPU) e consulti i registri "Info AG: REG. BL." ; ti darà la causa dello stop. Così a naso anche io concordo per un problema alla periferia.

 

errore cpu.jpg

Condividi questa discussione


Link discussione
Condividi su altri siti
aniellos

20181203_103821.jpg

per adelino rossi ...come faccio a trovare quale modulo input ..output e guasto..grazie

scusatemi buonagiornata a tutti

Condividi questa discussione


Link discussione
Condividi su altri siti
battistella.roberto

come ho scritto nel mio post, con il sw s5 quando andrà in stop devi collegarti e nel registro errori vedrai la causa dello stop.

consiglio. magari non centra nulla, ma collega anche il PE sulla CPU.

poi vedo che hai la segnalazione di batteria scarica....

 

 


Messaggio editato da battistella.roberto

completamento

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc

Una delle cause di stop di questa serie (ma non l'unica) è la mancanza di collegamento tra la CPU e la prima base-bus su cui sono innestati i moduli.

Prova, a plc spento, a togliere le prime due schede EE EA e sconnettere e riconnetre la base alla CPU


Messaggio editato da rguaresc

Condividi questa discussione


Link discussione
Condividi su altri siti
max.bocca

A parte che le terre devono essere collegate e buone, una causa potrebbe essere l'alimentatore, poi i connettori Dil del bus (cavo piatto) o gli innesti dei moduli I/O qualche problema in certi ambienti li hanno creato. Per questo basta scollegarli e un po' di buon disossidante.

 

Condividi questa discussione


Link discussione
Condividi su altri siti
pt1957


Buonasera,

condivido tutti i suggerimenti ma comunque se possono servire, alcune considerazioni personali:

 

- escluderei l'alimentatore se facendo STOP-RUN il plc riparte (ripartirebbe da solo se ci fosse un buco di tensione)
- con la diagnosi "Info AG: REG. BL" di Step5 devi collegarti con il plc in stop, vedere la FB/PB ed indirizzo dove viene
  richiamata la periferia che provoca lo stop (un po macchinoso se non conosciuto)
- vero per i contatti del primo flat collegato alla cpu, ma forse poco probabile.
- personalmente verificherei la prima/seconda scheda dopo la cpu (AE/AA) schede analogiche

 

Buona fortuna

Condividi questa discussione


Link discussione
Condividi su altri siti
aniellos

buona giornata.. mi sta succedendo anche che dall azionamento dell impoanto...il plc modulo cpu si spegne...e poi si riaccendee 

Condividi questa discussione


Link discussione
Condividi su altri siti
rguaresc

Alimentazione della CPU ??? 

Puo' esserci un carico improvviso a 24 V DC. Lampade a 24 V DC di vecchio tipo non a LED?. C'e' un pulsante prova lampade?

 

Condividi questa discussione


Link discussione
Condividi su altri siti
batta
Quote

grazie per la risposta pigroplc ..ma purtroppo non ho nessuno che mi analizza il software...

 

Può essere che, andando per tentativi, ci scappi una botta di c..o e si risolva il problema, ma per riuscire almeno a circoscrivere le possibili cause, devi trovare qualcuno che si colleghi al PLC e consulti la diagnostica.
Senza questo passaggio, è come mandare dal medico la foto della carta d'identità e pretendere che il medico scopra di cosa si soffre.

Condividi questa discussione


Link discussione
Condividi su altri siti
busanela

Sono sacrosanti i consigli di Flavio e degli altri di consultare il registro delle interruzioni per accorciare la ricerca del motivo di stop della cpu, se effetivamente la cpu si pone in stato di stop. Purtroppo, in uno dei primi post aniellos ci dice che non ha la possibilità di collegarsi alla cpu, non dice se per indisponibilità dei mezzi o per mancanza di conoscenza. Ricordando l'esistenza di PG2000 scaricabile in rete la versione di valutazione che potrebbe essere sufficiente per una breve diagnosi e che i convertitori PG-AG si trovano anch'essi a pochi euro anche sulla baia elettrinica, dall' ultimo post mi sembra di intuire (il nostro amico non è prolisso di informazioni e quelle poche non sono precisissime) che la cpu passa in stop in seguito ad un "calo" di tensione, interno ad essa od esterno, non è chiarissimo. La sconnessione delle terre dà da pensare che qualcuno abbia avuto il sospetto di un corto verso massa; sarebbe bello capire se quando 

il 5/12/2018 at 10:47 , aniellos scrisse:

...il plc modulo cpu si spegne...e poi si riaccendee 

lo stesso fanno anche i led dei moduli d'ingresso (quelli delle uscite ne sono diretta conseguenza dello stop cpu), per capire se nell'istante in cui qualche uscita pilota una elettrovalvola che scarica a terra, per esempio, o qualche conduttore, di solito in catena portacavi, presenta l'isolamento corrotto.

Se invece non è un problema di tensione ausiliaria, verificabile dalle fluttuazioni con un normalissimo tester e un telefonino messo in videoregistrazione, allora non c'è trippa per gatti: la cpu va sostituita.


Messaggio editato da busanela

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×