Vai al contenuto

Giuseppe Signorella

Logo OBA8 Stranezza

Recommended Posts

Giuseppe Signorella

Ho programmato un logo OBA8 per replicare lo stato degli ingressi su un pannello operatore (Non SIemens).

In modo molto semplice e banale il software è pressapoco il seguente:

Ingresso I1 --NOT-- M1

Ingresso I2 --NOT-- M2

.

.

.

Ingresso I8 --NOT-- M9

(Ho saltato il bit M8 perchè bit di avvio.

Accade dopo qualche giorno che il logo smette di comunicare con il pannello operatore.

Il primo pensiero fù quello di ricercare il problema nella comunicazione.

Mi sono reso conto che il problema era il logo.

E' come se smettesse di aggiornare lo stato delle variabili dell'area "V"

Per maggior scrupolo, ho realizzato all'interno del logo una pagina WEB ove visualizzo lo stato dei bit Merker (dall'M1 all' M9) ed il valore di preset di alcuni temporizzatori. I valori sono appoggiati a 4 WORD che vanno dall' MW100 al MW106. Questo ovviamente  per renderle visibili sia nel pannello operatore che nel Web Server.

Dopo qualche giorno che il logo è in funzione i valori delle 4 Word (lato web server e lato pannello operatore) vanno a "0" mentre nel software il loro valore è corretto, e le icone associate ai BIT merker si comportano nel medesimo modo.

All'interno del software invece tutto funziona regolarmente.

Essendo il web server integrato all'interno del logo, ed essendo la comunicazione tra web server e logo "trasparente e nativa", lascia perplesso che il logo non aggiorna più l'area di memoria "V".

E' sufficiente trasferire nuovamente il software per far si che tutto ritorni a funzionare regolarmente.

 

 

 


Messaggio editato da Giuseppe Signorella

Condividi questa discussione


Link discussione
Condividi su altri siti
max.bocca

Che versione è il tuo logo? 

L'anno scorso c'era un aggiornamento disponibile che risolveva alcune problematiche, prova vedere se è da aggiornare.

Ma dopo quanti giorni ti succede? Potrei provare con uno che ho qui.

Condividi questa discussione


Link discussione
Condividi su altri siti
Giuseppe Signorella

Ciao,

La versione firmware è la 1.82.01 Credo che sia abbastanza recente, se non proprio l'ultima.

L'anomalia si verifica dopo 24-36 ore dal download del software.

 

Condividi questa discussione


Link discussione
Condividi su altri siti
elettrix01

Ciao Giuseppe, per far ripartire il Logo è necessario il download del software oppure è sufficiente spegnere e rialimentare? Un paio di anni fa mi è capitato che con il logo FS:04 il display andasse in tilt dopo un paio di mesi che il display restava in stand-by. Spegnendo e rialimentando il logo tutto ripartiva sentendo siemens ho risolto aggiornando il firmware alla versione 1.81.03

Condividi questa discussione


Link discussione
Condividi su altri siti
Giuseppe Signorella

Ciao,

E' necessario rifare il download. 

Ridare l'alimentazione non risolve il problema.

Domani mattina provvedo a sostituirlo con uno nuovo.

Quello difettoso lo testerò a banco. 

Condividi questa discussione


Link discussione
Condividi su altri siti
elettrix01

Ciao Giuseppe, sulla base della tua descrizione ho fatto una simulazione con il solo webserver (non ho un pannello con cui fare la simulazione). Ad oggi (48 ore) le variabili V si aggiornano correttamente.

Mi viene da pensare che quel logo sia difettoso


Messaggio editato da elettrix01

Condividi questa discussione


Link discussione
Condividi su altri siti
Giuseppe Signorella

Ciao elettrix01Ho sostituito il logo lunedì, da quel momento nessuna anomalia riscontrata. Credo anche io che sia un problema circoscritto a quel singolo logo.

Condividi questa discussione


Link discussione
Condividi su altri siti
elettrix01

Ciao Giuseppe, sono lieto che il tuo nuovo logo funzioni. Ti comunico inoltre che a 9 giorni dall'inizio della prova il mio logo continua a funzionare :) Quindi era sicuramente un difetto del singolo logo

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×