Vai al contenuto

abbio90

VPN client mikrotik con il pubblico del VPN server

Recommended Posts

abbio90

Ciao a tutti...

E possibile con mikrotik fare in modo che un client di una VPN possa uscire si internet con ip pubblico del server?

Un po come succede quando si usa Windows come client.

 

Condividi questa discussione


Link discussione
Condividi su altri siti
Andrea Annoni

Ovviamente è possibile. Usi come GW il tunnel (indirizzo IP, interfaccia, ecc) come nell'esempio che avevo indicato nell'altro forum che hai linkato.

Unica cosa devi creare una table perchè se metti con una distance più bassa il tunnel ovviamente questo cade. La default route deve essere sempre il GW fisico della LAN.

Condividi questa discussione


Link discussione
Condividi su altri siti
abbio90

Ciao Andrea, sicuramente sto sbagliando la rotta, questa configuraz. verrà utilizzata con Nord VPN ma al momento faccevo dei test creando un l2tp client verso la vpn di un'amico.

ho creato 2 vlan una locale e l'altra sotto VPN

Il GW della vpn è 192.168.90.1.

la vlan local è ok la vlan privacy non va per è chiaro che nella rotta c'è qualche castroneria

allego la coonfigurazione, magari salta fuori l'inghippo.

 

/interface bridge
add fast-forward=no name=bridge_local
add fast-forward=no name=bridge_privacy

 

/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=2ghz-b/g/n country=italy \
    disabled=no frequency-mode=regulatory-domain mode=ap-bridge ssid=\
    NORD-VPN_test wireless-protocol=802.11 wps-mode=disabled
/interface ethernet
set [ find default-name=ether1 ] name=ether1_WAN

 

/interface l2tp-client
add connect-to=8xx.xxx.xx.xx2 disabled=no name=l2tp-out2 password=ppp_test \
    user=ppp_user.test


/interface vlan
add interface=ether2 name=vlan_local vlan-id=10
add interface=ether3 name=vlan_privacy vlan-id=20


/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=test1234 \
    wpa2-pre-shared-key=test1234

 

/ip pool
add name=dhcp_pool_local ranges=10.166.42.150-10.166.42.230
add name=dhcp_pool_privacy ranges=10.166.43.150-10.166.43.230

 

/ip dhcp-server
add address-pool=dhcp_pool_privacy disabled=no interface=bridge_privacy name=\
    dhcp_server_privacy
add address-pool=dhcp_pool_local disabled=no interface=bridge_local name=\
    dhcp_server_local

 

/interface bridge port
add bridge=bridge_privacy interface=wlan1
add bridge=bridge_privacy interface=ether4
add bridge=bridge_privacy interface=ether3
add bridge=bridge_local interface=ether2
add bridge=bridge_local interface=vlan_local
add bridge=bridge_privacy interface=vlan_privacy

 

/ip address
add address=10.141.10.12/24 interface=ether1_WAN network=10.141.10.0
add address=10.166.42.1/24 interface=vlan_local network=10.166.42.0
add address=10.166.43.1/24 interface=vlan_privacy network=10.166.43.0

 

/ip dhcp-server network
add address=10.166.42.0/24 dns-server=10.166.42.1 gateway=10.166.42.1 netmask=\
    24 ntp-server=193.204.114.105
add address=10.166.43.0/24 dns-server=10.166.43.1 gateway=10.166.43.1 netmask=\
    24 ntp-server=193.204.114.105

 

/ip dns
set allow-remote-requests=yes servers=1.1.1.1,8.8.8.8

 

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1_WAN

 

/ip route
add distance=1 gateway=192.168.90.1 routing-mark=VPN
add distance=1 gateway=10.141.10.1

 

/ip route rule
add dst-address=0.0.0.0/0 src-address=10.166.43.0/24 table=VPN

 

/system clock
set time-zone-name=Europe/Rome
/system ntp client
set enabled=yes primary-ntp=193.204.114.105
[admin@MikroTik] >

 

Condividi questa discussione


Link discussione
Condividi su altri siti
Andrea Annoni

Ti manca di sicuro il masquerade della subnet VPN

Condividi questa discussione


Link discussione
Condividi su altri siti
abbio90

provavo il masquarade specificando la subnet ma non lavorava,,,cosi l'ho fatto specificando il routing table e specificando la table VPN e cosi funziona. e esco con l'indirizzo pubblico laato GW VPN.

al di la del fatto che funziona mi chiedevo se ho fatto correttamente o meno

Condividi questa discussione


Link discussione
Condividi su altri siti
Andrea Annoni

Come ben sai ci sono sempre più modi per arrivare alla soluzione con Mikrotik.

Tecnicamente deve funzionare anche mascherando la subnet della VPN.

Condividi questa discussione


Link discussione
Condividi su altri siti

Registrati o accedi per inserire messaggi

Devi essere un utente registrato per lasciare un messaggio. La registrazione è GRATUITA.

Crea un account

Iscriviti alla nostra comunità. È facile!

Registra un nuovo account

Connettiti

Hai già un account? Connettiti qui

Connettiti adesso

×