Jump to content
PLC Forum

etamatteo

Comunicazione persa (ERR e TER lampeggiante) TSX Micro

Recommended Posts

etamatteo

Avrei bisogno di un'aiuto sul seguente problema:

 

we lose the communication between ECR and EGB soot blower control panel, 

We try to restart the panel but we don’t have the feedback on ECR, remain in local and also in this situation  we cannot have the monitor of all LED in the panel because are off. 

image.png.b31ca3afeb1341ef99cb3b2e693afe5d.png

In first step we check the connection and the functionality on the selector LOCAL-REMOTE(see attach), tight all cable,
The signal to this selector go in input to the PLC 

 

image.png.0ccb9b9824669e3f68f84fc5fa4d90d3.png



Later we proceed to change the modulo 1, 2 & 3 INPUT & OUTPUTafter restart remain the same alarm (ERR and TER blinking).

 

image.png.44b3d08cf307e550904197bff16338e8.png

 

We see on PLC drawing this alarm is attributed to PLC FAULT OR SYSTEM FAULT,

The model of PLC is Modicon TSX Micro (Telemecanique) model TSX 3721001

 

image.png.e7257f0db20312f7738d1935f6a83eee.png

 

For your information we have on stock the spare parts(new model SCHNEIDER)without program

 

image.png.0f283d49a70dd061c74d21d9a1e1da3f.png

 

 We don’t have onboard one laptop with the program to transfer can you . us with more details or what we can do to reestablish the communications?

 

Thanks a lot for your collaboration

 

 

 

image.png

Share this post


Link to post
Share on other sites
max.riservo

Il PLC non è in RUN ma in FAULT.

Possibili cause :

- mancanza del programma applicativo (si è scaricata/manca la batteria tampone, il PLC si è spento e il programma è andato perso)

- guasto hardware della CPU

- errore nell'applicativo (i.e. superamento del watchdog). Se non ricordo male, queste anomalie,mettono in STOP la CPU e fanno lampeggiare il LED verde (RUN) mentre nel tuo caso sembra spento

 

Per risolvere la situazione hai comunque bisogno del programma applicativo, del sw di sviluppo (direi PL7 Pro) e del cavo seriale/USB di connessione.

Ti colleghi al PLC (se ci riesci) e analizzi le cause.

Magari sei fortunato e devi semplicemente rimettere in RUN il PLC (ho qualche dubbio) oppure devi ricaricare il SW applicativo.

 

P.S. - se sei a bordo ... buona navigazione.

Share this post


Link to post
Share on other sites
etamatteo
9 ore fa, max.riservo scrisse:

Il PLC non è in RUN ma in FAULT.

Possibili cause :

- mancanza del programma applicativo (si è scaricata/manca la batteria tampone, il PLC si è spento e il programma è andato perso)

- guasto hardware della CPU

- errore nell'applicativo (i.e. superamento del watchdog). Se non ricordo male, queste anomalie,mettono in STOP la CPU e fanno lampeggiare il LED verde (RUN) mentre nel tuo caso sembra spento

 

Per risolvere la situazione hai comunque bisogno del programma applicativo, del sw di sviluppo (direi PL7 Pro) e del cavo seriale/USB di connessione.

Ti colleghi al PLC (se ci riesci) e analizzi le cause.

Magari sei fortunato e devi semplicemente rimettere in RUN il PLC (ho qualche dubbio) oppure devi ricaricare il SW applicativo.

 

P.S. - se sei a bordo ... buona navigazione.

Grazie mille per i consigli.

 

Proviamo e ti aggiorno per ulteriori azioni.

Non sono a bordo, ma grazie lo stesso.

Share this post


Link to post
Share on other sites
etamatteo
12 ore fa, max.riservo scrisse:

 

Rispondo sotto:

 

Quote

Il PLC non è in RUN ma in FAULT.

Possibili cause :

- mancanza del programma applicativo (si è scaricata/manca la batteria tampone, il PLC si è spento e il programma è andato perso)

La batteria a tampone installata ha una tensione di 3.6 Volt (modello 1/2 AA Gennaio 2009) ma essendo datata non avrà più la forza di sopportare il carico del suo impiego
Per confermare questa ipotesi,abbiamo notato che ogni volta viene interessato lo STOP DI EMERGENZA il sistema viene disalimentato completamente.
Ecco allora una delle probabili cause della perdita del programma avendo una batteria non più idonea.

Quote

- guasto hardware della CPU

Non dovrebbe essere stato coinvolto

Quote

- errore nell'applicativo (i.e. superamento del watchdog). Se non ricordo male, queste anomalie,mettono in STOP la CPU e fanno lampeggiare il LED verde (RUN) mentre nel tuo caso sembra spento

Il led verde RUN e spento, mentre lampeggiano i led di segnalazione TER e ERROR.

Quote

Per risolvere la situazione hai comunque bisogno del programma applicativo, del sw di sviluppo (direi PL7 Pro) e del cavo seriale/USB di connessione.

Ti colleghi al PLC (se ci riesci) e analizzi le cause.

Magari sei fortunato e devi semplicemente rimettere in RUN il PLC (ho qualche dubbio) oppure devi ricaricare il SW applicativo.

Questo PLC non ha la modalita commutare in RUN e purtroppo non abbiano in nostro possesso un computer da poter collegare ed il cavo adatto a tale scopo.
 

Ulteriori consigli da darmi?

Grazie

Share this post


Link to post
Share on other sites
max.riservo

Se, come sembra, la causa del problema è la perdita del sw (dovuta all'invecchiamento della battera tampone) non hai molte possibilità :

 devi ricaricare il SW applicativo e, se tutto funziona, rimetti il PLC in run

Per farlo ti serve :

- pc con windows XP (o macchina virtuale)

- ambiente di sviluppo PL7Pro V4.5 (presumibilmente)

- sw applicativo

- cavo di connessione al PLC (lato PC seriale/usb - lato PLC con connettore Schneider)

Non vedo altre soluzioni ....

Anche installare una CPU nuova presuppone che tu abbia quanto scritto sopra.

Ulteriore possibilità, se fattibile, contattare un tecnico in grado di darti il supporto intervenendo in loco ....

Share this post


Link to post
Share on other sites
etamatteo
13 minuti fa, max.riservo scrisse:

Se, come sembra, la causa del problema è la perdita del sw (dovuta all'invecchiamento della battera tampone) non hai molte possibilità :

 devi ricaricare il SW applicativo e, se tutto funziona, rimetti il PLC in run

Per farlo ti serve :

- pc con windows XP (o macchina virtuale)

- ambiente di sviluppo PL7Pro V4.5 (presumibilmente)

- sw applicativo

- cavo di connessione al PLC (lato PC seriale/usb - lato PLC con connettore Schneider)

Non vedo altre soluzioni ....

Anche installare una CPU nuova presuppone che tu abbia quanto scritto sopra.

Ulteriore possibilità, se fattibile, contattare un tecnico in grado di darti il supporto intervenendo in loco ....

Grazie nuovamente.

Ti ho scritto un messaggio in privato se avevi dei contatti da darmi...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...