Jump to content
PLC Forum


rgbsystem

backup num 750t

Recommended Posts

rgbsystem

Buongiorno a tutti, ho un problema con un controllo num 750t, in pratica è apparso sulla schermata l'errore 1035, ho sostituito la scheda auto e all'avvio adesso chiede il classico raz/ram ma poi viene una scherma con l'errore 3035.
Ho il dubbio che debba essere ricaricato qualcosa, il problema che non ci sono dischetti ma solo il libro macchina, adesso c'è qualcuno sul forum ch ha un backup generico di un num 750t? vorrei provare a ricaricare i dati alle volte fosse un problema di software che stava sulla scheda auto, ho visto che su questa scheda ci sono delle flash che stanno sotto backup con le batterie.

grazie

Share this post


Link to post
Share on other sites

rgbsystem

Aggiornamento:
a seguito della sostituzione della batteria tampone sulla scheda auto, riporta la schermata di errore 3015, leggendo in rete, perchè purtroppo manca il manuale, vanno ricaricati i dati. Proprio su questi mi ritrovo un libro macchina dove ci sono i dati stampati e quindi il caricamento a mano, oppure un floppy disk con dei file .bin che dovrebbero essere i backup.
Leggo un estratto preso in rete, per il caricamento serve un programma chiamato "Numcom", ho provato a cercarlo ma non sono riuscito a trovarlo, quindi chiedo se qualcuno si è imbattuto con il caricamento e come lo ha risolto, se è disponibile a condividere tale esperienza.

ciao

Share this post


Link to post
Share on other sites
lucios

Non ho più i manuali del 750 e non mi ricordo cosa significa l'errore 3015, magari potresti postare la foto dello schermo.

Comunque quando si cambiavano le batterie della scheda AUTO (vado a memoria perchè sono anni che non vedo un CNC di quel tipo), non andava perso ne il PLC, che è su EEPROM, ne i parametri macchina, che sono sulla scheda PROC.

Si perdeva tutto ciò che era su memoria tamponata, cioè i dati retentivi del PLC. Ma questi dati normalmente non sono sui dischi di backup, sui quali veniva salvato il programma PLC ed i parametri. Probabilmente si tratta dei file .bin ai quali fai cenno, ma che non dovrebbero essere andati perduti.

Per ricaricare il PLC ed i parametri io utilizzavo un programma chiamato APA10 che però funzionava sotto DOS ed aveva il problema del millenium bug (per il quale andava falsato il datario del PC...). Devo averlo da qualche parte e, se lo trovo, te lo posso inviare però, prima di avventurarti in operazioni di restore che, se non le hai mai fatte, potrebbero risultare complicate, ti consiglio di capire bene a cosa è dovuto l'errore.

Eventualmente prova prima a dare un colpo di telefono alla Num di Milano e spiegare il problema.

Edited by lucios

Share this post


Link to post
Share on other sites
rgbsystem

il controllo è già stato dalla num ed è meglio stendere un velo pietoso, purtroppo non sono, lo dico come mia esperienza, collaborativi, ma posso capirli, ognuno oggi tira l'acqua nel suo mulino, riguardo alla schermata di errore, il controllo è sul banco quindi posso fare tutte le prove che voglio, ti allego la foto l'errore 3015 con indirizzo memoria 3010, questo errore da quando è stata sostituita la scheda auto con le batterie che era guasta.

Non avendo il manuale e cercando in rete mi sembra di capire che vanno ricaricati di dati macchina, il plc no, è su eprom e qui non dovrebbero essere persi.

WP_20160524_003.jpg

Share this post


Link to post
Share on other sites
lucios

Ah ma quella è una exception, dovevo immaginarmelo dal codice a 4 cifre... scusa ma sono anni che non vedevo un Num di quell'epoca e non ricordavo...

Il numero da guardare in questo tipo di errori è quello corrispondente all'indirizzo di memoria, nel tuo caso 00010300.

Ho trovato della vecchia documentazione e sembra che la causa sia che non vengono riconosciuti uno o più assi macchina dichiarati.

Quindi le cause potrebbero essere:

- Guasto di una scheda assi.

- Guasto di un cavo di misura.

- Uno o piu parametri assi corrotti.

 

Ma come mai hai sostituito la scheda AUTO? Il vecchio errore 1035 a che indirizzo di memoria puntava? Chi ti ha consigliato questa operazione?

 

Comunque:

La prima cosa da fare è verificare se hai un software chiamato "Utilitaire 5" caricato a bordo CN.

Per fare questo devi andare nel menù "Utilitaires" premendo il tasto con l'icona di un libro sotto lo schermo (l'ultimo a sinistra) e poi navigare tra i menù. Purtroppo non mi ricordo la sequenza esatta ma è veramente passato troppo tempo... comunque dovresti riuscirci.

C'era qualcosa chiamato se non ricordo male "Gestion des utilitaires" e da lì si accedeva.

Se hai l'utilitaire 5 puoi accedere all'editor dei parametri e, con il documento cartaceo alla mano, controllare che corrispondono. Nel tuo caso i più interessanti sono il P2 ed il P9 che riguardano appunto gli assi.

Se invece non c'è l'utilitaire 5 bisogna connettersi (in seriale con l'apposito cavo) utilizzando un software chiamato APA10 e caricare le utilitaires necessarie.

Però non è una operazione semplice da spiegare tramite post a chi non l'ha mai fatta.

Quote

il controllo è già stato dalla num ed è meglio stendere un velo pietoso, purtroppo non sono, lo dico come mia esperienza, collaborativi, ma posso capirli, ognuno oggi tira l'acqua nel suo mulino

Perchè? Cosa ti hanno detto? E' strano perchè in genere sono gentili e collaborativi.

Perchè l'hai mandato in Num? Qual'è la storia di quel CN?

Share this post


Link to post
Share on other sites
rgbsystem

con la vecchia scheda auto restituisce l'errore 1035 indirizzo 0002080f codice 1039, inoltre non funzionano i menù premendo i il tasto charg dal cn.

sostituendo la scheda auto restituisce la schermata controllore non inizializzato e premendo il tasto charg e poi il menù util 1 restituisce 4ed6 con tutte le FF, presuppongo che sia vuoto il menù che dovrebbe essere caricato.

IMG_4841.JPG

IMG_4836.JPG

IMG_4838.JPG

IMG_4839.JPG

IMG_4837.JPG

Share this post


Link to post
Share on other sites
lucios

Si l'errore 2080F potrebbe indicare in effetti un guasto sulla scheda AUTO.

Invece quella fila di FFFFFFF potrebbe essere un problema sulla memoria RAM.

Ma la scheda nuova dove l'hai presa? Funzionava prima?

E si tratta della stessa versione della precedente? Sul frontalino c'e scritto la versione e la memoria montata; a volte ci sono incompatibilità.

Share this post


Link to post
Share on other sites
rgbsystem

FFFFF lo da se premo 8 util1, la scheda auto proviene da un altro cestello identico con solita sigla, anche la scheda è con la solita sigla, il bello che questo cestello fa il solito identico problema cioè l'errore 3015

Share this post


Link to post
Share on other sites
lucios

Lascia perdere il comando 8...

A questo punto penso che la sola cosa che puoi tentare è quella di caricare l'utilitaire 5 che è quella che ti permette di modificare i parametri.

Però ti occorre il programma "APA10", il file binario dell'utilitaire 5, un cavo di connessione seriale ed un PC con una porta seriale reale (non USB) che si possa configurare come COM1 o COM2 e dal quale si possa eseguire un programma in DOS. Non è comunque una procedura agevole per chi non l'ha mai fatta, e non è neanche semplicissimo spiegarla via post purtroppo...

 

Considerazioni che non hanno nulla a che vedere con il problema specifico (e che probabilmente ti se già posto):

Il NUM 750/760 è un prodotto fuori produzione da, se non mi ricordo male, più di 30 anni, la NUM (ovviamente) non garantisce più la fornitura dei ricambi ne la riparazione degli stessi (alcuni componenti non sono più reperibili), quindi:

- La macchina meccanicamente è in buono stato e pensi di poterla utilizzare ancora per un po' e quindi possa valere la pena di pensare ad un revamping, magari solo elettrico?

- Rottamazione e acquisto di qualcosa di nuovo?

Edited by lucios

Share this post


Link to post
Share on other sites
rgbsystem
il 6/8/2019 at 08:54 , lucios scrisse:

Lascia perdere il comando 8...

A questo punto penso che la sola cosa che puoi tentare è quella di caricare l'utilitaire 5 che è quella che ti permette di modificare i parametri.

Però ti occorre il programma "APA10", il file binario dell'utilitaire 5, un cavo di connessione seriale ed un PC con una porta seriale reale (non USB) che si possa configurare come COM1 o COM2 e dal quale si possa eseguire un programma in DOS. Non è comunque una procedura agevole per chi non l'ha mai fatta, e non è neanche semplicissimo spiegarla via post purtroppo...

 

Considerazioni che non hanno nulla a che vedere con il problema specifico (e che probabilmente ti se già posto):

Il NUM 750/760 è un prodotto fuori produzione da, se non mi ricordo male, più di 30 anni, la NUM (ovviamente) non garantisce più la fornitura dei ricambi ne la riparazione degli stessi (alcuni componenti non sono più reperibili), quindi:

- La macchina meccanicamente è in buono stato e pensi di poterla utilizzare ancora per un po' e quindi possa valere la pena di pensare ad un revamping, magari solo elettrico?

- Rottamazione e acquisto di qualcosa di nuovo?

ciao, scusa il ritardo ma avevo accantonato un po' il tutto, io non ho i dischetti di sistema ma un cartaceo che dovrei reinserire a mano, se solo sapessi come fare, per quanto riguarda un retrofit lo accantonato come la sostituzione, in primis perchè meccanicamente ed elettronicamente sono sempre in ottimo stato, un retrofit costerebbe più del valore della macchina, anche se pur efficiente, in secondo ho solo subito una perdita di dati e devo reinserirli, insomma mi sembra paradossale buttare via una macchina funzionante solo per il ripristino dei dati...non credi?

Ho provato a parlare con il costruttore o quanto ne rimane, ma mi ha girato solamente i dati in formato cartaceo, devo trovare il modo di inserirli, cosa che non so.

Share this post


Link to post
Share on other sites
lucios

Vale sempre quello che ti ho detto, e cioè procurarsi il programma APA10, installarlo su un PC, ecc. ecc.

Una volta installata l'utilitaire 5 si potranno reimmettere a mano i parametri direttamente dalla tastiera del cn. Operazione noiosa ma fattibile in mancanza dei file di backup.

Però scusa se te lo ridico: le operazioni da eseguire sono semplici se hai esperienza, altrimenti possono risultare complesse e risulta macchinoso spiegarle via post.

Ritornando al revamping: giustamente è una valutazione che puoi fare solo tu però tieni presente che se ti si rompe una scheda e non hai il ricambio poi sei fermo veramente.

Ma di che tipo di macchina si parla?

Share this post


Link to post
Share on other sites
rgbsystem

Ma l’utilitaire 5 dove lo trovo? Il programma apa10 in rete non si trova ,ho quanto meno non sono stato in grado di trovarlo...ho due cn completi del num 750,sono recuperati ma funzionanti,li uso per i ricambi come la scheda auto 

Share this post


Link to post
Share on other sites
lucios

Da qualche parte dovrei averlo, se hai pazienza lo cerco e te lo faccio avere, non dovrei violare nulla perchè ormai è un "abandonware".

Dovrei avere anche le utilitaires.

Tieni presente comunque che è un programma che gira sotto DOS.

Share this post


Link to post
Share on other sites
rgbsystem

Te ne sarei grato,nessun problema per farlo girare, utilizzo vecchi pc che sono l'ambiente nativo di questi programmi.

Share this post


Link to post
Share on other sites
lucios

Ho trovato qualcosa, se mi giri il tuo indirizzo email tramite MP ti mando il tutto.

Share this post


Link to post
Share on other sites
rgbsystem

buondì, ho preparato tutto l'ambiente ms-dos e caricato le utilitaires nella cartella, però non me le carica, aspetta un consenso lato cn che non so qual'è, premo un tasto qualsiasi e in alto a destra compare la scritta pausa lampeggiante, il cn deve essere in una condizione particolare per ricevere i dati...ma qual'é?

image2.jpeg.de2eea72a0b6772154ef4a5bc6b75150.jpeg

image1.jpeg

Edited by rgbsystem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...