Jump to content
PLC Forum


ottoz

comunicazione tra due plc con profinet e plcsim

Recommended Posts

ottoz

Ciao a tutti  ho provato a collegare due plc s71500 tra di loro con profinet  tutto questo nel tia v15  ma ho visto che non si puo simulare  con plcsim  e vero?

grazie

 

Share this post


Link to post
Share on other sites

batta

Cosa intendi con " collegare due plc s71500 tra di loro con profinet "? Devono scambiare dati tra di loro? In che modo? Cosa non funziona col simulatore?
Hai lanciato la simulazione di entrambi i PLC?
Che versione di PlcSim stai usando?

Share this post


Link to post
Share on other sites
step-80

Logico...si parla di 1500 nella sezione 1200. 

 

Classica discussione in cui chi ha postato si eclissa

Share this post


Link to post
Share on other sites
ottoz

ciao Batta in pratica ho preso due plc s7 1200  uguali con tia v15.0 uno fa il controller e l altro i device  la comunicazione la faccio con aree di trsferimento

un plc riesco a caricarlo e laltro non si puo in sostanza non funzionano

posso farli comunicare fra di loro con simulatore plcsim?

Share this post


Link to post
Share on other sites
batta

Ma hai aperto un'altra istanza del simulatore, o stai cercando di fare il download della seconda cpu con una sola istanza di PlcSim aperta?

Share this post


Link to post
Share on other sites
ottoz

doanload con plc sim aperto

Share this post


Link to post
Share on other sites
batta
11 ore fa, ottoz scrisse:

doanload con plc sim aperto

Ma quanti PlcSim hai aperto? Uno solo, o uno per ogni PLC?

Share this post


Link to post
Share on other sites
ottoz

doanload con plc sim aperto

Share this post


Link to post
Share on other sites
step-80

Seguo questa discussione con interesse, specialmente per la quantità di dettagli ..

Share this post


Link to post
Share on other sites
batta
il 27/8/2019 at 15:32 , step-80 scrisse:

Seguo questa discussione con interesse, specialmente per la quantità di dettagli ..

Effettivamente, non è che "Ottoz" si sprechi.

Poi, credevo di essere stato abbastanza chiaro: se continuo a chiedere se hai aperto una sola istanza oppure due istanze di PlcSim, significa che devi aprire due istanze di PlcSim.
Dunque, apri il tuo progetto TIA con due PLC. Selezioni un PLC e clicchi sull'icona del simulatore. Ti si apre un'istanza di PlcSim e scarichi il progetto in quel simulatore.
Poi selezioni il secondo PLC, clicchi sull'icona simulatore, TI SI APRE UN'ALTRA ISTANZA di PlcSim, e scarichi il programma in quel simulatore.

Aprire un solo simulatore e cercare di scaricarci dentro il programma di due diversi plc, è come cercare di caricare due programmi diversi in un'unica cpu.

Share this post


Link to post
Share on other sites
ottoz

e vero sono sempre un po taccagno, in realta volevo capire se era possibile fare un collegamento di comunicazione tra due plc  e simularlo con plc sim.

quindi  mi stai dicendo che si puo fare  come dici Tu? allora provo poi ti dico

 

Share this post


Link to post
Share on other sites
ottoz

 

grazie  mille ,siete indispensabili  ho fatto come hai detto e funziona

sono contento

ciao un grazie di cuore

 

Share this post


Link to post
Share on other sites
ottoz

sembrava bello adesso funziona on line solo che il trasferimeto delle are di ingerssi e uscite non avviengono  in pratica devo trasferire uscita q2.0 del controllore all ingresso del device

I2.0 per poi comandare un uscita sul device q0.0

in sostanza al controllore nella area di trasferimento ho indirizzo Q2  e va verso I2.

quindi nel controllore  in OB1 ho cerato un segmento con i0.0 che comanda una bobina Q2.0

nel device in ob1 ho creato un segmento con un un contatto I2.0 che comanda un uscita q0.0

ma lo scambio non avviene ???

non so se sono stato chiaro

Share this post


Link to post
Share on other sites
batta
1 ora fa, ottoz scrisse:

non so se sono stato chiaro

No, assolutamente no.
Devi specificare in modo dettagliato come hai configurato le due cpu, come avviene lo scambi dati, le aree dei dati di scambio.

Share this post


Link to post
Share on other sites
ottoz

ok stasera ti dico tutto per filo e per segno

ciao Batta

 

Share this post


Link to post
Share on other sites
ottoz

 ho aperto tia v15.1, ho preso due cpu 1215 dc dc dc una l ho chiamata controller e atra device.

in vista rete ho collegato le due ineterfaccie  in profinet  plc controller ho aperto la porta di interfaccia . modi di funzionamento  vedi  seconda  foto(controller)

poi ho aperto interfaccia porta profinet del device in proprieta 3 foto (device)

ho aperto ob1 in controller e ho creato un segmento foto 4(ob1 controller)

poi ho aperto obi del device fota 5(obi device)

caricato il primo plc controller con plcsim e poi ho caricato il device con plcsim in totale due plcsim il tutto viene caricato ,pero quando alzo il bit i0.0 il q2.0 si alza (ob1 controller)

ma nel obi device i2.0 non mi alza l uscita q0.0 del device .

spero di essere stato un po piu chiaro

 

 

 

profinet.JPG

controller.JPG

device.JPG

ob1 controller.JPG

ob1 device.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...