Jump to content
PLC Forum


Sign in to follow this  
anarchico

Tcon,Tdiscon,Tsend Problemi Tia Portal V15

Recommended Posts

anarchico

Buonasera,

dovrei mettere in comunicazione una Cpu S7 300 con una stampante attivando una comunicazione TCP. Ora l'HW di cui dispongo è una CPU 315 2-DP a cui è stata aggiunta una CP 343-1 per implementare una comunicazione con uno switch su cui sono collegati pannello e stampante e altre utenze.Il progetto,per ordine del cliente è stato realizzato con piattaforma Tia Portal V15.

Mi accade una cosa strana o forse normale,io non so dirlo.I blocchi Tcon,Tdiscon e Tsend sono presenti in Comunicazione ma non selezionabili.

Se cambio nel progetto la cpu e ne prendo una qualsiasi PN tutto torna a funzionare e i blocchi sono di nuovo selezionabili.E' una stranezza dovuta a una diavoleria legata a versione firmware o quant'altro e quindi normale,oppure con Tia portal i blocchi selezionabili sono legati alla CPU scelta?Che essendo solo DP non prevede comunicazione TCP?

La cosa che non mi torna è che se lo provo sullo Step7 non ho problemi.

 

Sbaglio io,o è una limitazione del Tia Portal con CPU di vecchia generazione e profibus?

 

Grazie mille.

Share this post


Link to post
Share on other sites

TravelMen

Ciao

 

in genere si, ci sono cpu che non dispongono di comunicazione TCP/IP, come la 315-2DP, controlla il tipo di CP che hai messo.

In setp7 non viene fatto un controllo tra blocchi che usi e tipo di PLC, ecco perchè te lo lascia fare, ma poi non comunichi, io ci ho perso una giornata intera su una CPU et200s che disponeva della sola comunicazione Profinet e non TCP/IP che mi serviva.

 

Saluti

 

Share this post


Link to post
Share on other sites
anarchico

Grazie mille,sei sempre così pronto e gentile.

Quindi il fatto di avergli abbinato una Cp 343-1 non modifca lo stato delle cose.

Ottimo,ed ora?

L'unica alternativa è anche qui cambiare la CPU? 

Saluti.

 

Share this post


Link to post
Share on other sites
TravelMen

Ciao

 

hai provato a vedere se cambiando CP le cose cambiano.

 

Saluti

 

Share this post


Link to post
Share on other sites
anarchico

Ho provato con tutte quelle a catalogo 343-1 , 343-1 Lean,343-1 Advanced,343-1 ERPC ma niente.

 

 

Edited by anarchico

Share this post


Link to post
Share on other sites
anarchico

Mi sa che l'unica soluzione è sostituire la CPU.

 

Share this post


Link to post
Share on other sites
floydfan

Open user communication funziona solo con la porta Profinet della CPU....che la 315-2dp non ha..

Devi cambiare la cpu 2dp con una cpu Profinet sempre serie 300

Io comunque non userei TIA Portal per le Cpu serie 300...usa Simatic Manager..

Edited by floydfan
ulteriori informazioni

Share this post


Link to post
Share on other sites
anarchico

Grazie Floydfan, l'uso del Tia portal mi sta dando tanti problemi,ma non è una mia scelta ma del cliente.

Si,oramai ero certo di dover cambiare la CPU.Sono in attesa della risposta cliente dato che il sistema l'ha progettato lui recuperando dei suoi pezzi a magazzino.

Attualmente lavorano senza stampante.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...