Jump to content
PLC Forum


agoman

modifica alimentazione ,su visualizzatore consumo energetico a led.

Recommended Posts

agoman

buonasera a tutti, tempo fa' avevo realizzato un visualizzatore di consumo a led e un anno che funziona, pero' ha un piccolo problemino con la lavatrice il primo led si accende anche col solo motore avviato quando si dovrebbe accendere a 1000w , il problema ho notato che e' della lavatrice perche' con altre lavatrici provate il problema non lo da' , forse perche' la mia e una marca cinese ahahahha e meno filtrata non saprei. girando per il forum ho trovato questo schema gia' realizzato, e sembra funzionare, chiedevo 3 informazioni.

1 il TA vuole per forza il sirio? ho puo' funzionare con altri tipi.

2 ho provato come da foto a mettere un toroide con spire avvolte ma la tensione non supera i 3,50 volt e normale?  ho ho sbagliato qualcosa un led lo accende, regolando il trimmer riesco ad arrivare a massimo a quella tensione non oltre, a 1000w ho 1,30v e a 2000 il doppio.

3 chiedevo ma l'uscita del lm324 che corrente puo' sopportare posso collegare il circuito che tempo fa' ho fatto?

ho fatto questo circuito pensando che magari e piu' staboile spero.

 

Nessuna descrizione della foto disponibile.90715228_3812813832092103_7032008683676499968_o.jpg?_nc_cat=104&_nc_sid=110474&_nc_ohc=-mUz15W3FnYAX8A41IO&_nc_ht=scontent-mxp1-1.xx&_nc_tp=6&oh=926ab5db5f1236f7479b2d4c578920c2&oe=5EA0DFA2

 

schema.

Nessuna descrizione della foto disponibile.

Edited by Domenico Maschio

Share this post


Link to post
Share on other sites

gabri-z

Ma non fai passare la fase al interno del toroide ?

Che marca è l'adattatore schuko ? 

Share this post


Link to post
Share on other sites
agoman
1 ora fa, gabri-z ha scritto:

Ma non fai passare la fase al interno del toroide ?

si ho messo un fono industriale  ho usato una spina col filo volante per fare una prova alla veloce.

1 ora fa, gabri-z ha scritto:

Che marca è l'adattatore schuko ?

:roflmao: non volevo tagliare la spina per tirare fuori il filo.

 

ma sono le armoniche del motore della lavatrice a fare sto casino

strano perche' con un'altro modello di lavatrice non me lo dava questo problema, giusto giusto a me e andata a capitare sta lavatrice, al di fuori la lavatrice va perfettamente peccato.

 

dimenticavo a dirti che un lm324 e saltato non so' il motivo anche il led si e bruciato forse perche' il toroide a poche spire? oppure  ho caricato troppo l'uscita,!!  ma con un solo led non penso, non ho utilizzato la resistenza sara' per quello?

il toroide originale a 151 spire? che significa dalla sigla sai qualcosa?

151008.

 

 

 

Edited by agoman

Share this post


Link to post
Share on other sites
gabri-z

Hai un oscilloscopio , guarda a che frequenze si trovano , e se non riesci con un filtro solito sull'alimentazione della la lavatrice , puoi sempre filtrarle nel ingresso del tuo '' coso ''.

Quale è lo schema che hai fatto ?

Share this post


Link to post
Share on other sites
gabri-z
14 minuti fa, agoman ha scritto:

non volevo tagliare la spina per tirare fuori il filo.

Guarda che non occorre tagliare la spina , basta ......tagliare il cavo !:roflmao:

Share this post


Link to post
Share on other sites
rfabri

Pero sull'uscita del TA in parallelo alla r da 100ohm non potevi mettere un condensatore di filtro tipo un 0,1uF e anche sul cursore del potenziometro un condensatore da 1uF non stava male.

Share this post


Link to post
Share on other sites
agoman

questa era il circuito fatto. il filtro in entrata lo messo molti disturbi sono andati via ma si vede che quel motore della lavatrice ha altri disturbi bo , ho provato anche ha mettere un filtro anti disturbo esterno in parallelo all'alimentazione della lavatrice  ma non cambia nulla.

 

 

Nessuna descrizione della foto disponibile.

Share this post


Link to post
Share on other sites
agoman
45 minuti fa, rfabri ha scritto:

Pero sull'uscita del TA in parallelo alla r da 100ohm non potevi mettere un condensatore di filtro tipo un 0,1uF e anche sul cursore del potenziometro un condensatore da 1uF non stava male.

lo schema non lo fatto io ci stava gia' sul forum.

Share this post


Link to post
Share on other sites
agoman

questo e il circuito completo trovato nel forum che ha quella parte di circuito messo.

Nessuna descrizione della foto disponibile.

Share this post


Link to post
Share on other sites
rfabri

questi circuiti sono di Mirko, però mi pare strano che sul TA essendo attraversato dalla corrente di qualsiasi utilizzatore non ci sia nemmeno un filtro di nessun tipo, o fatto qualcosa anch'io del genere però ho dovuto filtrare perchè motori come quello della lavatrice sia a triac che i moderni a inverter mi creavano disturbi, mentre carichi resistivi ok.

Share this post


Link to post
Share on other sites
agoman
2 ore fa, rfabri ha scritto:

mentre carichi resistivi ok.

stessa cosa il mio circuito, con l'induttivo e un caos.

nel mio circuito un filtro l'ho messo molti disturbi li ha eliminati ma il primo led pultroppo si accende lo stesso solo con motore in rotazione  , quindi  con 120w circa mi falsifica la lettura e non sono + 1000w ma 100w , pero'  lo so io e amen, se riuscissi  ad  eliminare questo problema sarebbe bello, ci vorrebbe un oscilloscopio ma non me lo trovo :-(.  per questo motivo ho provato a fare questo circuito, ma ho paura che dia lo stesso problema ma non ne sono sicuro mi servirebbe il TA originale e capire se  in uscita del lm324  posso alimentare il mio circuito esistente.

Edited by agoman

Share this post


Link to post
Share on other sites
Livio Orsini

Il Circuito di MIRKO è filtrato, ed anche pesantemente.

Se osservate a valle dei 2 raddrizzatori c'è un grosso condensatore elettrolitico (22µF) che ammazza tutto; non solo ma serva anche spianare i picchi dei carichi transitori.

Share this post


Link to post
Share on other sites
Adelino Rossi

Il ta o toroide è un elemento fondamentale per il funzionamento dei rilevatori di corrente.

ogni toroide è costruito per scopi specifici e non sono di uso generale.

Per usi di questo tipo conviene acquistare un toroide ta dichiarato per gli ampere max previsti ormai costano decisamente poco.

Per prova ho acquistato un toroide di recupero a una fiera e con un circuito di prova l'ho caricato in corrente. Non andava oltre i due ampere poi si saturava.

Moltissimi toroidi sono costruiti espressamente per circuiti di filtraggio.

Per circuiti di questo tipo a mio parere conviene testare il toroide da solo a banco per tutto il range di corrente e solo dopo aver verificato che ai capi della resistenza di carico

c'è la tensione esatta corrispondente si può inserire il ta nel circuito di misura. 

Vedi se questa discussione ti può essere utile.

visualizzatore-consumo-kw-a-led

 

 

Share this post


Link to post
Share on other sites
agoman

grazie adelino provo a leggere.

Share this post


Link to post
Share on other sites
gabri-z
6 ore fa, Adelino Rossi ha scritto:

conviene testare il toroide da solo a banco per tutto il range di corrente e solo dopo aver......

:thumb_yello: Nessuna piega....

Aggiungerei che la risposta in secondario deve essere proporzionale al carico , lineare .

Edited by gabri-z

Share this post


Link to post
Share on other sites
agoman
5 ore fa, gabri-z ha scritto:

Aggiungerei che la risposta in secondario deve essere proporzionale al carico , lineare .

quindi se prendo il toroide giusto e utilizzo questo schema , pensate che quel problema non me lo da' piu'? perche' se me lo continua a dare io non sto a perdere tempo lo lascio come'.

 

Share this post


Link to post
Share on other sites
Livio Orsini
Il 25/3/2020 alle 21:28 , agoman ha scritto:

un anno che funziona, pero' ha un piccolo problemino con la lavatrice il primo led si accende anche col solo motore avviato quando si dovrebbe accendere a 1000w

 

Questo non è problema di TA ma di filtraggio. Questa lavatrice è probabile che abbia il motore ad inverter oppure un motore universale a spazzole con regolazione di velocità tramite dimmer a triac.

In entrambi i casi generano una quantità elevata di disturbi.

Nel circuito originario di MIRKO, come ho già scritto, il segnale del TA è filtrato in modo pesante, proprio per evitare problemi come questo e picchi istantanei di assorbimento.

Se non filtri bene il segnale del TA non risolvi il problema.

Share this post


Link to post
Share on other sites
rfabri
Il 27/3/2020 alle 09:33 , rfabri ha scritto:

questi circuiti sono di Mirko, però mi pare strano che sul TA essendo attraversato dalla corrente di qualsiasi utilizzatore non ci sia nemmeno un filtro di nessun tipo, o fatto qualcosa anch'io del genere però ho dovuto filtrare perchè motori come quello della lavatrice sia a triac che i moderni a inverter mi creavano disturbi, mentre carichi resistivi ok

E giusto quello che dice livio sul filtro pesante  ma i picchi come dicevo sopra secondo me passano, però il controllo della linearita TA è molto importante, ma è enche molto difficile trovare un TA perfetto bisogna accontentarsi di quello che si ha nel cassetto.

Share this post


Link to post
Share on other sites
gabri-z

Se il TA ha una risposta lineare, vuol dire che in quel ambito di assorbimento, il nucleo non si  "satura" 

 

Share this post


Link to post
Share on other sites
Livio Orsini
1 ora fa, gabri-z ha scritto:

Se il TA ha una risposta lineare, vuol dire che in quel ambito di assorbimento, il nucleo non si  "satura"

 

Giustissimo; quando ci si avvicina alla saturazione la risposta comincia ad essere "curva"

Share this post


Link to post
Share on other sites
agoman
7 ore fa, Livio Orsini ha scritto:

il motore ad inverter oppure un motore universale a spazzole con regolazione di velocità tramite dimmer a triac

si a questo metodo di regolazione di velocita'.

allora puo' essere anche un problema di TA?

provero ad acquistare il sirio su ebay si trova non costa caro e poi rifaccio le prove.

ma questo circuito fatto di mirko puo' alimentare il mio circuito? 

ho bisogna utilizzare per forza LM3914 e questo che non capisco.

l'uscita LM324 cosa puo' soportare  

Share this post


Link to post
Share on other sites
Livio Orsini
33 minuti fa, agoman ha scritto:

allora puo' essere anche un problema di TA?

 

Agoman ma non leggi quello che scrivo?

Ti ho scritto: "Questo non è problema di TA ma di filtraggio".

 

Poi c'è il problema di saturazione. Sulle specifiche del TA è indicato il campo di applicazione; se ad esempio c'è scritto 0-5A, signifca che sino a correnti di 5A la misura è abbastanza lineare, oltre non lo è più.

Share this post


Link to post
Share on other sites
agoman
6 ore fa, Livio Orsini ha scritto:

Questo non è problema di TA ma di filtraggio"

quindi questo circuito e la parte del filtraggio giusto?

se cosi' fosse e lo ricrivo per l'ennesima volta dato che nessuno ancora mi risponde a questa domanda,  posso usare questo circuito di alimentazione per il mio circuito fatto?

se si , ci vuole il suo tA? perche' con quello che ho non supero i 3,50 volt a 3000w dove sta' il problema?

la tensione deve essere cosi' bassa?

e poi in uscita lm 324 che corrente ho?

ecco questo e quello che voglio sapere.

grazie per chi mi risponde. 

Nessuna descrizione della foto disponibile.

 

 

Edited by agoman

Share this post


Link to post
Share on other sites
gabri-z
9 minuti fa, agoman ha scritto:

e poi in uscita lm 324 che corrente ho?

La corrente è '' poca '' , ma la tensione dovrebbe essere 1,41 X U  dove U è la tensione alternata ai capi del potenziometro .

Non puoi aumentare il numero di spire sul TA  ?

Oppure mettere una sezione del 324 dopo il potenziometro , come amplificatore passa basso , con taglio sopra i 75 - 80 Hz ?

Abbi un po di pazienza , se non salta fuori da qualche altra parte , cerco di combinarti uno schema .

Edited by gabri-z

Share this post


Link to post
Share on other sites
Livio Orsini
10 ore fa, agoman ha scritto:

perche' con quello che ho non supero i 3,50 volt a 3000w dove sta' il problema?

 

Quanto ti esce dal tuo TA?

Quante spire del filo di potenza hai fatto fare nel toroide?

I primi 2 operazionali costituiscono un raddrizzatore, quasi ideale, a 2 semionde,poi c'è l'elettrolitico di spianamento e filtraggio; il terzo operazionale è solo un inseguitore di tensione che serve a non caricare il raddrizzatore.

Puoi sempre provare a modificarlo in un amplificatore a guadgno 4, ad esempio. basta mettere un 39 kohm dall'ingresso invertente a zero ed una 100kohm come reazione, invece del corto tra ingresso ed uscita (guadagno 3.56).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...