Jump to content
PLC Forum


Protezione campo I/O con parametrizzazione alla voce "Sicurezza"


Riccardo Palmarin
 Share

Recommended Posts

Riccardo Palmarin

Ciao a tutti,

 

ho la necessità di proteggere in scrittura alcuni parametri visualizzati su una pagina del KTP400.

Dopo aver cambiato nome utente e password dell'utente amministratore già inserito di default nel progetto, ho parametrizzato la voce "Sicurezza" segliendo un'autorizzazione che ha solo l'amministratore. Ho caricato il progetto e alla prima prova ho inserito il nome utente e la password riuscendo a modificare il parametro protetto.

 

Tuttavia, dopo un paio di caricamenti aggiuntivi sul display (per aggiungere 2 pagine), ho provato nuovamente la modifica dei parametri protetti. Inserendo la password e il nome utente corretti non sono riuscito a modificare i parametri (sembrebbe che il venga rifiutata la password).

 

Ho provato a modificare username e password nel progetto e a fare un caricamento completo nel display senza risolvere il problema. 


C'è qualcosa che mi sfugge o sono incappato in un bug di TIA v15.1 / KTP400.

Edited by Riccardo Palmarin
Link to comment
Share on other sites

  • Riccardo Palmarin changed the title to Protezione campo I/O con parametrizzazione alla voce "Sicurezza"

 

3 minuti fa, Riccardo Palmarin ha scritto:

o sono incappato in un bug

Non mi risultano ce ne siano sulla gestione degli utenti identica dai tempi del protool.

Hai provato una compilazione completa del progetto prima di trasferirlo?

 

Link to comment
Share on other sites

Riccardo Palmarin

Si, ho provato sia una compilazione completa e il sucessivo caricamento, sia il rispristino del KTP400 senza risolvere il problema.

Link to comment
Share on other sites

Simone.Salarsi

durante il download del progetto nel pannello hai spuntato la casella "sovrascrivi la gestione utenti" ?

Link to comment
Share on other sites

Riccardo Palmarin
5 ore fa, Simone.Salarsi ha scritto:

durante il download del progetto nel pannello hai spuntato la casella "sovrascrivi la gestione utenti" ?

Si. Ho anche fatto un caricamento completo come se fosse il primo caricamento su un pannello nuovo.

Link to comment
Share on other sites

Il 12/7/2021 alle 18:30 , Riccardo Palmarin ha scritto:

Inserendo la password e il nome utente corretti non sono riuscito a modificare i parametri (sembrebbe che il venga rifiutata la password).

Il pannello operatore visualizza un messaggio dove ti dice se l'accesso non è consentito perché la password non è corretta oppure perché non hai un livello sufficiente.
Comunque, io ricontrollerei la gestione utenti. Secondo me, inavvertitamente hai cambiato qualcosa lì.
Prova anche a reimpostare la password, e poi fai il download con la spunta per sovrascrivere la gestione utenti.

Link to comment
Share on other sites

Riccardo Palmarin
13 ore fa, batta ha scritto:

Il pannello operatore visualizza un messaggio dove ti dice se l'accesso non è consentito perché la password non è corretta oppure perché non hai un livello sufficiente.

Non viene visualizzato nessun messaggio. Quando faccio tap su "OK", il campo per inserire le credenziali sparisce (come se fosse tutto ok). Se poi provo ad agire nuovamente sullo stesso elemento ricompare la finestra con il nome utente già compilato. Provando ad inserire la password corretta il ciclo si ripete.
Ho provato a cambiare credenziali e a caricare spuntando "gestione utenti", tuttavia a volte funziona e altre volte non funziona.

Link to comment
Share on other sites

20 minuti fa, Riccardo Palmarin ha scritto:

Non viene visualizzato nessun messaggio.

Quando crei un nuovo progetto ti vengono proposte delle scelte. Di default, viene inserita nella pagina base la finestra "segnalazioni di sistema".
In questa finestra apparirebbe il messaggio informativo. Se non appare il messaggi, significa che hai eliminato la finestra.

 

25 minuti fa, Riccardo Palmarin ha scritto:

Provando ad inserire la password corretta il ciclo si ripete.

Cosa intendi con: "Il ciclo si ripete"?

Link to comment
Share on other sites

Riccardo Palmarin
1 ora fa, batta ha scritto:

Quando crei un nuovo progetto ti vengono proposte delle scelte. Di default, viene inserita nella pagina base la finestra "segnalazioni di sistema".
In questa finestra apparirebbe il messaggio informativo. Se non appare il messaggi, significa che hai eliminato la finestra.

Come posso attivare la visualizzazione automatica delle segnalazioni di sistema senza dove inserire pagina per pagina la vista segnalazioni? Comunque non ho mai modificato impostazioni inerenti a questa funzionalità.
 

 

1 ora fa, batta ha scritto:

Cosa intendi con: "Il ciclo si ripete"?

Intendo che,  anche provando infinite volte le stesse credenziali, non sono in grado di modificare il campo I/O. 

Link to comment
Share on other sites

Simone.Salarsi

come dice @batta dovresti inserire nella pagina "global screen" l'oggetto vista segnalazioni con spuntato solo gli eventi di sistema( di default dovrebbe già esserci però magari sono stati rimossi)

 

image.thumb.png.cad5dd5bda2871b3380c54a1247d9c5a.png

Link to comment
Share on other sites

1 ora fa, Riccardo Palmarin ha scritto:

Intendo che,  anche provando infinite volte le stesse credenziali, non sono in grado di modificare il campo I/O. 

Aggiungi la finestra delle segnalazioni di sistema, come indicato da Simone.
In questo modo, almeno, si ha un'indicazione su ciò che accade.

Link to comment
Share on other sites

Riccardo Palmarin
4 ore fa, batta ha scritto:

Aggiungi la finestra delle segnalazioni di sistema, come indicato da Simone.
In questo modo, almeno, si ha un'indicazione su ciò che accade.

Ho provato senza riuscire a vedere nessuna informazione. Comunque sono riuscito a risolvere il problema. Ho aggiunto una pagina con la vista utenti e ho eliminato dal progetto ogni singolo utente. Poi li ho aggiunti dalla vista utenti e ho risolto il problema.

Link to comment
Share on other sites

Quindi c'era qualcosa di sbagliato nella gestione degli utenti nel progetto.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...