Jump to content
PLC Forum


Twincat3 runtime su Windows 11 freeze


Luca.Lombardi
 Share

Recommended Posts

Luca.Lombardi

Buongiorno a tutti,

sono un neofita della programmazione plc  e per ragioni lavorative dovrò quantomeno avere dei rudimenti sulla programmazione tramite Twincat3.

Oggi ho installato Twincat3 versione 15.0.28010.2050 su un pc HP con Windows11.

L'installazione è andata a buon fine, e sono riuscito a creare un progetto base.

 

Nel prosecuo del mio auto-apprendimento ho cercato di far eseguire un banale incremento di una variabile usando la simulazione in locale.

Dopo varie prove e letture di documentazioni varie ho disabilitato tutte le funzionalità di Hyper-V di windows e settato un core isolato da destinare a Twincat.

La prima volta ha funzionato: l'icona di TwinCAT di stato è passata da blu a verde (segno che era in runtime credo).

Seguendo un video per andare in simulazione e scaricare così il mio progetto nel plc simulato ho cliccato su Active Configuration che ha generato una finestra in cui mi si richiedeva l'inserimento di una licenza temporanea che ho inserito (chiedeva di ricopiare un codice alfanumerico).

 

Dopo quell'operazione, stop. Il computer di blocca totalmente: non va più il mouse, il CTRL+ALT+CANC non risponde e sono costretto a spegnere brutalmente il notebook.

 

Qualcuno ha qualche idea per risolvere il mio problema?

 

Grazie mille

Link to comment
Share on other sites


ciao,

intanto non mi torna la versione di Twincat 3.

L'ultima che trovi sul sito è la 3.1 4024.32

image.png.cd6f8b8e38f0c428ab5632d0f2f3122d.png

quindi non saprei cosa è la versione che citi tu 15.0.28010.2050

image.png.675ca8bba8ff81a1a0d4b6f411bfcedc.png

le operazioni che hai fatto mi sembrano corrette e normalmente sul mio pc funziona

 

fammi sapere la versione

 

un saluto

Valvolina

Link to comment
Share on other sites

Luca.Lombardi

Buongiorno e grazie della precisazione.

Sinceramente aveto aperto l'ambiente di sviluppo e premuto su .... ma a quanto pare è un dato errato.

 

Al percorso che indichi trovo la seguente versione: 3.1 4024.18

 

Ho dimenticato di dre che ho anche provato, vedendo il problema, a deinstallare totalmente e reinstallare da 0, ma nulla da fare...

 

Grazie mille

Link to comment
Share on other sites

ciao

 

aggiorna con la versione 4024.32 e riprova

io ho configurato così:

image.thumb.png.eaf1135c66c25fb8d3f4b347470dbbc8.png

 

con read from targhet (dove il targhet è il tuo pc) leggi quanti core hai disponibili.

Ne isoli uno, io uso solitamente l'ultimo in fondo alla lista, poi clicca su "set on targhet",

se non lo hai già fatto ti chiederà il riavvio del pc.

Fatto questo riprovi, a me funziona.

 

per quanto riguarda le versioni, io ho queste installate

image.png.d134e7e84d32e2af63ff364f8ce9b214.png

la 18 o me la sono persa oppure non l'ho vista

 

il consiglio è aggiorna e riprova

fammi sapere se ok

 

un saluto

Valvolina

 

 

Link to comment
Share on other sites

Buongiorno a tutti,, specialmente a Valvolina.

Ho provato ad aggiornare alla versione 3.1.4024.32 e sembra funzionare correttamente il runtime e il pc nopn si freeza più

 

Farò ancoira qualche test, me credo che il tuo suggerimento abbia risolto il problema

 

Grazie mille

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...