Jump to content
PLC Forum


Collegamento Trasmettitore 4-20 Ma


marioori
 Share

Recommended Posts

ciao a tutti.

devo collegare un trasmettitore 4-20 mA, il SITRANS TH 100 della SIEMENS, ad un plc C7 e ad un S7-300. ma non riesco a capire come fare. avete una dritta?

grazie...

Link to comment
Share on other sites


ho configurato l'ingresso del c7 come 4-20 mA, ed ho provato a collegare il trasmettitore così:

il + del trasmettitore a +24V

il - del trasmettitore al contatto "I" dell'ingresso analogico

il contatto "C", comune, dell'ingresso analogico a massa.

ma la variabile PEW mi rimane sempre a fondo scala minimo.. il collegamento è giusto così?

Link to comment
Share on other sites

per provare il trasmettitore potrei mettere il + del trasmettitore a +24V, il - collegato ad una resistenza da 500 ohm collegata a sua volta a massa, così ai capi della resistenza dovrei misurare la tensione generata dalla corrente che la attraversa.

Link to comment
Share on other sites

Ciao,

il problema sono le polarità invertite: il + e il - del TH100 identificano il verso della corrente di segnale, non le polarità di alimentazione. Dal morsetto + uscirà la corrente di segnale, che quindi deve essere "spinta" dal 24V sul morsetto -.

Il cablaggio corretto è:

+ del sitrans con I dell'ingresso analogico

- del sitrans con il 24V

C dell'ingresso analogico a massa

vedrai che così funziona.

MASSIMA ATTENZIONE: in questo modo il sensore non è protetto! In caso di corto-circuiti potrebbe danneggiarsi il sensore. Conviene predisporre un fusibile sul circuito di misura che protegga sensore e C7.

buon lavoro!

Link to comment
Share on other sites

Il cablaggio corretto è:

+ del sitrans con I dell'ingresso analogico

- del sitrans con il 24V

C dell'ingresso analogico a massa

ASSOLUTAMENTE NO!

Il trasmettitore in questione (dare qualche informazione in più, senza far perdere tempo a chi vuol dare una risposta per andare a cercare di cosa si tratta non sarebbe stata una cattiva idea) è un convertitore da PT100 a 4-20mA.

Dal lato 4-20mA è un trasduttore a due fili che, detto in modo barbaro, utilizza la corrente fino a 4mA per autoalimentarsi.

I segni + e - determinano il verso (convenzionale) della corrente. Il collegamento corretto quindi è quello del post #2.

I motivi del mancato funzionamento vanno ricercati da un'altra parte.

Per esempio, siamo sicuri che la PT100 sia integra e collegata in modo corretto?

Un segnale fisso al valore minimo mi induce a pensare proprio ad un collegamento errato della PT100, magari con il terzo filo collegato al posto sbagliato.

Normalmente le PT100 classiche a 3 fili (sempre che di questo stiamo parlando, dato che l'amico marioori non si è certo dilungato in spiegazioni) presentano due fili rossi ed uno bianco.

I due fili rossi vanno collegati sui morsetti 3 e 4, e quello bianco sul 6.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...