Jump to content
PLC Forum


Sign in to follow this  
steveh86

Tsx Premium + Pannello Operatore Magelis Xbtgt 4230

Recommended Posts

steveh86

Salve, sto cercando di risolvere il problema seguente (prima volta a che fare con il PLC, totale inesperienza):

Disponiamo di un PLC TSX Premium (TSX P57103 + vari moduli di I/O) il quale ha come interfacce due porte: TER e AUX. Alla AUX è attaccato un pannello operatore (Magelis XBTF032110 con una porta a 25 pin, cavo XBTZ968) che stabilisce alcuni set-point al PLC. Alla porta TER era attaccato con un cavo TSXPCU1030 (seriale 9 pin) un PC che registrava tramite il programma Vijeo Look alcune grandezze sul proprio disco rigido (tramite OPC server)

Dopo molti anni, irreperibile il programmatore, il PC si è guastato, abbiamo deciso di installare un pannello che facesse il lavoro al posto del defunto. Il prescelto (a torto?) è un Magelis XBTGT4230.

Ho costruito l'interfaccia con Vijeo Designer, stabilito le variabili da prelevare dalla memoria del PLC (verificate dal programma con PL7 v4.2), aggiunto al programma in Vijeo il protocollo di comunicazione e qui sorge il problema: non so quali parametri devo configurare!

Disponendo della configurazione sia del pannellino presente sia del PLC ho settato alcune configurazioni, ma sono incerto su alcuni parametri.

1) può andare bene il cavo TSXPCU1030 per stabilire una comunicazione seriale?

2) Bisognerà modificare la configurazione del PLC e aggiungere qualcosa perché il pannello si colleghi?

Grazie, qualsiasi risposta è bene accetta, mi scuso se qualche domanda sia mal posta.

Share this post


Link to post
Share on other sites

magnete

Di solito si utilizza il ModBus e va configurato sia nel PLC che nella testiera allo stesso modo, Es: br 38400, bit 8, stop 1, parita n.

Per il cavo di connessione bisogna guardare le istruzioni sul manuale, il cavo TSXPCU1030 se ben ricordo è il convertitore 232/485 che si usava per la programmazione.

Se puoi leggere il settaggio attuale della porta ter sul PLC puoi copiarla tale quale sul pannello.La tastiera è Master, quidi una volta configurata e collegata se non ci sono errori sulle richieste il PLC le risponde in automatico.

Share this post


Link to post
Share on other sites
RDA

Il protocollo da utilizzare e unitalway, e lo stesso protocollo da settato sul HMI, settaggio porta su HMi com1 rs485 velocita 19200 bit di parita dispari bit di stop 1 indirizzo base 4, e vedi che funziona.

Saluti.

Share this post


Link to post
Share on other sites
steveh86

Intanto grazie mille per le risposte!

Sul programma del PLC (visualizzazione configurazione TSX57103 su PL7) vedo:

_ Canale 0 (porta terminale)

_ Connessione Uni-telway --- MAST

_ Tipo Master

_ Velocità di trasmissione 19200

_ Numero di slave 8 (dati evento 0 byte)

_ Dati 8 bit - 1 di stop - Parità dispari

Non trovo l'indirizzo base del server però.

Su Vijeo Designer ho impostato:

_ driver Unitelway: COM1, RS485, parità dispari, bit di stop 1, 19200, timeout 6 secondi, indirizzo base 4, n° indirizzi consecutivi 3 (va bene così?).

Codifica? ASCII-UNICODE, ANSI?

_ Apparecchiatura Unitelway sottesa: 0,254,0, selettore 0, Pt.connessione/modulo 254, rif.canale 0, lunghezza frame massima (o lascio il default 120?)

_ Devo configurare anche una tabella di dialogo? Per ora è vuota.

Compilo, scarico, collego il cavo seriale dal PLC all'HMI.

Sullo schermo esce "Le variabili vengono collegate al volume di memoria attualmente non disponibile o pieno." E poi "Nessuna risposta del PLC (Apparecchiatura Unitelway01)".

Sono riuscito a ricollegare il PLC al computer (con i dati di default e gentilmente confermati da RDA) e a leggere i dati del PLC, ma mi permette di scaricare solo e word di memoria, non i dari REAL etc)

Share this post


Link to post
Share on other sites
RDA

In ordine i problemi sono 2 :

volume di memoria e riferito alla memoria dell' HMI forse non configurata bene;

nessuna apparecchiatura collegata non si stabilisce il collegamento tra p,lc e terminale.

Quando colleghi il terminale, per sicurezza scollega il pcl da pc, sulle ultime versioni di Vigoe si presenta questo problema legato al Driver Unitelway.

Sul Plc i parametri di configurazione delle porte fai restare quelli di default.

Se il collegamento si stabilisce ti accorgi dalla maggior intensità della spia ter sulla cpu con lampeggio piu' veloce, ovviamente connessa sulla porta giusta sull HMI.

Saluti.

Share this post


Link to post
Share on other sites
steveh86

Grazie a tutti per le risposte: ho comprato in aggiunta il cavo appropriato costruito apposta per il collegamento al PLC del terminale XBTGT. Spero che fosse quello il problema. Il fatto che sia una modifica ad un quadro fatto da qualcun altro ha complicato le cose, ma sono fiducioso.

Grazie e buon lavoro!

Share this post


Link to post
Share on other sites
steveh86

Riesumo la discussione per confermare che con il cavo (XBT9780, un semplicissimo cavo dritto da porta TER alla porta COM2 del Magelis con ingresso RS485 con connettore RJ45) e i settaggi suggeriti da RDA ma su COM2. I dati affluiscono regolarmente e li posso visualizzare con il trend cronologico in una pagina a parte.

Grazie a tutti!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...