Jump to content
PLC Forum


Sign in to follow this  
agoman

programmatore pic 16F84A

Recommended Posts

agoman

ok dai provo a cambiare il pic, lo compro nuovo ascolta io mi ritrovo il pic16f84a-20p

io in linea ho trovato questo con la parte finale diversa non so a cosa e riferita va bene ugualmente al massimo ne compro 2 , ho visto che altri costano di piu' che cambia?

http://www.ebay.it/itm/Microcontrollore-8-Bit-PIC16F84A-04-P-Enhanced-Version/252722906791?_trksid=p2045573.c100033.m2042&_trkparms=aid%3D111001%26algo%3DREC.SEED%26ao%3D1%26asc%3D20140423084956%26meid%3Db88f09afd49d4166acc39db905fbbcf7%26pid%3D100033%26rk%3D3%26rkt%3D8%26sd%3D201780723729

Share this post


Link to post
Share on other sites

dott.cicala

il 16f84a-20 supporta il clock fino a 20MHz invece il -4 solo fino a 4MHz

 

...dipende da che quarzo hai montato. Un -20 funziona a 4MHz, un -4 non va oltre i 4MHz

Share this post


Link to post
Share on other sites
attiliovolpe

Su sito microchip fai richiesta sample e in dieci giorni hai a casa i pic

Share this post


Link to post
Share on other sites
agoman

ciao attilio su ebay dicono che dovrei averli tra il 2 febraio e max 8 quindi mi va bene non ho a aspettare tanto.

e speriamo che riesco a saltarci fuori.

grazie comunque della dritta.

Share this post


Link to post
Share on other sites
attiliovolpe

Hai postato il link dello schema, perché non posti il firmware da caricare?

 

Share this post


Link to post
Share on other sites
attiliovolpe

Grazie, intanto vedo che hai ricevuto i PIC

Share this post


Link to post
Share on other sites
agoman

si e arrivato subito ora spero solo alla riuscita del programma vedremo sabato buonanotte.

 

Share this post


Link to post
Share on other sites
agoman

niente non funziona nulla chi vuole il programmatore e i pic li regalo ho caccio tutto nell'immondizia ,compro un timer programmabile  gia' fatto faccio prima.

secondo me il programma hex a qualche problema e se non ricordo male allora mi sa che mi avevano fatto cambiare qualcosa perche' mi dava errore 0000h 

 

 

Share this post


Link to post
Share on other sites
dnmeza

prima di buttare attendi, la speranza è l'ultima a morire :superlol::whistling:

Share this post


Link to post
Share on other sites
agoman

ecco questa era la discussione 

ho letto che il vpp deve essere con tensione piu' elevata? io mi ritrovo 5 volt.  e poi se non erro qualcuno aveva cambiato qualcosa al programma originale poi e andato tutto a buon fine qualcuno potrebbe vedere se effettivamente i file del programma funzionano?

a costo che spedisco tutto il kit con i pic per fare una prova spero non sia il programmatore che ha dei problemi.

 

no danilo non butto niente e stato un momento di rabbia.

 

poi ultima domanda ma il tasto sul programmatore a che serve?

e poi per alimentare il pic devo dare la 5 volt giusto?

perche' non mi e stato detto.

 

 

 

 

Share this post


Link to post
Share on other sites
agoman

e qui ce l'altra discussione dove giro mi dice che ce un errore nel file 

 

 

Share this post


Link to post
Share on other sites
Nikiki

Il file hex non può essere responsabile del fallimento della scrittura... Potrebbe non funzionare una volta programmato il PIC,  ma la programmazione dovrebbe andare a buon fine. 

 

Se usi il Pickit3 con lo zoccolo zif è necessario impostare il pickit3 per fornire alimentazione al pic, per default non è così perché il pickit3 nasce per fare programmazione e  debug direttamente sul circuito target (che dovrebbe essere alimentato)

 

Per il resto se vuoi una mano "aiutaci ad aiutarti", dicci che errore ti dà, posta una foto della schermata, o qualcosa del genere... 

Share this post


Link to post
Share on other sites
agoman

questo e quello che dice 260yjo3.jpg

 

uso una basetta breadboard per i collegamenti non i porta pic il pic e un pic16lf84a-04p.

Share this post


Link to post
Share on other sites
Darlington

Ago non prenderla a male ma scrivi in una maniera che fa cascare i cosiddetti a chi legge, magari se usassi un pò di punteggiatura sarebbe una buona idea, poi sarei curioso di sapere perché metti la H dove non ci va ed invece sistematicamente NON la metti dove invece ci va.

 

Tante volte io vorrei risponderti ma mi passa la voglia leggendo.

 

Detto questo: se un pic non viene programmato o letto la colpa spesso è dei collegamenti, hai verificato che effettivamente arrivino i 12-13V sul pin MCLR durante la lettura o la scrittura?

 

Un altro errore comune è invertire per sbaglio i pin CLOCK e DATA, a me è capitato un paio di volte e ho bestemmiato tanto.

 

Poi, avevo letto che il pickit2 aveva dei problemi nel gestire i vecchi 16F84, infatti come soluzione molti dicono di modificare un file nella cartella di installazione del programma, ok che tu stai usando un pickit3 ma nel dubbio controlla.

 

Sono col tablet ed è scomodissimo linkare, ma se cerchi il sito del pickit clone di Tomasella, parlano proprio di quel problema, e ricordo anche che c'è il file da sostituire.

Share this post


Link to post
Share on other sites
agoman

allora darlington ho provato a vedere se su mclr ci stava tensione durante la lettura non supera i 5 volt la tensione varia da 2 a 4,7 volt circa misura fatta tra negativo e pin 4.

Poi a destra del programma vedo scritto targhet power, li devo mettere ok su on e mclr?

io per ora o ok solo su on 5 volt alimentazione pic come da foto.

poi pin cloc e data sono corretti  uscita 4 del programmatore va sul pin 13 e uscita 5 va sul pin 12.

poi ultima cosa il pulsante del programmatore a che serve?

grazie per l'aiuto.

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Darlington
Quote

Poi a destra del programma vedo scritto targhet power, li devo mettere ok su on e mclr?

 

 

Non conosco il pickit perché uso un altro programmatore, ma vedendo la finestra del programma direi che li devi abilitare entrambi... se non hai tensione su MCLR allora ecco il perché i pic non ti si programmano, :)

 

Prova ad abilitare sia Target Power che MCLR e poi riprova.

 

Quote

poi ultima cosa il pulsante del programmatore a che serve?

 

 

Il programmatore ha una sua memoria interna, tu in teoria potresti caricare il firmware sul programmatore, staccarlo dal pc, collegare il programmatore al circuito, alimentare esternamente il programmatore con un alimentatore USB tipo cellulare, e caricare il firmware sul pic senza avere per forza il pc con te.

 

Il pulsante a quanto ne so serve a quello, è comodo se devi aggiornare un dispositivo montato in posizione poco accessibile oppure se devi fare una piccola produzione in serie: prevedi un connettore ICSP, prepari tutte le schede, e come ultima cosa le flashi tutte in batteria.

Share this post


Link to post
Share on other sites
agoman

ho abilitato tutte e due i riquadri ma nulla :toobad:. ho paura che ci mollo.

mi conviene cercare qualcuno che mi programma sti pic forse faccio prima.

 

 

 

Share this post


Link to post
Share on other sites
gabri-z
Quote

 ho paura che ci mollo.

Stai buono , non è da te . Prendi uno due giorni di pausa e ritorna ; funziona sempre .:thumb_yello: 

Share this post


Link to post
Share on other sites
dott.cicala

Al momento purtroppo non posso aiutarti perché sono moolto lontano da casa....ci vorrà qualche settimana prima che torni  

Share this post


Link to post
Share on other sites
gabri-z
Quote

 sono moolto lontano da casa...

Sei ancora in Alaska ? :P

Share this post


Link to post
Share on other sites
agoman

ok gabri mi fermo un attimo magari riprovo a fine settimana.

Stefano vai tra, aspettero', se riesco bene, se non riesco ti spedisco i pic e mi butti il programma dentro, poi se vuoi ti mando anche il programmatore e te lo regalo dato che non e' cosa mia usare sti aggeggi  ahhahahaha,:roflmao: e il minimo che posso fare.

 

 

 

Share this post


Link to post
Share on other sites
Darlington

Dopo aver abilitato la casella relativa hai controllato che poi effettivamente arrivino i 13V su MCLR?

 

Controllato il pinout del programmatore, di non aver iniziato a collegare i pin partendo dal 6 scambiandolo per l'1?

Share this post


Link to post
Share on other sites
agoman

prova fatta  mclr non supera i 5 volt ,io ho misurato tra pin 4 e pin 14 del pic giusto?

i collegamenti sono corretti il pin uno del programmatore e dove ci sta il triangolino e po la piattina a i cavetti colorati non poi sbagliare il pic e un PIC16LF84A-04P.

:(.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...