Jump to content
PLC Forum


Mauro Dalseno

Pickit 3 e MPLAB IDE

Recommended Posts

Mauro Dalseno

Ho un piccolo problema da risolvere per chi ha pratica:

Ho ricevuto un file .hex da installare sopra ad un Pic 16F886 che ho appena acquistato, per fare questa operazione ho disponibile il PICKit 3 e ho installato MPLAB IDE v.8.86, il problema è che non riesco a capire come trasferirlo sul processore.

Ho fatto la procedura per impostare il PIC Giusto, la procedura per alimentarlo a 5V, lui si accende regolarmente ma il programma non riesco a trasferirlo... Ho trovato un tutorial ma è fatto con vecchie versioni che sono diverse, oppure trovo qualcosa in inglese che non mastico. Qualche buon anima non mi spiegherebbe passo per passo come fare a importarlo regolarmente e trasferirlo?

Grazie a chi mi risponderà

Share this post


Link to post
Share on other sites

Lcucinelli

buonasera , io uso il pickit3 come programma, uso la funzione import exe , penso che dovrebbe essere molto simile.

Share this post


Link to post
Share on other sites
dott.cicala

File>Importa

selezioni il tuo file HEX,

vedrai la conferma dell'importazione nella finestra OUTPUT>Build

Vai su Programmer e premi Program

Share this post


Link to post
Share on other sites
Mauro Dalseno
21 ore fa, dott.cicala scrisse:

File>Importa

selezioni il tuo file HEX,

vedrai la conferma dell'importazione nella finestra OUTPUT>Build

Vai su Programmer e premi Program

Stefano è un po scarna la tua risposta io ci provo....

altrimenti proverò a scaricare il programma consigliato da Cucinelli, ieri sera l'ho cercato, ma ero troppo cotto e non ho trovato nemmeno dove si scarica sul sito Microchip

 

Grazie a tutti e due, vi saprò dire

Share this post


Link to post
Share on other sites
Mauro Dalseno

GRANDE 😀

sono a debito di un caffè!!!!

Share this post


Link to post
Share on other sites
gabri-z

Si vede che non occorreva un messaggio da dieci pagine :smile: Corto , secco , preciso.:thumb_yello:

Share this post


Link to post
Share on other sites
Mauro Dalseno

il problema è che utilizzavo un file .hex per un Pic diverso, infatti già facevo la procedura corretta utilizzando le apposite iconcine del programma, ma non ero sicuro di procedere nel modo corretto... Quando ho fatto la procedura di Stefano ottenendo lo stesso risultato ho capito che l'errore era altro, infatti ho provato su un Pic diverso e magicamente funzionava...

22 ore fa, gabri-z scrisse:

Si vede che non occorreva un messaggio da dieci pagine :smile: Corto , secco , preciso.:thumb_yello:

effettivamente è corto e a prova di ignorante :wallbash:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...