Jump to content
PLC Forum


REDCAT2

Generatore UNAOHM EP115 - Aggiunta Marker

Recommended Posts

REDCAT2

Scusate, volevo aggiungere che entrando sull'altro ingresso (G2) il comportamento in uscita è identico a quello entrando sull'ingresso G1.

Link to post
Share on other sites

dott.cicala

A parte il livello, il circuito funge o no?

Per il livello, è normale, metti vari condensatori in parallelo altrimenti la xc ti fa quello scherzo.

 

Link to post
Share on other sites
gabri-z

Che siano pochi 100 uH ? Oppure 1nF ?

 

Ancora in ritardo ...:smile:

Ma era giusto aumentare i condensatori , vero ?

Edited by gabri-z
Link to post
Share on other sites
REDCAT2
43 minuti fa, dott.cicala ha scritto:

A parte il livello, il circuito funge o no?

Per il livello, è normale, metti vari condensatori in parallelo altrimenti la xc ti fa quello scherzo.

 

Non lo sò ancora, domani lo provo con l' EP115 in modalità sweep e con un secondo generatore che svolge la funzione di marcatore.

Non ho capito dove mettere questi condensatori, forse in parallelo a quelli da 1000 pF ? E quanti e di che valore ?

Poi non ho capito come fa ad esserci un segnale in uscita maggiore di quello in ingresso intorno ai 700 kHz.

Link to post
Share on other sites
REDCAT2
Posted (edited)

OK, non ci avevo pensato. Grazie gabri-z.

 

 

Edited by REDCAT2
Link to post
Share on other sites
gabri-z

Aspetta la conferma dal dott'' , io ci credo , ma non vuol dire che sia giusta l'interpretazione.

Link to post
Share on other sites
dott.cicala

Primamente, bisognerebbe vedere la realizzazione.

Secondamente, potrebbe essere una risonanza. 100uH risuonano a 700kHz con 500pF in parallelo.

 

I diodi hanno una bassissima capacità quindi la risonanza può avvenire quando su una o più porte si collega qualcosa che abbia capacità parassita elevata.

 

L1 (C1 || parassita di G1)

L2 (C3 || parassita di G2)

L3 (C6 || parassita di G3)

 

Prova ad aumentare L1-2-3 a 10mH - C4-C5 a 470nF

 

Per la questione del livello dovresti provare a mettere in parallelo a C1-C3-C6  due condensatori per ciascuno da 100pF - 10nF.

 

Servono a compensare la variazione di reattanza degli attuali C1-C3-C6 al variare della frequenza

 

 

 

 

Link to post
Share on other sites
gabri-z
4 ore fa, dott.cicala ha scritto:

100uH risuonano a 700kHz con 500pF in parallelo.

Non avevo fatto conti , ma non ci arrivo a vedere un altro motivo per una tensione maggiore di quella d'ingresso ....difficoltà di...istruzione..:(

Link to post
Share on other sites
dott.cicala
29 minuti fa, gabri-z ha scritto:

Non avevo fatto conti , ma non ci arrivo a vedere un altro motivo per una tensione maggiore di quella d'ingresso ....difficoltà di...istruzione..:(

Non ci sono altre ragioni fatta eccezione per gli errori grossolani o sistematici nelle misure

Link to post
Share on other sites
gabri-z
29 minuti fa, dott.cicala ha scritto:

Non ci sono altre ragioni fatta eccezione per gli errori grossolani o sistematici nelle misure

Grazie , ma così hai tolto il lavoro degli ultimi miei due neuroni , dovevi lasciarli cercare ...e cercare....:thumb_yello:

Link to post
Share on other sites
REDCAT2

Eccoci con le prove effettuate con il generatore EP115 in modalità sweep, un secondo generatore come marker, una radio AM come apparato sotto prova, il circuito multiplexer e un'oscilloscopio LEADER da 10 MHz di banda passante.

Allego tre foto, nella prima foto la curva di risposta dello stadio di media frequenza della radio con il generatore EP115 connesso all'ingresso della radio e l'uscita del rivelatore della radio connessa all'ingresso verticale dell'oscilloscopio, l'uscita "Horizontal" del generatore EP115 collegata con l'ingresso orizzontale dell'oscilloscopio; la curva è abbastanza nella normalità.

Nella seconda foto lo schermo dell'oscilloscopio presenta una curva di risposta attenuata e la presenza di impulsi probabilmente dovuti alla frequenza di commutazione generata dal 4093B, il setup è uguale al precedente inserendo il multiplexer tra l'uscita del generatore EP115 e l'ingresso della radio ma senza inserire il segnale del generatore marker.

La terza foto è con il segnale marker inserito nel multiplexer: in pratica appare una forma d'onda su tutta la larghezza dello schermo parallela alla linea di riferimento orizzontale.

Riassumendo non ho ottenuto il "pip" sulla curva di risposta (foto 1), inoltre nell'altoparlante della radio, con alimentato il multiplexer (tramite una pila da 9V), si sente il ronzio alla frequenza di commutazione del 4093B.

IMG_20200719_210137.thumb.jpg.ed6ceea133ea8e51c425113002b95bde.jpgIMG_20200719_210529.thumb.jpg.574074fd60950b40a0f419ec97d431e9.jpgIMG_20200719_210618.thumb.jpg.1d2749e3f432e9952b2956641d9d0179.jpg

 

 

 

 

Link to post
Share on other sites
REDCAT2

Mi sa che devo rinunciare a inserire il marker sulla radio frequenza, forse è meglio tentare con un circuito che fornisca un impulso per esempio all'asse Z dell'oscilloscopio in modo da creare un piccolo segmento privo di luminosità (o con luminosità accentuata) sulla traccia della curva di risposta in corrispondenza con la frequenza del marker. Il problema è sincronizzare l'impulso con tutto il resto.

Link to post
Share on other sites
dott.cicala

Non disperare. 

Non ho capito se l'oscilloscopio è in modalità xy oppure ext-trig: C'è una sostanziale differenza perché nel primo caso a pilotare l'orizzontale è un dente di sega, nel secondo un'impulso.

 

Se fosse un impulso, ( oscilloscopio in ext-trig) si potrebbe usare quello per pilotare il multiplexer, previa modifica al mux.

 

Considera che se non inietti il marker la relativa porta deve essere chiusa, altrimenti entra il rumore, in secondo luogo l'attenuazione ci sarà sempre.

In ultimo, sembra che il circuito funzioni, devi solo trovare la frequenza di commutazione appropriata e per questo devi giocare con i valori di R1-C2.

Dalle immagini è chiaro che è troppo bassa. Prova a diminuire drasticamente C1 a 100nF e al posto di R1 un potenziometro da 10k.

 

In sostanza per avere il pip il tempo in cui è aperta la porta dove applichi il marker deve essere molto minore di quella del segnale in esame. 

Fammi vedere cosa succede iniettando solo il marker.

 

Quella riga orizzontale sopra la curva cos'è?

Edited by dott.cicala
Link to post
Share on other sites
REDCAT2

Grazie dott.cicala, tengo duro.

L'oscilloscopio non è su X-Y e non è su Trigger esterno, ma è commutato su ingresso amplificatore orizzontale (cioè l'ingresso dell'amplificatore orizzontale è commutato su esterno invece che sulla base tempi interna all'oscilloscopio). Probabilmente è più o meno la stessa cosa di usare la posizione X-Y.

Per porta chiusa intendi con corto circuito o con "tappo" da 50 ohm ?

 

Appena posso provo a ridurre i valori di R1 e C2 (potenziometro da 10K e condensatore da 100K).

Però stavo pensando non sarebbe il caso di ridurre anche il duty cycle in modo da aprire la porta del marker per esempio del 5% rispetto al tempo in cui sta aperta la porta del generatore vobulato ?

 

La riga orizzontale è presente quando il selettore sul retro del generatore EP115 è su "BLANKING ON", se tale selettore è su OFF si vedono sullo schermo dell'oscilloscopio due curve di risposta che vanno sovrapposte regolando il comando "Horiz. Phase" posto sempre sul retro del generatore EP115.

 

Se confronti la foto 2 con la 3 vedi circa un centimetro sotto la mezzeria dello schermo una specie di forma d'onda che copre tutta la larghezza orizzontale, quella è dovuta all'inserimento del generatore marker con frequenza uguale a quella centrale del generatore vobulato. 

 

Link to post
Share on other sites
REDCAT2

Ecco due foto, una con il solo generatore marker collegato e la porta dell'altro generatore caricata con "tappo" da 50 ohm, nei "rettangoli" che si vedono nello schermo dell'oscilloscopio c'è un'onda sinusoidale con la frequenza del generatore marker, mentre la traccia è piatta quando la porta del marker è chiusa elettronicamente dal circuito con il 4093B.

L'altra foto è utilizzando l'oscilloscopio in modalità X-Y, senza il multiplexer, in pratica si vede solo metà curva di risposta (la parte a destra). 

IMG_20200720_193301.jpg

IMG_20200720_193731.jpg

Link to post
Share on other sites
dott.cicala
48 minuti fa, REDCAT2 ha scritto:

L'oscilloscopio non è su X-Y e non è su Trigger esterno, ma è commutato su ingresso amplificatore orizzontale

Quindi c'è un dente di sega a pilotare l'orizzontale?

 

49 minuti fa, REDCAT2 ha scritto:

Però stavo pensando non sarebbe il caso di ridurre anche il duty cycle in modo da aprire la porta del marker per esempio del 5% rispetto al tempo in cui sta aperta la porta del generatore vobulato ?

Sì, per forza

 

49 minuti fa, REDCAT2 ha scritto:

La riga orizzontale è presente quando il selettore sul retro del generatore EP115 è su "BLANKING ON"

Sono le solite cagate della unaohm.  Il blanking non si fa così e questa riga romperà le balle di brutto, al punto che il mux non darà mai buoni risultati.

 

 

Link to post
Share on other sites
REDCAT2

Come mai questo "amore" per la unaohm ...?

Ma se tengo il Blanking su OFF, la riga non c'è.

 

1 ora fa, dott.cicala ha scritto:

Quindi c'è un dente di sega a pilotare l'orizzontale?

No, guardando l'uscita dell' EP115 con l'oscilloscopio risulta essere una sinusoide.

Link to post
Share on other sites
REDCAT2
Posted (edited)

Come faccio a ridurre il duty cycle per aprire la porta del marker molto meno di quella del generatore vobulato ?

Forse con un NE555 la cui uscita tramite una resistenza da 1K pilota una porta, mentre sempre la stessa uscita passata in un inverter (tipo 40106) piloterebbe l'altra porta sempre tramite una resistenza da 1K ?  

Edited by REDCAT2
Link to post
Share on other sites
dott.cicala
1 ora fa, REDCAT2 ha scritto:

 una sinusoide.

e questo genera la ritraccia

1 ora fa, REDCAT2 ha scritto:

Ma se tengo il Blanking su OFF, la riga non c'è.

e hai l'immagine doppia?

 

image.png.62cd2095ed25f152801a8014069a36d6.png

il marker in questo circuito va su G2

Edited by dott.cicala
Link to post
Share on other sites
REDCAT2

Grazie mille per il nuovo schema !

19 minuti fa, dott.cicala ha scritto:

e questo genera la ritraccia

e hai l'immagine doppia?

 

image.png.62cd2095ed25f152801a8014069a36d6.png

il marker in questo circuito va su G2

 

Ho l'immagine doppia se non agisco sul regolatore "Horizontal Phase" sul generatore EP115 per sovrapporre le due immagini in modo che se ne veda una sola.

 

Avrò bisogno qualche giorno per recuperare le impedenze da 10 mH, condensatori e resistenze li ho.

 

 

 

 

 

 

 

Link to post
Share on other sites
dott.cicala
12 ore fa, REDCAT2 ha scritto:

Ho l'immagine doppia se non agisco sul regolatore "Horizontal Phase" sul generatore EP115 per sovrapporre le due immagini in modo che se ne veda una sola.

Il tutto per non fare un generatore di dente di sega e usare così un segnale sinusoidale recuperato dalla rete.

Per questo ho detto:

16 ore fa, dott.cicala ha scritto:

Sono le solite cagate della unaohm

 

Link to post
Share on other sites
REDCAT2
Posted (edited)
5 ore fa, dott.cicala ha scritto:

Il tutto per non fare un generatore di dente di sega e usare così un segnale sinusoidale recuperato d

 

Pensi che si potrebbe migliorarlo eliminando il segnale sinusoidale preso dalla rete e aggiungendo un generatore di dente di sega adatto a pilotare l'orizzontale dell'oscilloscopio e il circuito del vobulatore ?

Poi con il generatore di dente di sega il marker si può inserire come impulso che potrebbe pilotare l'asse Z dell'oscilloscopio ?

 

Ho sbagliato a settare il sistema nella prova con l'oscilloscopio in modalità X-Y, in realtà con il giusto setting la forma d'onda si vede totalmente come con l'oscilloscopio su ingresso amplificatore orizzontale su esterno.

Edited by REDCAT2
Link to post
Share on other sites
dott.cicala
36 minuti fa, REDCAT2 ha scritto:

Pensi che si potrebbe migliorarlo eliminando il segnale sinusoidale preso dalla rete e aggiungendo un generatore di dente di sega adatto a pilotare l'orizzontale dell'oscilloscopio e il circuito del vobulatore ?

Teoricamente sì, in pratica non sarà semplicissimo perché hanno sicuramente usato quel segnale anche per sweppare l'oscillatore

Link to post
Share on other sites
REDCAT2

Capisco che sia abbastanza complicato, per il momento mi concentro sul multiplexer.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...