Jump to content
PLC Forum


Motori master-slave e overtension


Lombard
 Share

Recommended Posts

Lombard

Ciao a tutti, qualche tempo fa vi avevo chiesto aiuto circa il funzionamento di due fotocellule per un gruppo taglio su di una tubiera per la produzione di tubi di cartoncino spiralati. 

Adesso il problema che vorrei affrontare riguarda i due motori che sono montati sulle due pulegge per far movimentare la cinghia (che a sua volta trascinerà le strisce per poi formare il tubo).

Ho due motori 100hz da 2/3kw, ora non ricordo con precisione, e due inverter. Tutto passa nel plc. Io da pannello operatore posso impostare la velocità del master e lo slave gli va dietro. L' unica regolazione ulteriore riguarda la velocità dello slave: posso incrementarla o diminuirla. 

Il problema è che lo slave salta a caso, un giorno funziona e un giorno salta ogni 10 minuti. Va in overtension e, da quanto ho capito, succede perché viene trascinato dal master. È comunque capitato che saltasse il master anziché lo slave. 

Adesso vi chiedo: è un problema risolvibile con poco e in maniera autonoma? Perché il plc è un Wekon e non ho tecnici in zona disponibili, avevo quasi quasi pensato di sventrare la macchina e farle tutta l' elettronica nuova adoperando materiale più comune.

Vi ringrazio anticipatamente!!

 

 

Link to comment
Share on other sites


4 ore fa, Lombard ha scritto:

Perché il plc è un Wekon e non ho tecnici in zona disponibili, avevo quasi quasi pensato di sventrare la macchina e farle tutta l' elettronica nuova adoperando materiale più comune.

Con tutti i chiari limiti di un "consulto" telematico, personalmente non penso probabile che il problema sia da ricondurre all'obsolescenza dell'elettronica ed in particolare al PLC.

 

4 ore fa, Lombard ha scritto:

Va in overtension e, da quanto ho capito, succede perché viene trascinato dal master

Sarebbe importante capire in quali condizioni di esercizio avete osservato l'inverter dello slave andare in fault per overvoltage.

Secondo me è più probabile che accada quando lo slave è più veloce del master, in questa condizione infatti lo slave viene indotto a decelerare e c'è il rischio che l'eccesso di energia non venga dissipato correttamente e quindi torni sui condensatori del DC-bus facendogli appunto superare la soglia d'allarme di sovratensione.

Di che inverter si tratta? Sono dotati di frenatura dissipativa (resistenza di frenatura) o di altro tipo di frenatura (rigenerativa, iniezione di continua, ecc.)?

 

Ciao

mc1988

 

Edited by mc1988
Link to comment
Share on other sites

Lombard
Posted (edited)
53 minuti fa, mc1988 ha scritto:

Con tutti i chiari limiti di un "consulto" telematico, personalmente non penso probabile che il problema sia da ricondurre all'obsolescenza dell'elettronica ed in particolare al PLC.

 

Sarebbe importante capire in quali condizioni di esercizio avete osservato l'inverter dello slave andare in fault per overvoltage.

Secondo me è più probabile che accada quando lo slave è più veloce del master, in questa condizione infatti lo slave viene indotto a decelerare e c'è il rischio che l'eccesso di energia non venga dissipato correttamente e quindi torni sui condensatori del DC-bus facendogli appunto superare la soglia d'allarme di sovratensione.

Di che inverter si tratta? Sono dotati di frenatura dissipativa (resistenza di frenatura) o di altro tipo di frenatura (rigenerativa, iniezione di continua, ecc.)?

 

Ciao

mc1988

 

Non intendevo dare la colpa all' elettronica attualmente in uso, è che ci siamo, o meglio, vogliamo sganciarci da chi ci ha fornito il macchinario perché evidentemente non sono seri e nemmeno capaci, ma in zona non sappiamo a chi rivolgerci perché lavorano tutti con altri marchi di plc. Per intenderci, il macchinario ci è stato consegnato con i motori collegati male. Uno è saltato direttamente ed è stato rigenerato, l' altro sta funzionando ancora (anche se fa più rumore rispetto a quello rigenerato).

 

Gli inverter sono LS s100 accoppiati ai motori sincroni Tramec da 2.2 kw, 4 poli, 3000 rpm. 

Il problema si presenta quasi sempre sulle decelerazioni, ma si presenta molto spesso anche quando la macchina gira a velocità costante. Salta soprattutto lo slave, ma succede che salti anche il master. Capita anche molto spesso che uno dei due motori scaldi parecchio, a volte il Master, altre volte lo slave. 

Adesso abbiamo provato ad invertire i due motori, posizionando il vecchio master (rigenerato) come slave e il vecchio slave (quello che è sopravvissuto) come master, ma il problema, seppur in maniera meno marcata, è rimasto. Adesso il problema si presenta soprattutto nelle decelerazioni, ma a volte anche a velocità costante. 

 

Tengo a specificare che non ho nozioni circa plc ed elettronica varia, mi sono informato molto l' estate scorsa su questi componenti perché avevo un problema sulla gestione del taglio con fotocellule: sono entrato nel plc ed ho aggiunto un ritardo sull' entrata del coltello impostabile da pannello operatore. Adesso mi piacerebbe capire dove potrebbe essere questo problema, considerato che i tecnici in zona non lavorano con questi marchi di componenti e spingono a farmi cambiare tutta l' elettronica.

Edited by Lombard
Link to comment
Share on other sites

Lombard

Qui una foto. I motori girano in senso opposto l' uno all' altro

16554864207317856676488462281652.jpg

Link to comment
Share on other sites

Livio Orsini

Quale sia la causa è chiarissimo: uno dei due motori trascina l'altro che si comporta da generatore portando il DC bus a valori di tensione troppo elevati.

 

E un problema che mi si è presentato parecchie volte, fin dai tempi in cui si usavano esclusivamente azionamenti in continua, sempre su regolazioni progettate da altri.

Il rimedio è uno solo:cambiare strategia di regolazione.

Bisogna controllare il master in velocità e lo slave in coppia, prendendo il riferimento di coppia dal master. In questo modo si realizza una ripartizione di carico tra i 2 motori; la velocità dello slave si adegua automaticamente a quella del master e nesseno dei due motori è trascinato dall'altro.

Ovviamente i 2 inverters devono lavorare in controllo vettoriale per poter controllare la coppia.

Link to comment
Share on other sites

Lombard
8 ore fa, Livio Orsini ha scritto:

Quale sia la causa è chiarissimo: uno dei due motori trascina l'altro che si comporta da generatore portando il DC bus a valori di tensione troppo elevati.

 

E un problema che mi si è presentato parecchie volte, fin dai tempi in cui si usavano esclusivamente azionamenti in continua, sempre su regolazioni progettate da altri.

Il rimedio è uno solo:cambiare strategia di regolazione.

Bisogna controllare il master in velocità e lo slave in coppia, prendendo il riferimento di coppia dal master. In questo modo si realizza una ripartizione di carico tra i 2 motori; la velocità dello slave si adegua automaticamente a quella del master e nesseno dei due motori è trascinato dall'altro.

Ovviamente i 2 inverters devono lavorare in controllo vettoriale per poter controllare la coppia.

Il manuale dell' inverter mi riporta solo queste poche righe. È una cosa fattibile o è complicata?

IMG_20220618_152800.jpg

Link to comment
Share on other sites

max.bocca

Quella è la guida rapida, il manuale è molto più...

Dal sito del del distributore reggiano è possibile scaricare tutto magari solo in inglese.

Altrimenti puoi provare a contattarli sono molto disponibili ma non ho mai approfondito il grado di conoscenza dei prodotti da loro trattati questo anche perché per certe applicazioni vogliono prodotti dei noti produttori per il settore industriale. 

Link to comment
Share on other sites

Lombard
Posted (edited)

Ok, ho trovato il manuale in inglese da 469 pagine. Me lo leggo un po', ma credo si inizi a parlare di argomenti molto complessi

Edited by Lombard
Link to comment
Share on other sites

Livio Orsini

Guada che il problema, forse, non è possibile risolverlo solo con gli inverters ma, probabilmente, bisognerà metter mano anche al software del plc.

Link to comment
Share on other sites

Il collegamento tra i due motori non è totalmente rigido (la cinghia permette un minimo slittamento).
Se ti risulta complesso il controllo in coppia dello slave, potresti anche controllare in velocità i due motori, introducendo una piccola correzione in percentuale dello slave (in positivo, o in negativo) e controllando l'assorbimento.

Link to comment
Share on other sites

Livio Orsini
11 ore fa, batta ha scritto:

Se ti risulta complesso il controllo in coppia dello slave, potresti anche controllare in velocità i due motori, introducendo una piccola correzione in percentuale dello slave (in positivo, o in negativo) e controllando l'assorbimento.

 

E la configurazione attuale.

 

Il 17/6/2022 alle 14:04 , Lombard ha scritto:

L' unica regolazione ulteriore riguarda la velocità dello slave: posso incrementarla o diminuirla. 

 

Link to comment
Share on other sites

13 ore fa, Livio Orsini ha scritto:

E la configurazione attuale.

Sì ma, probabilmente, la correzione di velocità dello slave non è fatta in modo corretto.
Dovremmo avere più informazioni al riguardo.

 

Ho fatto, circa un anno fa, il revamping di una tubiera. Prima di implementare un  controllo in coppia, ho voluto provare il semplice controllo in velocità.
Funziona tanto bene, da non sentire minimamente il bisogno di un passaggio al controllo in coppia.

Su HMI ho visualizzato (con indicatori analogici) la coppia % dei due motori.
Con due pulsantini incremento/decremento in percentuale il riferimento di velocità dello slave rispetto al master (step di ± 0.05 %).
Come detto, funziona a meraviglia. Gli inverter sono Siemens G120C con controllo vettoriale.
Con inverter di qualità scadente, non è detto che funzioni altrettanto bene. Ma, se sono inverter economici, senza controllo vettoriale, non puoi nemmeno fare il controllo in coppia.


Il controllo in coppia, assolutamente indispensabile in molte applicazioni, richiede un minimo di messa a punto per evitare instabilità.
Se non mi serve, preferisco evitarlo.

 

Edited by batta
Link to comment
Share on other sites

Livio Orsini

Dipende dall'applicazione e dagli azionamenti

Da come descritta questa è un'applicazione che non vedo per un controllo di velocità. 

Una cosa è  certa il controllo di coppia sicuramente risolverebbe il problema.

Come tutte le cose è semplice quando lo sai fare

 

Link to comment
Share on other sites

15 ore fa, Livio Orsini ha scritto:

Come tutte le cose è semplice quando lo sai fare

Livio, non è che non lo sappia fare, ma non vedo perché farlo se funziona egregiamente con un sistema più semplice.

Link to comment
Share on other sites

10 minuti fa, batta ha scritto:

ma non vedo perché farlo se funziona egregiamente con un sistema più semplice.

 

hai dei dati certi per poter affermare che in questa applicazione è sufficiente un controllo di velocità?

Io non ho dati, anzi gli unici dati che abbiamo indicano che il controllo di velocità non sta funzionando correttamente.

Inoltre so, per esperienza diretta, che il controllo in coppia dello slave risolve sempre problematiche di questo tipo.

Se gli inverter usati sono di prestazioni almeno sufficienti, probabilmente si può realizzare il tutto con modifiche minime o, addirittura, senza alcuna modifica al programma PLC.

Link to comment
Share on other sites

5 ore fa, Livio Orsini ha scritto:

hai dei dati certi per poter affermare che in questa applicazione è sufficiente un controllo di velocità?

Livio, non ho intenzione di polemizzare ma, come io non ho dati certi che in questa applicazione un controllo in velocità sarebbe sufficiente, allo stesso modo tu non hai dati certi del contrario, dato che non abbiamo la minima idea di come sia realizzato questo controllo in veocità.
Quello che so è che su una macchina esattamente di questo tipo ho realizzato un controllo in velocità e funziona bnissimo. Su questo tipo di macchine, su quelle datate, addirittura, ti capita di trovare i due motori sotto lo stesso inverter, anche con motori di taglie diverse.

Visto che per un cotrollo in velocità si tratta solo di fare un banale calcolo (due minuti, esagerando), non vedo perché non provare.

Link to comment
Share on other sites

14 minuti fa, batta ha scritto:

Livio, non ho intenzione di polemizzare ma, ....

 

nemmeno io, quindi per la cosa finisce qui. tu rimani della tua idea ed io della mia.

 

Comunque ci sono 2 dati incontestabili:

  1. La soluzione con lo slave in controllo di coppia risolve sicuramente il problema.
  2. Eseguire una ripartizione di coppia al 50% è un'operazione semplicissima e risolvibile all'interno degli inverters nella stragrande maggiorana dei cas. Bisogna usare componenentistica esterna solo gli inverter sono di cattiva qualità.
Edited by Livio Orsini
Link to comment
Share on other sites

Il 18/6/2022 alle 18:52 , batta ha scritto:

Il collegamento tra i due motori non è totalmente rigido (la cinghia permette un minimo slittamento).
Se ti risulta complesso il controllo in coppia dello slave, potresti anche controllare in velocità i due motori, introducendo una piccola correzione in percentuale dello slave (in positivo, o in negativo) e controllando l'assorbimento.

Ieri è venuto il tecnico che si occupa delle altre macchine e mi ha detto che lui cambierebbe motori, inverter, plc, praticamente tutta la macchina, perché non lavora con queste componenti. 

Oggi ho provato a vedere la coppia erogata dai due motori a varie frequenze e i risultati sono: 

MASTER: F10 T12/ F15 T8/ F20 T4

SLAVE: F10 T32/ F15 T36/ F20 T40

 

 

 

Link to comment
Share on other sites

1 ora fa, Lombard ha scritto:

mi ha detto che lui cambierebbe motori, inverter, plc, praticamente tutta la macchina, perché non lavora con queste componenti. 

 

Molto comodo, perbacco. Io cambierei "tecnico"(visto che sembra più un venditore). Se fosse un Tecnico troverebbe la soluzione con quel materiale o, almeno, darebbe una giustificazione tecnica sull'impossiiblità di effettuare il lavoro.

 

1 ora fa, Lombard ha scritto:

Oggi ho provato a vedere la coppia erogata dai due motori a varie frequenze e i risultati sono: 

 

E chiaro che che lo slave "tira" più del master. In quelle condizioni il candidato ad andare in allarme di overvoltage è il master.

Se ti va in allarme lo slave dovrebbe avere il valore di coppia che tende ad essere di molto inferiore a quello del master; quando la coppia diventa negativa, ovvero il notore viene trascinato, acatta l'allarme di sovrattensione sul DC bus.

 

Prova a diminuire la velocità dello slave del minimo possible, tenendo ferma la velocità del master. Dovresti veder scendere il valore di coppia dello slave ed aumentare quella del master; agendo sempre con il differenziale minimo di velocità trova il valore di velocità dello slave dove i due valori di coppia sono molto simili (ammesso che si riesca). Se riesci a metterti in questa situazione tieni sotto controllo i 2 valori di coppia: se si mantengono stabili significa che, con molta pazienza, puoi lavorare senza dover far modifiche.

Se i due azionamenti sono in anello chiuso di velocità tramite encoder/resolver forse è possible che un aggiustaggio molto fine della velocità dello slave risolva il problema. 

Se invece i 2 azionamenti sono ad anello aperto, senza trasduttori di velocità, diventa molto difficile mantenere stabile il rapporto di volocità, con la precisione richiesta dal bilanciamento di coppia.

 

Comunque, come ho scritto prima, la strategia risolutiva e mettere lo slave in controllo di coppia.

Se tu pubblicassi amrca emodello degli inverters, o il link al manuale degli stessi, si potrebbe verificare se è possibile portare il sistema con lo slave in controllo di coppia senza fare modifiche al programma del PLC.

Link to comment
Share on other sites

Immagino che "F" sia la frequenza in Hz, e "T" la coppia in %.
Quello che si nota è che, a pari frequenza, lo slave eroga più coppia del master e, all'aumentare della velocità, questa differenza, come è giusto aspettarsi, aumenta.

Anche se qualcuno è contrario, io un tentativo con un controllo in velocità proverei a farlo. Ma le variazione della velocità dello slave devono essere molto piccole.
Per esempio, la frequenza dello slave dovrebbe essere:
F_Slave = F_Master x K

Dove K è un fattore di correzione che parte ad 1, e poi provi ad incrementare o a diminuire (nel tuo caso sicuramente diminuire) a piccoli passi.
Potresti provare con incrementi/decrementi 0,001.
Se gli inverter non sono pessimi, io sono convinto che troverai il giusto bilanciamento.
 

Una domanda. Io non mi sono letto il manuale dei tui inverter (e nemmeno ho intenzione di farlo), ma sarebbe molto utile sapere se sono vettoriali oppure no.
Se lo sono, non dovesse funzionare il controllo in velocità potresti passare ad un controllo in coppia; se non lo sono ed il controllo in velocità non funziona, non ti rimane che cambiare inverter.

 

2 ore fa, Lombard ha scritto:

Ieri è venuto il tecnico che si occupa delle altre macchine e mi ha detto che lui cambierebbe motori, inverter, plc, praticamente tutta la macchina, perché non lavora con queste componenti.

Di risolvere i problemi in questo modo, sono capaci tutti.
Si tratta di valutare se l'hardware è in grado di svolgere il compito richiesto oppure no. Poi, si può sempre dire: "Fai fare il lavoro ad un altro, perché io non conosco questi dispositivi e non ho intenzione di perdere giorni ad imparare ad usare dispositivi che non userò mai più". Questo ha senso, ma pretendere che il cliente butti via materiale per svariate migliaia di euro se questo materiale è valido, è un'azione terroristica.

Link to comment
Share on other sites

8 minuti fa, batta ha scritto:

Anche se qualcuno è contrario, io un tentativo con un controllo in velocità proverei a farlo. Ma le variazione della velocità dello slave devono essere molto piccole.

 

Se hai letto il mio precedente intervento. devi aver notato che ho consigliato proprio di effettuare questa prova, indicandone anche le modalità.

Rimango scettico sui risultati, specialmente se si tratta, come suppongo, di azionamenti ad anello aperto senza reazione di velocità.

 

Tranne piccole varianti i nostri ultimi 2 interventi sono sostanzialmente eguali.

Edited by Livio Orsini
Link to comment
Share on other sites

8 minuti fa, Livio Orsini ha scritto:

Se hai letto il mio precedente intervento. devi aver notato che ho consigliato proprio di effettuare questa prova, indicandone anche le modalità.

Livio, ho iniziato a scrivere prima del tuo post. Il tuo l'ho letto solo dopo aver pubblicato il mio.
Fa piacere constatare che, ogni tanto, ci troviamo d'accordo su qualcosa 😉

Link to comment
Share on other sites

48 minuti fa, Livio Orsini ha scritto:

 

Molto comodo, perbacco. Io cambierei "tecnico"(visto che sembra più un venditore). Se fosse un Tecnico troverebbe la soluzione con quel materiale o, almeno, darebbe una giustificazione tecnica sull'impossiiblità di effettuare il lavoro.

 

 

E chiaro che che lo slave "tira" più del master. In quelle condizioni il candidato ad andare in allarme di overvoltage è il master.

Se ti va in allarme lo slave dovrebbe avere il valore di coppia che tende ad essere di molto inferiore a quello del master; quando la coppia diventa negativa, ovvero il notore viene trascinato, acatta l'allarme di sovrattensione sul DC bus.

 

Prova a diminuire la velocità dello slave del minimo possible, tenendo ferma la velocità del master. Dovresti veder scendere il valore di coppia dello slave ed aumentare quella del master; agendo sempre con il differenziale minimo di velocità trova il valore di velocità dello slave dove i due valori di coppia sono molto simili (ammesso che si riesca). Se riesci a metterti in questa situazione tieni sotto controllo i 2 valori di coppia: se si mantengono stabili significa che, con molta pazienza, puoi lavorare senza dover far modifiche.

Se i due azionamenti sono in anello chiuso di velocità tramite encoder/resolver forse è possible che un aggiustaggio molto fine della velocità dello slave risolva il problema. 

Se invece i 2 azionamenti sono ad anello aperto, senza trasduttori di velocità, diventa molto difficile mantenere stabile il rapporto di volocità, con la precisione richiesta dal bilanciamento di coppia.

 

Comunque, come ho scritto prima, la strategia risolutiva e mettere lo slave in controllo di coppia.

Se tu pubblicassi amrca emodello degli inverters, o il link al manuale degli stessi, si potrebbe verificare se è possibile portare il sistema con lo slave in controllo di coppia senza fare modifiche al programma del PLC.

Ho nel frattempo provato a variare la velocità dello slave in funzione dei valori riscontrati, cercando di bilanciare il valore della coppia, ma risulta impossibile. Fino ad un certo range di modifica della velocità dello slave, la ripartizione di coppia resta invariata, dopodiché inizia a sbilanciarsi in maniera opposta fino ad arrivare ad avere un motore che tira e uno che riposa (e poi salta). 

 

Gli inverter sono LS S100 e sfigliando il manuale è presenta la voce vettoriale

Link to comment
Share on other sites

2 ore fa, Lombard ha scritto:

Gli inverter sono LS S100 e sfigliando il manuale è presenta la voce vettoriale

Ora dovremmo sapere se il controllo vettoriale è abilitato, oppure se l'inverter è banalmente in U/f (cosa molto probabile).
Se si vuole una buona regolazione della velocità ad anello aperto, serve il controllo vettoriale.
Posso affermare che con i Sinamics G120 in controllo vettoriale, la regolazione della velocità ad anello aperto è molto precisa.
Un inverter di qualità, impostando correttamente i dati di targa ed eseguendo l'ottimizzazione del motore (l'inverter si legge resistenze ed induttanze del motore), compensa molto bene lo scorrimento.

 

A questo punto, io farei un altro tentativo con controllo in velocità dopo aver impostato l'inverter in vettoriale ed aver eseguito l'ottimizzazione (passaggio obbligatorio anche per il controllo in coppia).
Se non va, ti studi il manuale e vai di controllo in coppia.

Link to comment
Share on other sites

11 ore fa, Lombard ha scritto:

Ho nel frattempo provato a variare la velocità dello slave in funzione dei valori riscontrati, cercando di bilanciare il valore della coppia, ma risulta impossibile. Fino ad un certo range di modifica della velocità dello slave, la ripartizione di coppia resta invariata, dopodiché inizia a sbilanciarsi in maniera opposta fino ad arrivare ad avere un motore che tira e uno che riposa (e poi salta). 

 

Si questo conferma quanto ho supposto sin da subito.

Non ti rimane che compiere le operazioni che ha suggerito Batta, se non risolvi non ti rimane che la ripartizione di coppia.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...