Jump to content
PLC Forum


Sign in to follow this  
agoman

Timer Bromografo - pic16f84a da programmare?

Recommended Posts

GiRock

Ti stavo aspettando al varco rolleyes.gif...

Hai scaricato il file che ti ho linkato???

Hai premuto il bottone UnZip???

Ho appena aperto il file del bromografo estraendolo dallo Zip e non ha nessun problema...

Menu ICProg File -> Apri e clicchi sul file...

Spiegati meglio, non capisco tante volte cosa vuoi dire...

A parte che non ti deve chiedere nulla se hai seguito la procedura, ma sei tu che lo devi caricare prima di mettere il PIC sullo zoccolo...

Edited by GiRock

Share this post


Link to post
Share on other sites

agoman

o scaricato il tuo link o premuto su unizip dopo mi carica e mi rimane la finestra con c/: lampeggiante a lato ce scritto browser se devo vedere gli 8 file caricati devo pressare run win zip dopo che digito run win zip mi viene fuori la schermata usa versione di valutazione win zip e al lato ce buy now che non so il significato e sotto ce scritto register e attiva codice se poi digito versione di valutazione mi vengono fuori gli 8 file ora volevo sapere il file del temporizzatore e l'ultimo file timer buzzer hex? perche propio quello non lo apre che devo fare?

Share this post


Link to post
Share on other sites
GiRock

rolleyes.gif Ma nooooooooooooooooooooo Ago!!!

I files li trovi nella cartella C:\ICProg, non devi lanciarlo da WinZip...

Una volta premuto UnZip puoi chiuderla la finestrella, poi vai in Esplora Risorse dove troverai tutto pronto...

laugh.gif Mannaggia...

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

ahahahah saro' un imbranato col pc biggrin.gif che casino ti faccio uscire matto stasera alla fine ti pago il conto !!!!! o capito tutto il file lo dovevo aprire dal programma o visto gia' io avevo fatto tutto esternamente e per quello che non andava ora il programma e dentro o seguito le istruzioni o pressato il tasto verde come mi ai detto inizia a programmare alla fine naltro intoppo mi viene fuori la finestra con scritto verifica fallita al address 0000h? che vuol dire il led quando butto dentro il programma mi lampeggia e normale? sad.gif

Edited by agoman

Share this post


Link to post
Share on other sites
GiRock

Il LED si accende solo quando programma o esegue la verifica...

Una domanda: hai impostato tutto bene prima di premere il tasto programma tutto???

Il driver lo hai caricato rilanciando il programma???

Hai verificato la COM???

La casella a discesa è impostata su PIC16F84A???

Quel tipo di errore di solito lo fa se la tensione della seriale non è sufficente, ma che Computer usi, non dirmi un portatile perché ti uccido...

Io di solito se mi da errore, provo con una cancellazione del chip prima di riprogrammarlo...

Fai questo test: premi leggi tutto e guarda se il LED lampeggia saltuariamente, poi fammi sapere...

Share this post


Link to post
Share on other sites
agoman

si il led lampeggia quando il programma va dentro si accende ok quindi il pic posso riprogrammarlo sopra o prima devo cancellare i dati per riprovare?

Share this post


Link to post
Share on other sites
GiRock

Ago, non modificare i messaggi quando ho già risposto, altrimenti sembriamo due rimbambiti...

Allora sto LED lampeggia o no???

Se passi con il mouse sui vari bottoni vicino a quello che ti ho marcato in verde, appare il messaggino con la funzione che svolge, se hai cablato tutto bene non dovrebbero esserci problemi...

Attenzione che molti PIC di quella serie che vendono sono delle sole, quindi se lo hai preso a poco prezzo, non è detto che sia programmabile...

Prova a cancellarlo, se ti dice Cancellazione effettuata allora è probabile che abbia bisogno di una spinta...

Non toccare assolutamente i fuses, l'ultimo serve per proteggere il PIC da ulteriori programmazioni, deve essere abilitato solo il PWRT...

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

si me la cancellato tutto ok o riprogrammato e l'errore non me la dato + che significa? che dobbiamo brindare ? se mi dici tutto ok ti dico solo che domani lo provo perche se no o un agguato della mia ragazza che e mezzora che mi aspetta per uscire comunque secondo me ce l'abbiamo fatta domani ti diro' se il circuito del bromografo va o meno grazie di tutto ci sentiamo domani dopo pranzo ciao.

Share this post


Link to post
Share on other sites
agoman

brutte notizzie wallbash.gif sto cazzarola di circuito non accende ancora porca miseria siamo in alto mare o ricontrollato tutte le piste e sono ok alimentazione 5 volt ok l'unica cosa diversa che o messo e il rele' che e a 6 volt ma non credo che centra perche' lo smontato e non va neanche. ti chiedevo ma quando si da alimentazione al circuito i display si dovrebbero accendere o devi premere start per visualizzare i display sad.gif non e che montato il pic senza aver messo il programma abbia subito qualche danno? io o provato col tester in megaom tra piedino 14 e piedino 5 col tester e puntali messi corretti cioe il meno col meno e il+ col+ non mi segna nulla se inverto i puntali mi da una resistenza elevata quasi 7 megaomm non e un po elevata? o provato anche a misurare in entrata alimentazione circuito con i puntali giusti e tester a 20 megaom non mi segna nulla

con i puntali invertiti mi da7 megaom blink.gif bo non dovrebbe segnarmi al contrario? e un casino i display sono hdsp-5501

hp923g+ thailand il quarzo e di 4000.000 dovrebbe essere giusto? transistor tutti bc 337 npn l'unica cosa diversa che ce e l'alimentatore costruito con ponte di diodi 7805 condenzatore 2200 mf in entrata e uscita 7805 condenzatore 470mf ma non centra nulla neanche quello. o o sbagliato a collegare qualcosa oppure a qualche problema il pic dimenticavi il cd e un hef4511bp va bene? asppetto qualche suggerimento. o fatto un tema scusami smile.gif

Share this post


Link to post
Share on other sites
GiRock

Allora, siamo sicuri che il PIC sia stato programmato???

Non è che dalla fretta ieri sera lo hai solo cancellato???

Se mi assicuri che il circuito del bromografo è stato fatto a regola d'arte, probabilmente non hai programmato bene il chip...

Ripeti la procedura di riprogrammazione, prima però esegui una cancellazione, e questa volta con calma, la fretta è cattiva consigliera...

Alla fine della programmazione, quando esce il messaggio che è tutto OK, premi il bottone Verifica per essere sicuro che i dati memorizzati siano corretti...

Ad ogni modo data alimentazione il display si deve accendere, altriementi come lo programmi il tempo???

Share this post


Link to post
Share on other sites
agoman

quindi anche se il pic non era programmato il display si deve accendere? perche se e cosi devo ricontrollare tutte le piste della basetta non vorrei ci sia qualche interruzzione o orrore sai lo fatto col pennarello e il clorulo mi a indebbolito un po le piste quasi quasi li ristagno tutte col saldatore. com prima riprovo a programmare poi ti dico.

Share this post


Link to post
Share on other sites
GiRock

Purtroppo il circuito lo hai tu, li non posso aiutarti più di tanto, il mio compito era quello di aiutarti nella programmazione del chip, per il resto devi verificare tutti i collegamenti dello stampato aiutandoti con il tester...

Occhio ai ponticelli sul display, spero che tu li abbia fatti, così come i collegamenti laugh.gif...

Il PIC non è che lo puoi verificare con il tester, al limite devi farti un circuitino a parte di prova per toglierti ulteriori dubbi, ma sappi comunque che sono molto resistenti se non li strapazzi per lungo tempo...

Se lo programmi e non ti da errori è molto probabile che la colpa sia altrove...

Share this post


Link to post
Share on other sites
agoman

non mi dava piu' errore perche non avevo messo dentro il programma mannaggia ora me lo rida' di nuovo l'errore una cosa volevo dirti ma il file che devo mettere dentro e dove ce scritto timer buzzer hex giusto? o devo cliccare su ic prog?

Share this post


Link to post
Share on other sites
GiRock

Ma qui continuiamo a ripeterci, leggi bene quello che ti ho scritto dove ci sono le immagini, altrimenti facciamo solo confusione...

Il PIC va collegato solamente dopo aver caricato il programma e settato i parametri...

Un ultima volta:

1) Collegare il programmatore (sperando che sia correttamente cablato rolleyes.gif)...

2) Lanciare ICPRog...

3) Visto che ori usi i bottoni, clicca su quello con il disegno della spina ed imposti JDM e selezioni la COM ed IO diretto poi dai OK...

4) In Opzioni -> MISC verificare che il driver sia abilitato...

5) Caricare il programma premendo il bottone a sinistra quello con la cartellina...

6) Verificare che la casella a discesa riporti PIC16F84A e l'oscillatore XT...

7) Inserire il PIC...

8) Premi F4 (novità) per programmare i fuses e conferma (non toccare nulla in quella sezione), verifica solo che sia selezionato PWRT...

9) Canella il chip e attendi il messaggio di risposta...

10) Se tutto in ordine, finalmente premi Programma tutto ed attendi il risultato...

Due domandine a cui non hai mai risposto:

Che Computer usi???

Che sistema operativo usi???

mad.gif Sappi che se è un portatile, mi rifiuto di aiutarti in futuro, dato che ti avevo avvisato subito che ci sarebbero stati dei problemi laugh.gif...

A questo punto, se non hai ancora risolto, non rimane che andare a comprare un altro PIC e levarsi ogni dubbio almeno sulla programmazione, il resto lo devi fare tu con calma e precisione prima di inserirlo nel circuito...

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

ops lo lasciato collegato lo smonto scusami ora seguo passo passo il pc non e un portatile riprovo.

Share this post


Link to post
Share on other sites
agoman

sono al passo 3 comm? devo posizionare su 1? cosa e comm?

Share this post


Link to post
Share on other sites
GiRock

Se hai una sola porta COM si...

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

driwer xp ok priorita' cosa devo mettere normale?

Share this post


Link to post
Share on other sites
GiRock

Non toccare nulla se il driver è caricato, dai OK, altrimenti se ti chiede di riavviare il programma confermi...

P.S. Il programma l'ho testato e non da errori, quindi vedi di concentrarti su quello che stai facendo...

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

sono alla fase 5 apro la cartellina gialla e mi vengono fuori 8 file quale devo mettere dentro? l'ultimo timer buzzer? o altro qui mi blocco

Edited by agoman

Share this post


Link to post
Share on other sites
agoman

niente mi da verifica fallita con un numero finale che 2 palle o un dubbio pero' riesci a farmi vedere la foto del programma timer buzzer a destra mi saltano fuori dei quadratini delle croci non e che non legge bene il programma sto pc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...