Jump to content
PLC Forum


Sign in to follow this  
agoman

Timer Bromografo - pic16f84a da programmare?

Recommended Posts

GiRock

Ma lo hai cancellato prima???

Foto in arrivo, fammela caricare...

user posted image

Edited by GiRock

Share this post


Link to post
Share on other sites

agoman

si lo cancellato fino qui ci arrivo ahahaahah

Share this post


Link to post
Share on other sites
GiRock

Devi darmi il numero di errore, così posso capire che problema hai...

Share this post


Link to post
Share on other sites
agoman

nel 0028: dove ce la colonna separata a destra mi ritrovo dati diversi

allora mi trovo ..-quadratino 0. quadratino quadratino e diverso come mai? del resto la numerazione mi sempra uguale

nella tua foto

..- 0. sono giusti i dati tuoi non e che non mi legge questi file corretti?

Share this post


Link to post
Share on other sites
GiRock

Devi ricaricare il file per averli corretti, probabilmento hai quello errati letti dal PIC...

Già che ci sono metto il link allo schema: Bromografo...

Edited by GiRock

Share this post


Link to post
Share on other sites
GiRock
ohmy.gif Bloccati, c'è un errore nella compilazione del codice, lo sto correggendo, poi ti mando il file corretto...

Share this post


Link to post
Share on other sites
agoman

finalmente mi dice cip verificato con successo provo.

Share this post


Link to post
Share on other sites
agoman

a ce u errore capito sai o provato a mettere il pic mi da segni di vita mi suona il buzzer a intermittenza e se schiaccio start mi si eccita il rele' e si accende il led ma non capisco i display non si accendono ancora ghe gatta da pelare mannaggia. aspetto correzzioni

Share this post


Link to post
Share on other sites
GiRock

laugh.gif E prova, ma verifica un po il bromografo prima...

Non aspettare, controlla il circuito che hai cablato, ora che sei riuscito a programmarlo...

Edited by GiRock

Share this post


Link to post
Share on other sites
GiRock

Allora non si lavora così, adesso sono proprio stanco, se vuoi fare di testa tua vai avanti da solo...

Corri il rischio di bruciare il chip, per ogni pulsante che schiacci viene scritto un dato memoria e se i collegamenti non sono corretti, puoi immaginare...

Addio...

Share this post


Link to post
Share on other sites
agoman

mi sa che devo rivedere le piste del display sono molto piccole non vorrei ci sia una pista interrotta i 5 volt dai 4 transistor escono e sul basetta del display arriva pure tenzione controllo tutto a modo poi ti dico dai magari ci sentiamo stasera non ti tenco piu' su pc vai tra se vuoi andare poi riprendiamo stasera ciao

Share this post


Link to post
Share on other sites
agoman

niente o risaldato tutte le piste non si accendono non e che i display non vanno bene ? ai detto che cera un errore prima mi riesci a mandare la correzzione poi magari stasera dopo cena riprovo a programmare. ciao e grazie.

Share this post


Link to post
Share on other sites
GiRock

Come ti ho già detto, controlla tutto bene e con calma, altrimenti mi fai uscire pazzo rolleyes.gif...

Adesso devo riposarmi un po per modo di dire, sto verificando lo schema del bromografo con il simulatore per vedere se funziona bene...

Forse ci becchiamo più tardi...

Share this post


Link to post
Share on other sites
agoman

azzo forse o capito secondo me sono i display possibile che mi si accendono i segmenti col positico comune non deve essere il negativo il comune o provato a mettere sul tre il positivo e girando col negativo i segmenti vanno tutti compreso il punto col negativo come da schema non accende nulla sul display ce scritto g+ mica intende gate comune positivo? com fai con comodo io vado via ci senttiamo a tarda sera ps displey codice hdsp-5501 hp 923 G+ taillandia vedi datascet se ci o beccato o meno a stasera dopo cena ciao.

Share this post


Link to post
Share on other sites
GiRock

rolleyes.gif In effetti c'è qualcosa che non torna...

Quei display hdsp-5501 sono ad anodo comune, mentre sulla lista componenti c'è scritto catodo comune, forse dovresti contattare l'autore per delucidazioni in merito mad.gif...

Secondo me, da quanto ho letto è stato scopiazzato e modificato, si sono solo dimenticati di modificare lo schema che è quello dell'autore originale...

Acc... la prossima volta chiedi consiglio qui nel Forum, di questi schemi è piena la rete...

Se hai in giro un catodo comune prova con quello, almeno ancora una volta il dubbio e tolto di torno...

Share this post


Link to post
Share on other sites
agoman

ma vaffanbagno ne o provato uno col comune positivo e accende ma non capisco i numeri i segmenti girano a caso com se scaccio i pulsanti cambia qualcosa e come se i numeri giranoi boo pero l'imput di accenzione ce ora sono display smontati da vecchie tv forse e meglio che li compro con le stesse caratteristiche e negativo comune vai a trovare il codice ora mamma mia che caos.

Share this post


Link to post
Share on other sites
GiRock

Non facciamo confusione, il display deve avere il catodo comune altrimenti non può funzionare...

Sul datasheet c'è la tabella con la sigla per ogni tipo, vedere quì: HDSP DISPLAY...

Il 5503 per esempio va bene, poi ce ne sono altri se non lo trovi...

Il simulatore ha dato esito positivo, ha suonato pure il buzzer, e ti posso anche spiegare la funzione dei pulsanti:

1) UP -> Incrementa il tempo a passi di 10 sec.

2) DOWN -> Decrementa il tempo a passi di 10 sec.

3) PROG -> Programma il tempo prescelto così le volte successive non devi più farlo.

4) START -> Accende le lampade e parte il countdown (conto alla rovescia).

Azz che sudata Ago, non so se la prossima mi vedrai in GiRock...

Share this post


Link to post
Share on other sites
GiRock

L'ultimo pulsante, quello di START, funge anche da STOP e RESET se pigiato più volte...

1 volta) START

2 volte) STOP

3 volte) RESET

Aspettiamo che modifichi il circuito con i nuovi display, facci sapere qualcosa...

Share this post


Link to post
Share on other sites
agoman

scusa sono appena rientrato o finito da poco di cenare scusa allora i display che o io anno l'anodo in comune quindi non vanno bene li devo sostituire vanno bene i 5503? ora provo a vedere se ne o qualcuno e lo metto su vediamo cosa succede

Share this post


Link to post
Share on other sites
agoman

non ce lo oltre al 5503 ci sono altri display che posso adattare? spero di trovarli in negozio com quando do corrente il disply vecchio sembra che lambeggia a tempo di buzzer dovrebbe andare pero' i segmenti non si vedono bene quando cambio i displey ti dico qualc sperro di trovarli se no li devo prendere tramite internet ciao alla prossima e grazie di tutto.

Share this post


Link to post
Share on other sites
GiRock

Dimmi quelli che hai che facciamo prima a sapere se vanno bene...

Se quando accendi suona il buzzer, devi premere il tasto START, dopo quando si programma si imposta da solo e non suona più all'accensione...

user posted imageuser posted imageuser posted imageuser posted image

Edited by GiRock

Share this post


Link to post
Share on other sites
agoman

li o gia provati ne o solo 1 che a l'anodo comune e il tfk 451 sotto ce d300pag booo mai sentiti sara di qualche mivar vecchio smontato pero' non accende bene avra linterno dei led predisposto diversamente dai lunedi vado in negozio e vedo se li trovo se non li trovo poi vedeamo se su internet si trovano che li mando a prendere. ciao a presto

Share this post


Link to post
Share on other sites
GiRock

Va bene, però una controllatina a tutto dagliela ancora, ci sentiamo, Ciao...

Share this post


Link to post
Share on other sites
agoman

a scusa o riletto allora devono avere il katodo in comune ok scusa ma il caldo fa brutti scherzi.

Share this post


Link to post
Share on other sites
agoman
ohmy.gif oooooooo giro o provato a programmarlo come mi ai detto te e anche se non vedo i displey dando start e 2 pigiate di ap dopo un tot mi si spegne il led il display lampeggia e il buzzer si mette a suonare forse ci siamo abbiamo programmato il cip a modo menomale laugh.gif sei un grande mamma mia manca solo per sti cavolo di display se ne trovi altri modelli perfavore me li posti che lunedi' o martedi mi faccio i miei giri sperando di trovarli sono condento dai siamo quasi alla fine thumb_yello.gif alla prossima. Edited by agoman

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...