Jump to content
PLC Forum


Henon

Problemi Sporadici Di Interruzione Com. Profibus - Profibus con dei problemi sporadici di Communicazione.

Recommended Posts

Henon

Vi Racconto queste 2 storie per sentire altri pareri su come risolvere

Problematiche di Communicazione in ProfiBus.

1° Caso

Mi è capitatto su 2 impianti identici (Medesima Configurazione)

di avere dei problemi di communicazione ProfiBus tra PLC s7-414 2DP e moduli remoti ET200M.

capitava 2 o 3 volte alla settimana che la comunicazione si interropeva per

un istante (circa 30 /40 ms Rilevato dalla Diagnostica), questo provocava la perdita degli I/O di

campo con il conseguente arresto della Linea.

Dalla Diagnostica veniva segnalato Guasti ai Nodi-DP in ordine sempre diverso, (a volte in nodi

dei Drive a volte i nodi delle ET200M, a volte gli Encoder).

Perciò non si riusciva a risalire alla Causa.

La rete era composta da una CPU S7-414 2dp, N°7 Moduli ET200M, N°2 Drive ACS800,

N°2 Drive SDB della TDE, N°4 encoder Assoluti della ELCIS, N°1 PC come Panello operatore (in ProfiBus).

La CPU era nella Posizione Intermedia, il termine della rete era da un lato con una ET200M e

dall' altra parte con un Encoder ELCIS.

Lunghezza totale della rete di 30mt, nessun Repeater.

Ho provato le seguenti cose:

- Rifate le connessioni (Cavi nuovi, cambiati tutti i Connetori ProfiBus)

- Tolto il PC dalla rete ProfiBus e passato in MPI.

- Alimentato con un nuovo Alimentatore separato le ET200M , Encoder Assoluti.

- Separati i cavi ProfiBus su Condotte in Metallo (cavo passante su tubi separati).

- Controllate e Separate le Masse delle ET200M.

- Cambiato tutte le ET200M

- Sostituiti gli encoder Assoluti ProfiBus.

- Provato a Cambiare la CPU.

Poi dopo essere giunti quasi alla disperazione, ho fatto un cosa poco Ortodossa, nel Programma

PLC (Ho posto un piccolo ritardo alla Diseccitazione sugli ingressi che causavano l'arresto della Linea),

in questa maniera ho tamponato provisoriamente il Problema.

Poi dopo continue prove abbiamo trovato la soluzione.

Abbiamo Spostato la Terminazione della Rete ProfiBus dall' encoder Assoluto Elcis con un ET200M.

Pultroppo non siamo mai giunti a spostare la terminazione prima, per problemi della distanza dell' encoder.

In pratica la Terminazione sull' Encoder Elcis, non garantiva una Impedenza corretta di terminazione,

e la Rete profiBus andava in crisi, segnalando errori ai Nodi-DP in ordine casuale.

2° caso

Abbiamo collaudato in sede una Macchina S7-300 con rete ProfiBus, giunti alla fine

dei test con nessun problema (la Macchina Funzionava come un Orologio Svizzero).

All' improvisso all' accensione di un Drive, la Rete andava in crisi, segnalando l'interruzioni

ai Nodi-DP in ordine vario. (Blocco immediato della Lettura di Tutti gli I/O Remoti, e degli altri Devices)

Anche qui il problema era al quanto strano, sino a 5 minuti prima tutto funzionava perfettamente,

poi nella Cac...... più completa.

Cambiato ET200M, Controllato il Passaggio dei Cavi ProfiBus.

Cambiato CPU, sostituiti Connettori ProfiBus, etc.

Alla Fine abbiamo scoperto che per i Test delle Macchine in Sede, venivono usati Cavi ProfiBus

che avevano 4 o 5 anni. E molto probabilmente Strattonati molte volte avevano

perse le proprietà di isolamento tra Schermo e Segnali A e B.

Infatti Cambiato il Tratto incriminato la macchina è ripartita perfettamente.

Due Storie per raccontare che a volte, si può andare in pappa per piccolezze, che però possono procurare

notevoli problemi.

Ma forse bisogna dotarsi di un analizzatore di rete ProfiBus ( Ma ??? ???) ho è na boiata ?

Ho raccontato queste storie, per raccogliere pareri da altre persone, che si sono imbattuti nel

mio stesso problema.

Link to post
Share on other sites

kroccodile

Lavoro solitamente su impianti estremamente vasti, con reti profibus, e solitamente per la mia esperienza personale, la prima cosa che impedisce un corretto funzionamento della rete è la schermatura che alle volte non fa contatto, o gli spinotti ( o spine) che non fanno contatto bene. Sulle resistenze non ho mai avuto problemi, ma va detto che abbiamo spempre resistenze di chiusura o spine SIEMENS, mai di terze parti. Quindi se non funziona con le loro.....

Link to post
Share on other sites
capi

Anche io in genere lavoro con impianti piuttosto estesi; comunque quello che ho potuto constatare è che meglio mettere un repeater in più che uno in meno.

Spesso i problemi che ho avuto erano dovuti o a connettori o a cavi difettosi; la soluzione del problema spesso è difficile perchè non è detto che lo slave che non risponde sia effettivamente quello con il problema, anzi molto spesso è quello collegato immediatamente a monte o a valle.

Comunque per quanto riguarda l'analizzatore di rete...beh, secondo me lascia un po' il tempo che trova anche perchè mica ti dice dove sta il problema....

ciao ;)

Link to post
Share on other sites
Luca Bab

Sono d'accordissimo con capi

meglio un repeater in piu'

io preferisco anche farmi i connettori da solo

con l'atrezzo siemens per spellare il cavo ed i connettori fast ,

si fa' prestissimo e sono sicuro del risultato

Ciao

Luca

Link to post
Share on other sites
Henon

Non Penso che un Repeater potesse bastare, a risolvere il Problema.

Infatti abbiamo provato anche quella strada. (inoltre la Rete era di soli 30mt).

Be ovviamente ho rifatto personalmente le conessione dei Cavi, con Intestatrice della Siemens, e terminali della Siemens (12 MB).

Penso che il Problema potrebbe presentarsi anche a voi, qualche volta.

Penso inoltre che le Prime Versioni Hardware del Architettura ProfiBus erono meno soggette a queste

problematiche. (Non proprio le primissime, intendo 3-4 anni fà)

Infatti non avevo mai avuto di questi problemi, nelle architteture Hardware di qualche anno fà.

Forse a livello Elettronico hanno abbassato i livelli di Polarizzazione e protezioni delle Porte di Comunicazione ProfiBus.

E dove prima non riuscivi a compromettere la comunicazione nianche a Picconate, ora basta una

piccola imperfezione, e la Rete va in Pallone.

Poi non riesco a capire, perchè in questi casi non si capisce più niente dalla Diagnostica Siemens S7.

(Nodi che vanno e vengono, senza invece segnalare una attenuazione della comunicazione, chiedendo di rinviare al master la diagnostica dei singoli Slave, e l'attenuazione dovuta all'impedenza di terminazione.)

In una rete 485 dovrebbe essere possibile rilevare questa anomalia ? oppure no ?

Forse per abbasare lievemente i costi di Produzione Hardware (Taiwan,China,India) si manda a farsi

friggere in affidabilità una Rete come ProfiBus, che nell' affidabilità era un vanto.

Link to post
Share on other sites
Henon

Provate a terminare la Rete con una Impedenza, non appropriata e poi vi chiedo di individuare l'anomalia.

Penso che dalla Diagnostica non avrete un aiuto soddisfacente, per risolvere aggevolmente il problema.

Forse continuerete a provare e riprovare sino a risolvere il problema, per tentativi !

Link to post
Share on other sites
capi

è chiaro che un repeater non ti risolve tutti i problemi.

se poi ci aggiungi il fatto che le terminazioni potrebbero non essere corrette allora il funzionamento anomalo dipende da come viaggiano sul cavo le onde riflesse e quindi in funzione della topologia dell'impianto, del baud rete... auguri! :)

ciao

Link to post
Share on other sites
Luca Bab

Non credo che abbiano peggiorato l'architettura profibus

ti posso dire che in un impianto recente ho utilizzato circa 2,5 km di cavo profibus

senza nessun problema ( e' 3 anni che va' e va' bene )

Non credo che ti serva della diagnostica , ti serve solo un po' di metodo per capire dove stanno i problemi

Dando per inteso che utilizzi solo materiale siemens , tramite i connettori puoi sezionare segmento per segmento la tua rete.

Quindi procedendo a passi puoi trovare in quale segmento hai i problemi.

In questo modo , l'anomalia ( anche con una impedenza non appropriata) la trovi subito

Nessuno dice che con un repeater risolvi il tuo problema , era solo un consiglio che porta benefici sia ai problemi di lunghezza sia alla facilita' di sezionare parti della rete sia al cablaggio per avere delle derivazioni

Ciao

Luca

Link to post
Share on other sites
Henon

Componentistica Siemens o non Siemens, dovrebbe rispettare

le direttive che il protocollo ProfiBus impone, specialmente

se si vuole appartenere al Consorzio ProfiBus.

Bisogna far notare Inoltre che quando un impianto parte in produzione,

nessuno ti permette di fare le tue prove.

Molto spesso questi problemi appaiono a distanza di giorni,

magari per una settimana nessuno, e poi a raffica.

Su reti da Km, con più Repeater, è chiaro che i Tratti da Repeater a

Repeater hanno un circuito in cui è soddisfatta l'Impedenza di Trasferimento

(Non esiste Riflessione o altro), quindi la Rete non va in Tilt.

Nelle Reti non Lunghe, potrebbe invece succedere.

Chiaramente 100 volte può andare Bene, la Rete te la realizzi tu e tutto va bene,

ma quella volta (1/100), può bastare per rovinarti.

Ho cerco qualcosa che mi analizzi la Rete DP approfonditamente, altrimenti dalla Diagnostica non mi posso fidare.

Forse me lo posso Costruire Io, un qualcosa che mi analizzi un Tratto di Linea di

Trasmissione tipo RS485. oppure cerco su Internet.

Ho capito che me lo devo fare o Comprare, altrimenti sperando nella Meticolosità, costanza,

Scrupolosità etc non vado da nessuna parte specialmente, se a realizzare la Rete a Livello

Hardware, è qualche altra persona.

Ho visto questo modello che ne dite (Modello PBT3) ?

http://www.aeffesse.it/profibustool.htm

oppure questo:

http://www.procentec.com/profitrace/

http://www.softing[dot]com/en/communications/p...yzer_mobile.htm

per rs 485

http://www.bb-elec.com/bb-elec/literature/485slaa.pdf

Link to post
Share on other sites
Luca Bab

Per componentistica siemens intendevo il cavo e i connettori ( poiche' ho gia' avuto problemi con componenti piu' economici )

Compra pure un analizzatore , vedrai i pacchetti che passano in rete ( poi mi sai dire che cosa hai capito)

Ciao

Luca

Link to post
Share on other sites
Henon

Io sono più interessato su analizzatori che verificano e

misurano i Livelli del Segnale, e i segnali di riflessione.

So benissimo che i Pacchetti Dati dei vari messaggi, non sono cosi

importatnti, se non per persone che vogliono sviluppare

Slave o Master in ProfiBus-DP.

Grazie per il vostro aiuto.

Link to post
Share on other sites
Gabriele Corrieri

Ciao, parere di chi fa tutto a manina con tester e oscilloscopio: un analizzatore in effetti è comodo, lo so anche io e ti risparmia accidenti a mezzo mondo quanto il problema è intermittente, da valutare.

Il PB-T3 secondo me è un bell'aggeggio, a prescindere dal costo, mi fido anche guardando la marca (SOFTING) che da molti anni si prodiga nel settore dei field buses. Hai chiesto un prezzo dell'aggeggio?

http://www.softing[dot]com/en/communications/p...ools/tester.htm

Ciao

Link to post
Share on other sites
Henon

Grazie Gabriele

Secondo te chi posso contattare, come rivenditore in Italia ?

Link to post
Share on other sites
Gabriele Corrieri

Ciao

simpatici o no, cordiali o no ... e altre mille motivazioni il rivenditore Softing in italia è AFS

http://www.softing[dot]com/en/communications/c...world.htm#italy

e lì ti conviene rivolgerti, non so come potrai agire altrimenti in caso di importazione "parallela", niente garanzia e i casini sono solo tuoi, in altri casi se AFS ti tratta in qualche modo puoi sempre rivolgerti in germania da softing in quanto il tuo acquisto è originale e non di provenienza strana.

Ciao

Link to post
Share on other sites
walterword

in impianti piu o meno vasti i motivi che conducono ad un fault sulla rete possono essere

diversi.

Tra i piu diffusi :

-Cavi profibus non schermati

(l'ultima messa in servizio erano addirittura alimentate le schermature a 90 V )

-Connettori poco affidabili o "crimpati male" , magari tagliati e non visibile il taglio.

-Schede profibus montate sugli azionamenti , che interfacciano la rete con i drives ,

(e' successo di sostituire intere partite dichairate malfunzionanti , a tempi irregolari , e su nodi differenti ).

I sistemi siamtic sono molto ma molto protetti conto armoniche , disturbi e quant'altro .

E' difficile poter provare o dimostrare che un'apparecchiatura sia difettata o malfunzionante .

Normalmente i problemi derivano dal campo , cioe dall'hw

ciao

walter

Link to post
Share on other sites
lele65

a me è capitato (proprio ieri...) che su una reta abbastanza vasta, circa 2km fra cavo e fibra, che mi spegnessero 2 plc. Tutto il sistema di supervisione e gli altri plc nella rete sono impazziti....

Possibile che se non hanno alimentazione i connettori siemens non abbiano + la resistenza di terminazione????

Riaccendendo tutto eliminati i problemi....

E se devo mettere un plc in manutenzione? fermo tutto lo stabilimento? non mi sembra normale dovere andare a sezionare il connettore precedente.

Saluti e buone ferie (anche se mi sembra ci sia ancora molta gente a lavorare...)

Link to post
Share on other sites
COMPROFIBUS

Ciao a tutti ,

Stavo facendo una ricerca con google per alcuni docs sul profibus e mi è saltato al'ochio questa discussione,vi segnalo alcuni suggerimenti su una societa che fornisce software ed assistenza a riguardo:

http://www.indu-sol.com/opencms/export/ind...s/diagnosetool/.

Io ho avuto problemi molto seri con una rete profibus(Linea di produzione ferma per 56 ore!!!!) con anomalie tipiche di stazioni in guasto in modalita random.

Un aiuto significativo possono arrivare anche dagli strumenti descritti nel link allegato,io personalmente ho dovuto ricablare parte della rete schermando i singoli segmenti in uscita dai cabinet con guaina schermata con cavo profibus +cavo di terra da 16mm2.

E' una storia un po lunga da raccontare ..ma il profibus è così ;) quando arrivano i problemi ti crocifigge :D se l'anomalia e seria.

Ciao

Link to post
Share on other sites
walterword

tutte le tipologie di problemi quando arrivano rompono .

Profibus e' una certa e provata , e se ci sono delle anomalie e' sempre pe rmal cablaggio,connettori mal collegati , configurazioni hw mal fatte , cavi profibus vicini a cavi ti tensione ed affini

E 'difficile che il problema profibus sia legato ad un'apparecchiatura difettata o ad un formware mal scritto

Gli aggeggi del sito sono molto interessanti , ma finche li faranno solo in tedesco temo che saranno usati

solo da tecnici tedeschi

ciao

Link to post
Share on other sites
garibaldik

Proprio ieri mi è capitato in un impianto avviato 1 mese fà, dove ho una s7-300 collegata via profibus tramite olm12g a 3 nodi et200s, che la comunicazione ogni tanto saltava per circa 100ms. Dopo ore e ore mentre fissavamo sconsolati il quadro con la s7-300, abbiamo scoperto l'arcano! Ebbene essendo il primo giorno effettivo di caldo si attivava la ventolina del quadro si superavano i 30 gradi. Appena partiva la ventola evidentemente si generavano armoniche che andavano ad interferire con il repeater olm12g. Per avere una conferma,l'abbiamo avviata per ben 20 volte e ad ogni avvio si vedevano le spie dei canali dell'OLM che diventavano ROSSE (comunicazione interrotta). Incredibile che una ventolina da pochi euro causi tanti guai! ;)

Link to post
Share on other sites
Paolomen81

Per analizzare i problemi profibus ho utilizzato il tool procentec profitrace, aiuta a capire il problema su reti estese, guardi i livelli di tensione e gli errori nei vari nodi. Per terminare una rete in modo sicuro, senza dipendere dai nodi accesi, esistono i terminatori attivi alimentati a 24vdc.

Saluti 

Edited by Paolomen81
Link to post
Share on other sites
Domenico Maschio

Paolomen81 ,

Il regolamento, che avresti dovuto leggere prima di postare, al punto 
s) Vietato accodarsi alle discussioni di altri utenti, anche con apparente eguaglianza del problema.
Apri una discussione propria riportando il link di questa, se credi ti possa essere utile.
Saluti.
 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...