Jump to content
PLC Forum


automan73

Blocco randomico smartlan/G IN073-R0

Recommended Posts

automan73

Buongiorno a tutti,

nel mio appartamento ho installato personalmente nel 2010 un impianto smartliving 1050L attualmente aggiornato al FW 5.11

Nel 2013 ho aggiunto anche una smartlan/G versione HW IN073-R0 aggiornata al FW 5.14 che utilizzo sia per le notifiche via mail che per l'accesso remoto tramite DDNS.

Il tutto funziona perfettamente a meno di fastidiosi blocchi randomici della smartlan che si verificano fin dalla sua installazione: praticamente ogni 1 - 2 - 3 mesi l'interfaccia smartlan non è più pingabile all'indirizzo ip statico prescelto ed osservando i suoi led di stato il SYS risulta sempre spento, i LINK e POWER sono accesi e l'ACT lampeggia. Resettando la smartlan tramite il tasto SW1 reset, la smartlan riprende a funzionare correttamente ed il led SYS lampeggia saltuariamente. Finora per verificare la frequenza dei blocchi avevo abilitato un test periodico via mail impostando un timer settimanale sulla centrale ed agendo poi manualmente sul tasto di reset SW1 della smartlan quando le mail cessavano di arrivare: ovviamente trattasi di un palliativo molto poco pratico ma tant'è.

Purtroppo non sono riuscito a risolvere questo problema nonostante i miei molteplici tentativi e settaggi vari: qualcuno di voi ha accusato lo stesso malfunzionamento ed ha trovato una soluzione?

In caso contrario, pensavo di togliere dalla centrale il ponticello J10 dai pin 1-2 in modo da inibire l'alimentazione alla smartlan dal connettore J17 di programmazione della centrale ed alimentare la smartlan tramite il suo connettore AUX IN collegando il pin positivo ad un morsetto AUX della centrale ed il pin negativo al contatto open collector OC1 impostato come normalmente chiuso: dovrebbe funzionare visto che per la mia centrale la corrente massima erogabile dai contatti OC è di 500mA e la smartlan/G assorbe una corrente dichiarata di 90mA max.

Ovviamente abiliterei il test connessione IP e se dovesse generarsi l'evento di connessione IP persa, farei pilotare l'OC1 in modo che si apra e si richiuda dopo qualche secondo in modo da ripristinare il funzionamento della smartlan/G.

Che ne pensate di questa soluzione?

Ringrazio anticipatamente per i vostri consigli o suggerimenti a riguardo.

Share this post


Link to post
Share on other sites

automan73

Facendo una verifica strumentale sulla smartlan/G, il pin negativo del suo connettore AUX IN è in comune con la massa della centrale, quindi il metodo illustrato nel mio messaggio precedente non funzionerebbe.

Credo che dovrei togliere comunque il ponticello J10 su 1-2 (l'interfaccia smartlan non verrebbe più alimentata dalla centrale) ed interporre i contatti C1 ed NC1 di una interfaccia auxrel32 tra il positivo del connettore AUX IN della smartlan/G ed il terminale AUX1 della auxrel32 pilotando il relativo relè1 tramite il contatto OC1 impostato di default come NO.

Quindi abilitarei il test connessione IP e se dovesse generarsi l'evento di connessione IP persa, farei pilotare l'OC1 in modo che si chiuda e si riapra dopo qualche secondo in modo da togliere e ripristinare l'alimentazione della smartlan/G.

Così dovrebbe andare, che ne dite? Potrebbe esserci qualche criticità durante l'uso o la riprogrammazione che non ho considerato?

Share this post


Link to post
Share on other sites
Panter
2 ore fa, automan73 scrisse:

 ho installato personalmente nel 2010 un impianto smartliving 1050L attualmente aggiornato al FW 5.11  [...]   Nel 2013 ho aggiunto anche una smartlan/G versione HW IN073-R0 aggiornata al FW 5.14  

[...]  Il tutto funziona perfettamente a meno di fastidiosi blocchi randomici della smartlan

.............

Credo che dovrei togliere comunque il ponticello J10 su 1-2 (l'interfaccia smartlan non verrebbe più alimentata dalla centrale) ed interporre i contatti C1 ed NC1 di una interfaccia auxrel32 tra il positivo del connettore AUX IN della smartlan/G ed il terminale AUX1 della auxrel32 pilotando il relativo relè1 tramite il contatto OC1 impostato di default come NO.

Quindi abilitarei il test connessione IP e se dovesse generarsi l'evento di connessione IP persa, farei pilotare l'OC1 in modo che si chiuda e si riapra dopo qualche secondo in modo da togliere e ripristinare l'alimentazione della smartlan/G

 

 

In teoria dovrebbe funzionare ma, pur essendo geniale è sempre un ripiego. Tieni anche presente che operazioni del genere dovrebbero essere fatte in modalità Servizio per una rilettura della configurazione alla sua uscita.

Io consiglierei, dato che hai una 1050L, di cambiare la scheda di centrale e aggiornare tutte le periferiche alla ver. 6.XX (6.07 attuale) facendoti dare dal distributore il firmware di aggiornamento e il software smartleague aggiornato anch'esso. La spesa è molto limitata e la ver 6 ti offrirebbe molti vantaggi. Unica cosa da fare è la conversione guidata della programmazione dalla ver 5 alla ver 6. La conversione lascia comunque la vecchia programmazione 5.11 e ne crea una nuova 6.xx.

Edited by Panter

Share this post


Link to post
Share on other sites
automan73

Ciao e grazie per i tuoi suggerimenti.

Mi consigli di cambiare la scheda di centrale perchè per la tua esperienza l'attuale scheda di centrale (versione HW IN025-R3) è la probabile causa del malfunzionamento della smartlan/G?

In caso saresti così gentile da darmi un codice di riferimento della nuova scheda di centrale?

Share this post


Link to post
Share on other sites
Panter
23 ore fa, automan73 scrisse:

Mi consigli di cambiare la scheda di centrale perchè per la tua esperienza l'attuale scheda di centrale (versione HW IN025-R3) è la probabile causa del malfunzionamento della smartlan/G?

 

NO, il malfunzionamento potrebbe dipendere da cause molteplici che andrebbero individuate nella programmazione (anche ddns che usi), ma... la tua scheda 1050 non è aggiornabile oltre la 5.11.

Inutile aggiornare ulteriormente la smartlan/G se non con la versione 6.xx.

Se sei disposto a spendere per una scheda auxrel32 tanto vale spendere per una scheda 1050 aggiornata e aggiornabile in futuro. Tra la ver 5 e la ver 6 c'è stato un gran salto di qualità e opzioni disponibili (come il cloud e una connessione perfetta).

 

Quella che indichi è la ver del pcb e non serve per un nuovo acquisto (dice solo che non è aggiornabile). Puoi andare da un distributore Inim e richiedere una nuova scheda di centrale 1050 e ti verrà fornita aggiornata o comunque aggiornabile all'ultima versione (da etichetta ver 6.07), e sarà lui a usare il codice d'ordine. Non cercarla però on-line.

 

ps. non è detto però che tu debba non seguire la tua idea che comunque va sperimentata..

Edited by Panter

Share this post


Link to post
Share on other sites
automan73

Grazie per la tua disponibilità.

Ok riguardo il distributore autorizzato: ipotizzando di voler aggiornare la scheda centrale con la versione 6.xx ma non potendo aggiornare oltre la smartlan/G per incompatibilità dell'hardware con le nuove versioni, potrebbero esserci dei problemi di compatibilità tra centrale e smartlan? Il cloud funzionerebbe comunque con la mia versione di smartlan?

 

Share this post


Link to post
Share on other sites
Panter
2 ore fa, automan73 scrisse:

non potendo aggiornare oltre la smartlan/G per incompatibilità dell'hardware..... Il cloud funzionerebbe comunque con la mia versione di smartlan?

 

quindi c'è anche la complicazione della smartlanG che non è aggiornabile......, quindi quella che hai non era 5.14 all'origine ma è stata aggiornata alla 5.14, e hai già visto che non si aggiorna alla 5.30 che dovrebbe essere la versione giusta per la 5.11 di centrale? Dalla 5.30 in poi si può aggiornare all'ultima ver che è la 6.11 e il cloud richiede la ver 6.xx.

Le cose si complicano perché il costo di una nuova smartlanG è superiore a quello della scheda di centrale. Quindi o fai un acquisto radicale o ripieghi sulla modifica che hai pensato.

Ma per curiosità..., hai fatto gli acquisti online o da distributore?

Share this post


Link to post
Share on other sites
automan73

Tutto il materiale è stato acquistato nuovo da un unico rivenditore autorizzato in punto vendita fisico e non online, esclusivamente per un'unica installazione presso la mia abitazione: il problema è che ha i suoi anni.

Nel lontano 2009 presi centrale 1050L addirittura ver. 2.10, smartlogos30, combinatore smartlinkg-wb, 2 tastiere joymax, 3 espansioni flex5, sirena ivy-f e lettore nby-x.

Nel 2010 ho aggiunto una sirena ivy-bf ed un ulteriore inseritore nby-s, nel 2012 ho sostituito lo smartlinkg-wb (funzionante) con il combinatore nexus e nel 2013 ho installato la smartlan/G ver 5.10.

Negli anni ho saltuariamente effettuato gli allinamenti delle programmazioni, ora non potendo più scaricare gli aggiornamenti dal sito inim non so se qualche periferica sia ancora upgradabile ulteriormente.

Aggiornare l'hardware dell'impianto sarà certamente possibile ma parecchio dispendioso rispetto al piccolo malfunzionamento che ho descritto: credo che mi converrà investire qualche spicciolo per la auxrel32 e vedere se risolvo col il metodo del secondo post.

Per il resto sono soddisfatto dell'impianto, è molto stabile, l'app alienmobile funziona con ddns dlinkddns e con connessione internet in fibra FTTC infostrada.

Edited by automan73

Share this post


Link to post
Share on other sites
glaio

Anche a me è capitato da un paio di clienti i problema del blocco della Smartlan/G, (non più aggiornabili) che ho risolto come proponi tu. Ho tolto il ponticello J10 e al suo posto ho messo un connettore a due pin con 2 fili collegati al NC di un relè pilotato dalla uscita OC2 monostabile per 5", comandabile da tastiera o da telefono tramite menù vocale. Funzionano da inizio 2015.

Se vuoi fare la finezza del controllo automatico della connessione IP, ancora meglio...

Roberto

Share this post


Link to post
Share on other sites
automan73

Sabato scorso ho implementato la modifica e per il collegamento hardware ho fatto come te: invece di utilizzare i collegamenti descritti al post 2, sulla centrale ho tolto il ponticello J10 dai pin 1-2 ed al suo posto ho inserito un connettore a due poli con i relativi fili collegati ai morsetti C1 ed NC1 di una interfaccia auxrel32, pilotando il relativo relè1 con il contatto OC1 della centrale impostato di default come monostabile NO da 5 sec.

Quindi ho abilitato il test connessione IP ed impostato l'OC1 all'evento di connessione IP persa: ho fatto un pò di prove simulando la mancanza della connessione LAN ed il tutto funziona.

Durante la lettura o la programmazione o la messa in servizio o l'uscita da codice installatore dalle joymax, l'OC1 non viene mai pilotato e quindi la smartlan/G rimane sempre correttamente alimentata.

E' sicuramente un ripiego ma non potendo più aggiornare nè la smartlan/G e neppure le altre periferiche attive del mio sistema oltre quanto previsto dalla ver. 5.11 a causa dell'hardware ormai datato, mi è sembrata la soluzione più semplice ed economica.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...