Jump to content
PLC Forum


Sign in to follow this  
aleda5859

Programmazione Pic Ed Assembler

Recommended Posts

aleda5859

Sono riuscito a trovare la rivista finalmente... (tu che programmatore hai? se lo hai già dico..)

Grazie per la dritta di comprare la rivista..cia cia

Share this post


Link to post
Share on other sites

Pablo78

Caro aleda

se vuoi t do lo schema di quello che uso io,comunque t ho già spedito una email

ciao ciao ;)

Share this post


Link to post
Share on other sites
aleda5859

Grazie pablo..

ti ho mandato la mail..

per evitare complicazione te la riscrivo anche qua...

danigeno[at]hotmail.com

grazieeeeeeeeeeeeeeeeeeeeee

Share this post


Link to post
Share on other sites
Giorgio Demurtas

ciao Pablo78,

mi piacerebbe che mettessi a disposizione di tutti il tuo schema.

Anche io sono nella stessa posizione di aledda.

Rispondento ad aledda: ho trovato n programmatore per 16€, ma ho comprato i pezzi per fare il minipippo con 3€.

ciao

Giorgio

Share this post


Link to post
Share on other sites
aleda5859

qanche io ho fatto il minipippo... una domanda,come hai saldato i diodi? cioè la parte con la barretta nera da che parte l'hai messa?

Share this post


Link to post
Share on other sites
Giorgio Demurtas

La fascia nera l'ho messa come indicato nel disegno, nel +, non puoi sbagliare!

minicomp.gif

ma porca miseria non riesco a caricare il programma (LED.HEX) che ho fatto, nel pic.

stò usando IC-prog.exe 1.05 come programmatore.

appena lo avvio mi da un errore: "Privileged Istruction", clicco ok e si apre la schermata iniziale.

adesso faccio file-->open--> il mio file led.hex

imposto modello del pic e tipo di hardware

premo il pusante "program all" per caricare il prog nel pic.....mi chiede una conferma....dinuovo l'errore di prima!!

e dopo si ferma e non risponde all comando per annullare l'operazione.

in conclusione devo chiudere ic-prog dal task manager...

come funziona quest'affare? :angry:

Share this post


Link to post
Share on other sites
dlgcom

Ciao Giorgio,

Io non ho un programmatore per ic-prog.

Ma ho caricato il programma .

Per eliminare l'errore che hai , devi andare nel menu setting , poi hardware e cambiare la voce interface da direct i/o a windows api.

Con questo , non mi presenta piu' l'errore , ma devi provare se poi entra in comunicazione .

Fammi sapere.

Saluti

Share this post


Link to post
Share on other sites
Sergio Bianchi

L'errore di "privileged instruction" appariva anche a me, poi ho risolto semplicemente configurando correttamente ICprog.

Devi verificare nell menù settings-hardware anche le altre impostazioni che cambiano in base al programmatore che usi, inoltre ricordati che sotto il menu-options c'è un' opzione (driver per NT/2000) da attivare se usi uno di questi due sistemi operativi oppure se usi XP.

Il mio ICprog è correttamente configurato per l'uso del programmatore ProPic su porta parallela, se hai lo stesso modello dimmello che ti passo la configurazione.

Ciao

Share this post


Link to post
Share on other sites
aleda5859

Perchè allora sul disegno c'è segnato il "+"? La barretta non indica il catodo? :-)

Share this post


Link to post
Share on other sites
Giorgio Demurtas

e si, hai ragione.

La spiegazione che mi sono dato è che quel + indica che sulla piazzola corrispontente c'è una tensione positiva.

comunque posiziona i diodi come nel disegno (seguendo la fascia nera).

ciao

scusatemi ma non ho ancora ritentato a effettuare la programmazione.

Share this post


Link to post
Share on other sites
Giorgio Demurtas

adesso ho tentato la programmazione, anche se sono le 23:10, ma sono troppo impaziente!

Ha funzionato tutto tranne un'errore... Verify failed at address 0000h !

che famo?

grazie

buonanotte -_- e a domani.

giorgio

Share this post


Link to post
Share on other sites
aleda5859

hai già costruito la basetta del lampaeggiatore? mi manderesti una foto? :D

Share this post


Link to post
Share on other sites
Pablo78

scusate l'ignoranza, ma purtroppo non so mettere l'immagine sul forum...

se qualche anima pia me lo spiega sarò ben lieto di postarvi lo schema che uso io.

Saluti e grazie

Pablo

Share this post


Link to post
Share on other sites
Gabriele Corrieri

Ciao Pablo

scusate l'ignoranza, ma purtroppo non so mettere l'immagine sul forum...

se qualche anima pia me lo spiega sarò ben lieto di postarvi lo schema che uso io.

Share this post


Link to post
Share on other sites
Giorgio Demurtas

Ciao aleda (ma come ti chiami?).

mi hai chiesto una foto....ti mando quella del mio minipippo

minipippo_mio.jpg

fin che non riesco a programmare il pic non posso fare il lampeggiatore.

Qualcuno mi aiuta a risolvere quell'errore?

Ha funzionato tutto tranne un'errore... Verify failed at address 0000h !

che famo?

Share this post


Link to post
Share on other sites
aleda5859

grazie per la foto...:)

ah..mi chiamo Damiele...mi ero dimenticato... :D

voi che utilizzate per tagliare la basetta?

Share this post


Link to post
Share on other sites
Giorgio Demurtas
voi che utilizzate per tagliare la basetta?

Share this post


Link to post
Share on other sites
aleda5859

ok..grazie... :-) appena ho finito di farlo..te ne mando una foto.. :ph34r:

Share this post


Link to post
Share on other sites
Giorgio Demurtas

Ma è possibile che nessuno sappia aiutarmi per risolvere quell'errore... :o

Share this post


Link to post
Share on other sites
life

Ciao Giorgio, quel tipo di errore e' dato da un errore di compilazione del codice sorgente. Hai provato ad usare qualche altro tipo di prg per caricare il .HEX???

Se vuoi puoi mandarmi il tuo file e provo io a caricarlo e poi ti faccio sapere.

Share this post


Link to post
Share on other sites
dlgcom
quel tipo di errore e' dato da un errore di compilazione del codice sorgente

Share this post


Link to post
Share on other sites
Pablo78

Per inserire una immagine vado nella sezione upload ma vuole una nuova registrazione...la devo fare per forza?

Se metto il mio stesso account mi da errore,....bohhh!!?? :blink:

saluti

PS:con tutto quello che ho studiato mi sarò rincretinito...è possibile!! :(

Share this post


Link to post
Share on other sites
luciano

si la devi fare ma usa la stessa username e la stessa password che dai ora

ciao

Share this post


Link to post
Share on other sites
Pablo78

ecco qua il programmatore che uso io

con una piccola aggiunta, a me funziona....vediamo se me la spirugghio a mandare l'immagine.Programmatore_ok.JPG

Speriamo bene!!! ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...